Issue 93638

Summary: Copying of paragraph with page-break property changed behaviour from 2.4.1 to 3.0
Product: Writer Reporter: max.odendahl
Component: codeAssignee: Oliver Specht <os_ooo>
Status: CLOSED WONT_FIX QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: DEV300m31Keywords: regression
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
bug doc created in Word 2000
none
sample native document, with no notes none

Description max.odendahl 2008-09-08 23:15:31 UTC
- load attached document
- copy the note, e.g. by doing Ctrl-A, Ctrl-C
- leave selection, hit enter for a new line
- paste 

-> not only the selection including the note is inserted into the document, but
a page break as well

mod->cmc: any idea? this does not seems to happen with new notes, only with the
imported note, .doc- file was created in Word 2000
Comment 1 max.odendahl 2008-09-08 23:16:09 UTC
Created attachment 56337 [details]
bug doc created in Word 2000
Comment 2 caolanm 2008-09-09 11:50:07 UTC
I'll build up m31 to check this, but it might not be related to the comment, but
related to the (hopefully unchanged in the filter, and perhaps changed in
cut-and-paste) page-break-before property of the first paragraph.
Comment 3 caolanm 2008-09-10 09:05:55 UTC
Yeah, its a generic thing. See the next attached .odt. In 2.4.1 copying a
paragraph with page-break before in this situation would create a new paragraph
*without* the page-break before property. While in 3.0 and in DEV300_m31 the
page-break before gets copied as well.

I don't know if the *old* behaviour was a bug in that the property got lost, or
if the old behaviour was a special desired case which has become lost.
Comment 4 caolanm 2008-09-10 09:06:35 UTC
Created attachment 56367 [details]
sample native document, with no notes
Comment 5 caolanm 2008-09-10 09:07:27 UTC
Not specific to notes, I'll return this to the pool of untriaged-bugs for qa to
decide if the old or new behaviour is the wrong one :-)
Comment 6 dtardon 2008-09-10 09:19:34 UTC
That property gets copied too if you copy only a portion of the paragraph--say
one word of it, or one character. I think only character properties should be
copied in that case--or am I wrong?
Comment 7 michael.ruess 2008-09-10 11:02:26 UTC
MRU->ES: that's true, see CMC's attachment. The page break was not copy/pasted
in OO 2.4.1. Did this change intentionally?
Comment 8 eric.savary 2008-09-10 13:40:29 UTC
@AMA: issue 90123 is the opposite of this one. Please have a look at both.
Comment 9 Oliver Specht 2008-11-17 18:36:18 UTC
*** Issue 96223 has been marked as a duplicate of this issue. ***
Comment 10 andreas.martens 2009-01-19 10:36:19 UTC
Due to our workload and resources (development as well as QA) I've to retarget
this issue to OOo3.2.
Comment 11 Mathias_Bauer 2009-02-02 13:34:37 UTC
Oliver, please take over
Comment 12 Oliver Specht 2009-09-30 09:30:28 UTC
Target changed to 3.x
Comment 13 Oliver Specht 2011-02-28 11:12:09 UTC
I could not find out when or where the handling has been changed. 
But it absolutely makes sense to handle the break attributes the same way as any paragraph attribute. 
You can always find usage scenarios that prefer either the new or the old behavior.