Issue 93830

Summary: Can't see page breaks in page break view in copied worksheet
Product: Calc Reporter: dgdrummin <dgdrummin>
Component: editingAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, rainerbielefeld_ooo_qa, tengle1
Version: OOo 3.0 RC1Keywords: oooqa
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Can't see page breaks in page break view in copied worksheets none

Description dgdrummin 2008-09-12 14:58:39 UTC
When you copy a worksheet and paste the info in a new worksheet within
the same document or create a new worksheet from the copied worksheet
the page break data does not appear in page break preview and is not
editable via drag and drop.
Comment 1 dgdrummin 2008-09-12 14:59:36 UTC
Created attachment 56476 [details]
Can't see page breaks in page break view in copied worksheets
Comment 2 Rainer Bielefeld 2008-09-12 17:45:55 UTC
I checked with "Ooo 3.0.0 RC1 Multilingual version German UI WIN XP: [OOO300m5
(Build9350)]" and can confirm the reported effect for "page_break_problem.ods",
but I am not able to reproduce the problem with an own new test document. So
UNCONFIRMED until further notice!

@dgdrummin
Please specify your OS and Platform!
Can you contribute a step by step instruction how to reproduce the problem with
a new document?
Comment 3 dgdrummin 2008-09-12 18:19:24 UTC
OS X 10.5.4 on MacBook Pro Core 2 Duo 2.4
Steps to issue:
- create a worksheet
- copy the entire worksheet by 1) selecting all or 2) copy worksheet from contextual menu
- paste in new worksheet within the same document
- page break preview shows entirely greyed out area with no page breaks
Notes: 
- Original worksheet page break preview works fine
- You can still add page breaks but you cannot see them in preview nor are they editable via drag and 
drop


Comment 4 Rainer Bielefeld 2008-09-12 19:35:39 UTC
Seems to be MAC specific, I can not reproduce the problem with WIN.
Comment 5 pluby 2008-09-13 18:46:14 UTC
rainerbielefeld,

I can reproduce this bug on Windows XP using OpenOffice.org 3.0 RC1 and the
attached document.

It seems strange that you cannot reproduce this bug when I see it on both
Windows and Mac OS X. Maybe the difference is that your Windows machine has
Microsoft Office installed and my Windows machine does not? 
Comment 6 Rainer Bielefeld 2008-09-14 10:11:22 UTC
@pluby
Reading my comment carefully you will see that I CAN reproduce the problem with
"page_break_problem.ods", but not with an own new document. 
Sow we need someone else who can reproduce that problem with an own new document
so that we can be sure that that problem does not only exist for that special
document or dgdrummin's Mac.
Comment 7 tengle1 2013-09-17 10:37:20 UTC
I was able to reproduce the bug using Windows 7 when attempting to copy a worksheet and paste the info in a new worksheet within the same document (I received the greyed out area with no page break), however when opening a new document all together, the copying and pasting of the info worked fine and the page break was present.