Issue 95753

Summary: Can't add misspelled word to dictionary of username contains national characters
Product: General Reporter: kpalagin <kpalagin>
Component: spell checkingAssignee: stefan.baltzer
Status: CLOSED DUPLICATE QA Contact: issues@lingucomponent <issues>
Severity: Trivial    
Priority: P3 CC: issues, jbf.faure
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: All   
OS: Windows, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description kpalagin 2008-11-01 22:46:00 UTC
Repro:
1. Using English Windows XP create (My Computer-right click, Manage, Local 
users and Groups, right click Users) new user with non-Latin characters in 
name.
2. Logon as that user, run Writer, type some misspelled word, right-click it - 
you do not get "Add" option in context menu.
3. Press Esc, F7 - you get spell-check dialog. Click "Add" button - you do not 
get dictionary choice.
Comment 1 kpalagin 2008-12-04 06:52:45 UTC
Any chance for 3.2?
Comment 2 klonos 2008-12-24 12:02:17 UTC
This is a known issue. It usually occurs if the username contains national
characters. Sometimes it happens if for some reason there is no standard.dic
file under the user profile.

For WinXP, standard.dic should be under:

	C:\Documents and Settings\[user_name]\Application
Data\OpenOffice.org\3\user\wordbook

The issue can be worked around if you place a copy of standard.dic from a
working installation (a user profile with Latin characters only, or from another
computer) under the above mentioned directory.
Comment 3 kpalagin 2009-02-07 19:47:16 UTC
Stefan,
please consider this issue for 3.2.

Thanks a lot for your attention.
WBR,
KP.
Comment 4 stefan.baltzer 2009-02-09 16:58:36 UTC
The symptom of "adding words to a dict" is just the tip of the iceberg. :-)
See issue 95628 ("UserLayer location defaults to boot drive if username contains
non ansi characters") for details.


*** This issue has been marked as a duplicate of 95628 ***
Comment 5 stefan.baltzer 2009-02-09 16:59:34 UTC
Closing duplicate issue.