Issue 95985

Summary: need column-, bar- and area-charts of xy-type too
Product: General Reporter: meywer <mey.wer>
Component: chartAssignee: spreadsheet <spreadsheet>
Status: CLOSED DUPLICATE QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: IngridvdM, issues
Version: 3.3.0 or older (OOo)   
Target Milestone: ---   
Hardware: PC   
OS: Linux, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
bad spacing (here even for line-chart)
none
better (line-chart again - hope you can imagine a column-chart with bars at the red points) none

Description meywer 2008-11-08 09:27:07 UTC
Unfortunately only for line-charts there is the possibility to use xy-type. When
you want to create column-charts, whose categories are numbers, lets say years,
and the years don't have constant interval, you get a chart, which doesn't show
very well the facts.
Even if you have categories, that aren't numbers, you may want to get different
gaps between the bars. Therefore it is necessary to add another feature beside
data and categories to control the gaps between the categories. If categories
are years, this new "axis range" could contain exactly the same data. 
For a column of string-categories one could assign another column of numbers to
control the spacing. 
If user wants to get same spaces, one doesn't need this new feature. (Make
todays behaviour default.)

See bad and better example in attachements...
Comment 1 meywer 2008-11-08 09:28:42 UTC
Created attachment 57785 [details]
bad spacing (here even for line-chart)
Comment 2 meywer 2008-11-08 09:30:47 UTC
Created attachment 57786 [details]
better (line-chart again - hope you can imagine a column-chart with bars at the red points)
Comment 3 IngridvdM 2009-09-03 09:55:04 UTC
Histogram charts are requested with issue 49971 already.
xy area charts are requested with issue 104749.
Thanks for the feature request anyhow!

*** This issue has been marked as a duplicate of 49971 ***
Comment 4 IngridvdM 2009-09-03 09:58:56 UTC
closed as duplicate