Issue 96225

Summary: Mouse pointer trapped in dialog window.
Product: General Reporter: peterkraus <peter.kraus>
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, peter.kraus
Version: OOO300m9   
Target Milestone: ---   
Hardware: PC (x86_64)   
OS: Linux, all   
URL: http://user.services.openoffice.org/en/forum/viewtopic.php?f=16&t=11424
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description peterkraus 2008-11-14 21:16:58 UTC
Hello,
when using OpenOffice 3.0 x86_64, there is an annoying behavior of mouse
pointer. Whenever I leave any dialog window (Options, Customize, OOo's
Open/Save), my mouse pointer is forced back to the middle of the window. 

Using Arch linux x86_64, Enlightenment DR17 WM.

When I set mouse pointer focus to "click to focus", the issue disappears. When I
set it back to either "pointer focus" or "sloppy focus", the issue appears.
The issue is not present on gnome open/close dialogs, but is on OOo open/close
dialogs.

I have attached thread on community forums, there is some information available...
Cheers,
Peter
Comment 1 romanhodek 2009-11-11 21:49:36 UTC
*** Issue 96225 has been confirmed by votes. ***
Comment 2 romanhodek 2009-11-11 21:58:08 UTC
I can confirm this (really quite annoying) behaviour on 4 machines, and for two
different users. In all cases, the environment is Debian and Enlightenment E17
as window manager. Three hosts are x86_64, the last one a 32 bit machine, so
architecture probably isn't the cause.
Comment 3 manns 2010-02-28 15:24:15 UTC
I can confirm this behavior using Debian and E17. It is more than just annoying.
It breaks usage when working in parallel windows and using e.g. the search dialog.
Comment 4 manns 2010-03-06 16:11:53 UTC
Please update the Platform to any, since the bug is present on AMD64 and on x86
as well as on ia64.

Furthermore, the OOO version could be updated to v. 3.2.0.