Issue 96594

Summary: MSOffice file association
Product: Installation Reporter: siewsy <siew>
Component: codeAssignee: Olaf Felka <olaf-openoffice>
Status: CLOSED FIXED QA Contact: issues@installation <issues>
Severity: Trivial    
Priority: P3 CC: andre.schnabel, cno, dirk.voelzke, emerson.prado.eng, issues, jbf.faure, nesshof, thomas.lendo
Version: OOo 3.0   
Target Milestone: OOo 3.3   
Hardware: All   
OS: Windows, all   
URL: http://specs.openoffice.org/installation/filetyperegistration/foreign_file_type_registration.odt
Issue Type: FEATURE Latest Confirmation in: ---
Developer Difficulty: ---

Description siewsy 2008-11-26 08:18:20 UTC
Please do reinstate the file associate feature in next new OpenOffice 3.x 
release, as I couldn't double click to open any MSOffice document in my PC.
Comment 1 Olaf Felka 2008-11-26 09:20:28 UTC
reassigned
Comment 2 thegurkha (Dave McKay) 2009-01-11 16:36:59 UTC
This is a must have. Check out the OO Community Forum and do a search for file
association - this is a very big issue with the users. 

If it worked the way it used to in 2.4.x where it asks if it should make the
file associations during the file installation that would be great. 

If it could also have an option to repair those associations if they get poached
by some other app, that would be even better.
Comment 3 bobban 2009-01-12 00:08:22 UTC
+1 on what thegurkha said.
Comment 4 abqbill 2009-01-12 17:46:50 UTC
Agreed, this capability must be restored. Issue
http://www.openoffice.org/issues/show_bug.cgi?id=89097 states the request to
skip the association step, and the comments following reinforce the community's
desire to restore this capability. It was not good to reduce the functionality
of the previous version in this regard.
Comment 5 ianmoz 2009-01-12 19:24:51 UTC
Had voted at issue 89097 but, as advised, this seems a better place to get this 
issue fixed. So to repeat ...

IMHO an app should NEVER change file assocs without first asking the user.

This is my first look at OOo and I specifically wanted to use OOo 3.0 to open 
MSOffice 2007 files on a laptop which did not have Office, but did have MS 
Works installed. Because I did not get the option during installation to select 
which file types to associate, now everything is hooked into OOo. Not too 
impressed!
Comment 6 mfurr 2009-02-02 14:12:44 UTC
I have around 50 users with Open Office on new laptops who cannot open MS Office
documents by double clicking because we rush deployed Oo3 assuming it would
behave the same way our testing with 2.4 did. The associations where not made
even though no MS Office install existed on the laptops. There is now no easy
way to repair them. The users are not happy and I don't have time to manually
edit the associations on all 50 laptops. This one issue may have put the process
of our organization switching away from MS Office in jeopardy.
Comment 7 aziem 2009-02-02 14:18:58 UTC
mfurr: Try to deploy the registry here which will give you file associations
http://wpkg.org/OpenOffice.org_3.x
Comment 8 abqbill 2009-02-02 16:57:51 UTC
In my opinion, mfurr should not have to do so because it was not necessary in
the past. It is my opinion that it is not good to remove a feature from a
product (in this case, the ability to establish Microsoft Office file
associations using the installer) without providing some other way to accomplish
what is needed.
Comment 9 phil_ 2009-02-02 17:13:20 UTC
@abqbill: Sure, I completely agree. It is exactly what this issue is about, and
I wonder that still no target is defined despite the fact that there are 39 votes.

However, I assume aziem proposed the solution not to resolve this issue, but
rather as a workaround to solve the problem of mfurr in a short time frame.
Comment 10 abqbill 2009-02-02 17:15:13 UTC
Hi phil_, agreed, modifying the registry apart from the OOo installer is only a
workaround until the OOo team fixes the installer.
Comment 11 mfurr 2009-02-02 21:04:13 UTC
Thanks for the reg file aziem, worked like a charm. I looked and looked for
something like that on the intertubes but I guess my google = fail this time.
This really seems like something that should be in the program so the average
user can control it.
Perhaps an extension could be thrown together in the interim that would provide
a simple checklist and registry edit like the installer did? Any programmers out
there?
Comment 12 eionmac 2009-02-04 21:43:48 UTC
This caused considerable embarrassment , when upgrading a user from 2.4 to 3 by
talking over phone.

Please allow association during instal
Comment 13 tschrock 2009-02-06 13:46:03 UTC
This has to be re-implemented.  Many PCs are shipping with a trial of MS Office,
which causes a default file association, so anything that skips the association
dialogue based on what is associated in the registry means that no association
with OpenOffice occurs.  I agree with the proposal to keep the dialogue, and
default the checkmark state based on the registry.
Comment 14 Olaf Felka 2009-02-06 13:54:40 UTC
@ fl: Should we think about a new strategy of the MSI setup behavior? Something
to discuss on the UX list?
Comment 15 dirk.voelzke 2009-02-06 14:19:51 UTC
We could add another checkbox (only one!) to the last installer page, which asks
if the setup should add a desktop link. Or we could add another page with 30 or
more boxes for all the different file types. Or ...
Definitely something to be discussed. One problem is that there are three
choices, to force registration for an extension, to register only, when not in
use and to not register at all. A checkbox has only two states. Perhaps
something like 'Force ...' or two boxes with 'register' and 'even when already
in use by some other application'
Comment 16 tschrock 2009-02-07 04:04:48 UTC
The issue to me is associating MS Office types or not, so that would be only two
states.  Returning to the previous way of associating would be an option as well.

However, if people want to associate by individual file extensions, something
along how the image viewing program Irfanview would work.  One button associates
all image formats with Irfanview, but one can check the individual components as
well.  That dialogue is also available from the options menu, which would also
be a nice feature in OpenOffice
Comment 17 thegurkha (Dave McKay) 2009-02-07 16:25:40 UTC
Excellent suggestion by tschrock.

A dialog showing all the possible associations that can be made, with an option
to say Yes/No to all of them, with the ability to deselect certain ones would be
perfect.
Comment 18 abqbill 2009-02-07 17:15:55 UTC
The installer should provide a declarative approach to modifying the machine. I
think the current 3.0 behavior of attempting to determine the user's (or
administrator's) intent is not preferred. Giving the user/administrator the
ability to declare an intent (whether to associate or not) is the
correct/preferred behavior.
Comment 19 anderssj 2009-02-13 20:38:40 UTC
I am a first time user of OOo and I found the behaviour totally weird and still
does not understand if the lack of file association should be considered a
feature or a bug. At least I expect the software to ask what I want to do...
Comment 20 willkil 2009-02-15 01:09:10 UTC
I disagree w/ the statement about 3 choices. There are only 2 states: make OOo
the *default* application or not. "Not register at all" doesn't make sense as a
choice. If there is not already an association for a given type, the checkbox
should default on. If there is an association already, the checkbox should be
off. But for *all* supported filetypes, OOo should associate as an *available*
application so that OOo at least appears under "Open With ->".

The normal user is installing the app to open the file types it supports.
Experts can completely dissociate the app from filetypes when listing the app
under "Open With ->". The current behavior already puts swriter under OpenWith,
so all we're asking for is a checkbox to make OOo the primary app for the filetype.

There definitely should be a checkbox for each filetype. I may want to keep MS
1st choice for .ppt but not OOo for .docx.

The UI doesn't really need to be in the installer. Tools->Options would be just
fine, but the UI needs to be somewhere or nontechnical users will be unable to fix.
Comment 21 abqbill 2009-02-15 05:45:41 UTC
Regarding the comment "The UI doesn't really need to be in the installer": This
may be problematic for those of us who rely on Windows Installer (MSI) features
(such as transforms or properties specified on a command line) to manage
application installations. My opinion is that it makes the most sense to provide
this capability from the installer. If this capability is not available in the
installer, it can make managing multiple OpenOffice.org installations more
difficult (unless the association management tool can change associations for
multiple machines over a network). Since the installer can already associate
Microsoft Office file types (as the 2.4 installer did), I think it makes the
most sense to simply restore this capability to the installer (and no doubt this
is also the simplest solution to implement).
Comment 22 wcwlgp3ozjd 2009-02-17 03:02:16 UTC
Workaround - involves reinstallation via "setup.exe", with special command line
parms.

Worked for me with version 3.0.1. I had installed MS Word Viewer, and it
hijacked handling of .doc files on me. I was running OO (Novell) 2.4.1 and
needed to upgrade anyway.

My first install of OO 3.0.1 didn't reclaim .doc file handling so I (IIRC)
uninstalled it, then did the following procedure:

- Launch the downloaded installer (OOo_3.0.1_Win32Intel_install_wJRE_en-US.exe)
and it begins by asking where to unpack the files, choose your folder and
proceed with the unpacking until it's done.

- Now cancel the installer.

- go to the folder you unpacked into and drop to the command prompt and execute
this command:
=-=-=-=-=-=-=-=-
setup.exe SELECT_WORD=1 SELECT_EXCEL=1 SELECT_POWERPOINT=1 REGISTER_ALL_MSO_TYPES=1
=-=-=-=-=-=-=-=-

(AIUI: the SELECT_WORD, etc parms work only for OO 2.4.x, and only
REGISTER_ALL_MSO_TYPES works for 3.0.x, but I put 'em all in just to be sure)

- Then just proceed with the install as normal.

Thx to OO developers for all your work, but removing control of file
associations at install time was, um, maybe not your best work  : )
Comment 23 dainsmail 2009-02-21 17:38:35 UTC
Yes, please give us an easy way to associate both Open Office and MS Office file
types to OOO. This is both essential for adoption and for the needs of a small
but growing population of Open Office users - the portable apps population. I
recently found that OOO had been made portable, so I can now carry both my data
and my apps from one computer to another. So moving to a new computer is a
matter of 1. copying over the portable apps, and 2. setting the file
associations, and I'm up and fully productive in about 5 minutes. 

The copying is easy, but the file associations are the annoying part, and it
would very very much help if I could set all of the Open Office associations
right from within the program. Also helpful would be the ability to set them
back to the original, but that's not an essential feature, just a nice touch for
when I have been borrowing a machine for some months and am handing it back.

Thanks for all of your hard work, and I hope this isn't difficult to put back in!
Comment 24 bpbeinlich 2009-02-21 20:24:48 UTC
Hi folks,

OO is a great effort, and I am a happy user.  But aside from that, this issue
now has 52 votes, it's been open since November, it seems that it mostly
involves putting a feature back in that was removed (hence it seems that it
would involve not much new code), and still there's no target release?   I
wanted to recommend OO to a friend this morning, but they're not that computer
savvy, and I couldn't see having them wind up without the file associations when
they finished installing it.  It definitely impedes my desire to recommend this
fine suite of software.  Can this get scheduled in?  Please?
Comment 25 abqbill 2009-02-22 00:03:51 UTC
Yes, this problem currently has 52 votes, and if you count the votes in
http://www.openoffice.org/issues/show_bug.cgi?id=89097, which has 13 votes, this
brings the total to 65 votes. (It would seem that 89097 should be closed as a
duplicate of this item.)
Comment 26 appierm 2009-02-22 00:26:33 UTC
I had previously voted at Issue 89097, but I was advised that I was
inadvertently voting for skipping the file association step.  I favor returning
the file association step to the installation process.
Comment 27 hagar_de_lest 2009-02-26 08:04:18 UTC
Issue 89097 is for another situation and is not a duplicate. The spirit of 89097
is to skip the file association but activating it automatically when there is no
MS Office on the machine. So if OOo detects that the user doesn't have MSO,
then, OOo should automatically open the .doc, ... files. Hence, just don't ask
the user about that. But if MSO is installed, then let the user chose and keep
asking him at OOo install.

Simply removing the option was a big mistake that hasn't answer anything (with
opposite consequences!).
Comment 28 hermanclaus 2009-03-02 11:49:28 UTC
Without the option to associate Open Office with standard .doc, .xls etc, and to
give the user the option under windows to use the 'new' command on right mouse
click, I cannot introduce OO in my organisation.

I admit the .odf seperiority, but compatibility is more important.
Comment 29 abqbill 2009-03-03 18:57:42 UTC
Hi hagar_de_lest, I agree that issue 89097 is not technically a duplicate of
this one. I still think it should be closed, however, since 89097 is the current
OOo Windows installer behavior -- it already works this way, hence it should be
closed. This issue was created to address the bad decision made in 89097.
Regards, Bill
Comment 30 bladeoflight16 2009-03-23 07:49:54 UTC
Basically, everyone who's commented in favor of restoring this functionality is
right. It's a matter of the user being able to control the program, instead of
the program making assumptions about what the user wants. In my book, assuming
that all users want some a program to behave in some specific way is often one
of the worst things software can do.

It seems to me that these are the basic requirements of what we need regarding
file associations:

-User must be able to control whether OpenOffice becomes the default application
-It must be possible to control this with the installer for silent installations
-The ability to control the file associations within the program itself, after
it's installed.

The last one isn't really a requirement, but it would be very useful to me and,
I suspect, other users. I much prefer OpenOffice, but occassionally someone I'm
submitting work to requires a Microsoft file. I love OpenOffice, but when you
need to draw pictures and do other out of the ordinary things, saving a .doc
file with OpenOffice just doesn't work. When that kind of situation arises, I'm
forced to install MS Office to do that work and save it. When I'm done, I like
to uninstall MS Office and get it off my system. Recently, this has left me with
no easy way to restore the file associations that I originally chose when
installing OpenOffice previously. I could uninstall/reinstall OO, but I'm
worried about losing settings and templates. For this sort of situation, where a
third party (a program or person) changes the file associations, it would be
very useful to be able to get OpenOffice to reclaim the associations without
having to deal with installers at all.

The following suggestion may sound weird and not feasible since I'm not versed
in how OpenOffice or MS installers work, but perhaps it might useful as a
starting point.

I suggest moving the actual code for claiming file associations into the
application itself. From there, users can manually control the associations at
any time.

This would seem to violate the requirement for silent installs, but is it
somehow possible to activate the program's code from inside the installer once
installation is otherwise complete? If so, dialogs could be placed in the
installer, and this could be saved as a setting and the associations could be
made by the actual application code.


In regards to how the dialog should work, I suggest a tree structure. A full
blown list of file extensions would be too confusing for many users, but if the
list were divided into a tree, then a user could select the top nodes (which
would be things like "Microsoft Office Files", "Microsoft Works Files", and
"Open Office Files") to select all the file types under that heading. The tree
could also be expanded so advanced users could control the file types
individually. Select All/Select None buttons would also be useful. The dialog
could be implemented this way in both the installer and the application.

Additionally, within the application itself, OpenOffice should have some kind of
button that makes it reclaim all its prompted file associations. It might be
useful to do something like Mozilla products do: when they open, they notify you
that the file associations its supposed to maintain have changed and prompts the
user whether or not to restore the associations. If that kind of behavior were
to be implemented, it should be possible to make it stop asking you (probably
where you control the file associations themselves). Of course, when you make it
stop asking, it does NOT restore those associations automatically; it does
nothing about them. Even if that kind of behavior is not implemented, though, I
would greatly appreciate some kind of mechanism to easily make OpenOffice
restore the file associations I told it to have since other programs (such as MS
Office) can steal them.

A tree-like structure also opens up some possibilities for silent installs.
There could be parameters for the tree headings (MS Office files, etc.), a
parameter for all file types, and a parameter for no file types; the installer
should also still be able to handle a list of individual file types somehow.
What the default behavior should be in this sort of design, I don't know. I'm
not directly exposed to that type of situation.

Thanks to all of you who spend your time making OpenOffice better. Hopefully,
you will find this helpful.
Comment 31 coila 2009-03-26 21:38:01 UTC
Why would you ever take this OPTION out?
Comment 32 phil_ 2009-03-27 08:33:24 UTC
@coila:
The old behaviour also created a lot of problems for people who do not
understand what file associations mean, so there definitely was a motivation.
Therefore just reinstating the old behaviour might not be the right solution either.
For further information, the following user discussion might be helpful:
http://user.services.openoffice.org/en/forum/viewtopic.php?t=11386
Comment 33 bernicl 2009-03-27 11:09:49 UTC
The choice of completly eliminate the possibility to change MSO file
association, to me has more downside that benefit. I cannot understand what's
wrong in setting the installer default behaviour as is now but let the user the
option to modify the associations to his needs. At least in the "Repair option".
The user that don't know what is doing will not modify the default settings,
while the others can tweak them without going mad.

Disappointed.

Cesare.
Comment 34 phil_ 2009-03-27 13:53:53 UTC
@bernicl:
I agree with you.

I am quite confident that there will be a good solution for this - so please
keep up hope!  :-)
I am just saying that it wouldn't be a solution to simply go back to the old state.
Comment 35 abqbill 2009-03-30 20:12:06 UTC
It appears it is possible to assign all Microsoft Office file types with OOo by
setting the REGISTER_ALL_MSO_TYPES property to 1 for the installer. Apparently,
it is also possible to select the file types you want to register with OOo by
setting the REGISTER_NO_MSO_TYPES property to 1 and then set individual
properties REGISTER_EXT (where EXT is an extension, e.g., DOC, DOCX, etc.) to 1.
The only reference to this appears to be in the German OOo wiki here:

http://www.ooowiki.de/InstallationUnterWindows?#WindowsInstaller

I have tested REGISTER_ALL_MSO_TYPES=1 with Office 2003 and it appears to work
properly. I have not yet tested REGISTER_NO_MSO_TYPES=1 and individual types.
This information needs be published in the official documentation.

Even though it is possible to configure via properties, I wonder if the dialog
should still be restored to the installer?
Comment 36 abqbill 2009-03-30 21:30:33 UTC
It appears it is possible to assign all Microsoft Office file types with OOo by
setting the REGISTER_ALL_MSO_TYPES property to 1 for the installer. Apparently,
it is also possible to select the file types you want to register with OOo by
setting the REGISTER_NO_MSO_TYPES property to 1 and then set individual
properties REGISTER_EXT (where EXT is an extension, e.g., DOC, DOCX, etc.) to 1.
The only reference to this appears to be in the German OOo wiki here:

http://www.ooowiki.de/InstallationUnterWindows?#WindowsInstaller

I have tested REGISTER_ALL_MSO_TYPES=1 with Office 2003 and it appears to work
properly. I have not yet tested REGISTER_NO_MSO_TYPES=1 and individual types.
This information needs be published in the official documentation.

Even though it is possible to configure via properties, I wonder if the dialog
should still be restored to the installer?
Comment 37 janavasseru 2009-04-29 00:19:58 UTC
I just want to say to you OO guys: "you made a classy piece of shit"
yeah right, if you want to make administrators life any harder, go on, kill OO 
completely. What you forcme to install OO in C:\Program Files\Openoshit.org 3 
do you realiaze, that there are at least 4 places where file association can be 
set, and do you realize that if any of theese points to a different location 
all is wrong?
HAVE YOU GUYS EVER WORKED IN A MIXED DOMAIN?
try a domain with few instalaltions of OO2 and OO3
I assure you that the problems i have to solve every day with OO file 
associations cost the company 2 times more than buying MS office ML (which btw 
is the next thing which will happen as soon as we get beter hw). 
Please notice that there are such people who need to take care of hundreds of 
DIFFERENT computers. I do not expect you to help such people but at least, 
don't cripple theirs job. BTW, Do you realize that there are thousands of 
people which have NO IDEA what a file association is? 

Yeah guys, if you want to kill OO, go on, you're on right track:
a) keep the dictionaries separate
b) keep the OO fucked up
c) annoy sysdamins to hell
d) give sysadmins at least twice as much of work
e) make it a little bit slower
f) make your own menus and file dialogs different from anything seen in the OS
g) ignore this bug for another year

Yes i know that this post does not follow any rules and i do not bother. I took 
quite a lot of time to register and write this post in (probably false) hope 
that there might be someone who'll notice that OO is slowly being killed - 
don't blame MS for that, it is solely your fault - i don't care which of these 
is better but OO is not easy to handle, i'm not going to lose my time with it 
any more. 
Feel free to delete this post, feel free to ban me, i don't care a bit, i just 
looked at my reports and discovered that i already spent 65.4 hours solving 
various problems with OO 3 (99% - file associations and dictionaries) this year 
only.
I was waiting for a solution since march 2008.

Regards,
 Jana
Comment 38 kramy 2009-04-29 01:12:14 UTC
Well Jana, hold your breath a little bit longer. Maybe things will change under
Oracle - maybe not. We'll see in the next few months.

I'm still holding my breath for a file associations dialog.

At least the 3.0.1 installer has REGISTER_ALL_MSO_TYPES :/
Comment 39 phil_ 2009-04-29 15:39:08 UTC
Dear Jana,

I can fully understand your frustration, I have also lost much time due to OOo.

However, I believe that an unobjective rant about the problems will not help much.

Also, keep in mind that this software is free. Nobody has forced you to use it.
If you do not like it, just use a different product.

Kind regards,
phil
Comment 40 frank.loehmann 2009-04-29 16:54:22 UTC
OOo just wants to be a good citizen on Windows by not hijacking already
registered foreign file format extensions. XP/Vista allows to change the file
type file type association. Vista even offers a dedicated application for this.

FL->OF: Please verify that the current behavior (OOo 3.0/3.0.1/3.1) regarding
MSO file type association really works as defined in [1]. It seems to me that
OOo does not register to MSO file types even if no MS Office is installed on the
system. Also all MSO file type associations made by a prior version of OOo/SO
should have been registered to the newly installed OOo 3.x according to [1].

[1] 
http://specs.openoffice.org/installation/filetyperegistration/foreign_file_type_registration.odt
Comment 41 bernicl 2009-04-30 07:11:12 UTC
Hi fl.

Many of us has understood the rationale behind the spec, but what consider
frustrating is that an useful interface was removed leaving the users on your
own. If the choises done by setup are not what the user wants, then he is leaved
alone.
The spec cite an msi option but:
- it is a all or nothing option (i cannot associate, for example, only the
PowerPoint extensions);
- it is a hidden option (i have to know about that);
- it gives no feedback (will i have written it correctly?);
- it is frustrating because i have to understand where and how to put that option.

If you are worried about the user who associate the MSO options without knowing
what they are doing, why not to put out that choice from the default setup path
(for example under a "Change file association..." button) or, at least, render
the previous useful and already working interface, visible when i do a repair or
modify setup?

Kind regards.

Cesare.
Comment 42 rpremuz 2009-04-30 13:03:52 UTC
Hi, fl!
I'd say that current OOo 3 setup really works as defined in [1].

I had problems with MSO file type associations when MSO viewers had
been installed in Windows. In that case OOo 3 setup doesn't associate
the MSO file types with OOo applications, which doesn't make sense
because the viewers should always be regarded as inferior to the
editing applications of OOo.

(The viewers may be useful if you have a MSO document that is broken
when opened in OOo and you just want to view/print the document.)

-- rpr.
Comment 43 abqbill 2009-04-30 21:24:05 UTC
Hi Cesare, if the German documentation in

http://www.ooowiki.de/InstallationUnterWindows?#WindowsInstaller

is correct, then you can set the REGISTER_NO_MSO_TYPES property to 1 and then
set individual properties REGISTER_EXT (where EXT is an extension, e.g., DOC,
DOCX, etc.) to 1 to configure individual individual MS Office associations.

Regards, Bill
Comment 44 Olaf Felka 2009-05-04 10:52:22 UTC
I've installed OOo 3.1 RC2 on a XP with MSO 2007 and on a system without MSO. On
a the system without MSO all MS file types have been assigned to OOo. On the
system with MSO all file types have been assigned to MSO stayed assigned to MSO.
OOo isn't hijacking and file types.
Even after updating OOo 3.0.1 to OOo 3.1 all mime types are kept as before.

I don't know if we can tell wether MSO file types are assigned to an office or a
viewer.
I think that a simple solution can be a 'assign them all' switch at installation
time. Offering checkboxes for all Office applications and all MS file types
(doc, dot, docx, dotx a.s.o.) would be just confusing.
Comment 45 frank.loehmann 2009-05-14 13:00:12 UTC
FL->OF: Thanks for testing!

So we do not really know why this causes all the problems described above. I
think we should go as proposed to add a simple option to the custom setup
section only. So we would bring the command line switch to the interface, but no
Word or Excel only switches anymore. If checked OOo forces registration if
unchecked OOo registers only for currently unregistered MSO file types.

I have updated the spec.:
http://specs.openoffice.org/installation/filetyperegistration/foreign_file_type_registration.odt
Comment 46 abqbill 2009-05-14 21:40:13 UTC
Hi FL, the updated spec seems eminently reasonable. This will be entirely
suitable for advanced users that want more control and also for system
administrators that want to coerce the installer to register the MS office types.
Comment 47 bernicl 2009-05-14 23:16:52 UTC
Hi FL.
The updated spec seems to address the most common cases and it's clearly better
than now.
But what i really cannot understand is why you are cutting out a working and a
more precise functionality to a limited one.

At work we have some Win2000 PCs that we are trying to switch to OpenOffice.
Initially i've installed OOo side by side, leaving untouched the file
associations to MSO97 and keeping free the user to test OOo. After some time
i've switched the file associations to OOo to see how they feel. Some of them
asked me to switch back to Excel because some feature they use works better.

With the new spec i can only switch back *ALL* the file association to MSO (or
change file associations manually), while now i can only proceed manually and
before 3.x we can tweak every single association, restoring Excel association
and leaving all the rest to OOo.

To me the differences between 2.x and the updated spec are a reduction in
flexibility with apparent no real advantage.
Comment 48 abqbill 2009-05-15 15:45:31 UTC
Hi bernicl, can't your scenario can be accomplished by manually setting the
needed MSI properties (using either the command-line or a transform)?

FL, can we get the correct properties documented in the Windows installation
documentation?
Comment 49 thegurkha (Dave McKay) 2009-09-09 17:31:57 UTC
The sad truth is that a command line option will be no use for most users. A lot
of them won't discover it and others will be too confused to use it, or use it
incorrectly. 

IMHO there should be an interface to set this like in any number of other
programs. They present a list of common extensions and offer options to
'associate all', 'clear all associations' and checkbox to allow you to select
the ones you wish to have associated. 

Simple, effective and well-established in the software world as a mechanism that
'works' for most users.
Comment 50 dirk.voelzke 2009-10-01 14:39:10 UTC
Accepted.
Comment 51 rorrison 2009-11-23 07:56:07 UTC
I'm finding my use case very difficult: I have both OpenOffice.org and Microsoft
Office (2003) installed on my PC (WindowsXP).  I WANT to use OOo as my primary
office suite, I want the double-click action to be to open with OOo whenever
possible.  I want to be able to install OOo and just have it work, and keep working.

I used the REGISTER_ALL_MSO_TYPES command-line setup option (undocumented except
in this bug and on the German Wiki, as far I can find) when I installed OOo and
it was ok for a while, but MSO hijacked the file associations when downloading
some update, and REGISTER_ALL_MSO_TYPES doesn't seem to be working for me now
with either a Repair or Modify setup run.  Some day I'll bite the bullet and
uninstall OOo and then reinstall it again with REGISTER_ALL_MSO_TYPES, but that
is NOT acceptable in the long term.  It's pretty common for Windows apps to
check whether their file associations are set and if not, ask if you want them
to be.  Couldn't we do that?

Honestly, I get the impression that OOo doesn't want to be used as the default
office suite.  It's like it's saying "Oh, you've got Microsoft Office.  Ok, I'll
just go sit quietly in the corner here.  You don't really want me."  Come on, be
more assertive!  If someone installs OOo, they want to use it!  In most cases,
MSO is there by default and its presence can be ignored; installing OOo is a
choice that should be respected.
Comment 52 dirk.voelzke 2009-11-27 10:10:33 UTC
I've added the register for Microsoft File Types setup page again, but it will
only be visible while performing a custom setup.
Btw. starting with Windows Vista you should change the default file associations
via 'Start Menu / Default Programs / ...'
Comment 53 dirk.voelzke 2009-11-27 10:12:10 UTC
Changed target.
Comment 54 bernicl 2009-11-27 11:32:11 UTC
@dv: very very very appreciated. Thank you very much!
Comment 55 dirk.voelzke 2009-11-27 13:12:54 UTC
Please verify.
Comment 56 Olaf Felka 2009-12-03 12:10:13 UTC
of: The current behavior on new XP VMWare image:
Before installing the cws no MS file types are assigned (except .doc to
wordpad). Starting the setup the MS file type dialog has no check marks for
these file types. Expected: The file types should be checked.
Installing the cws, the MS filetypes are assigned to OOo. Expected: No check
marks for MS file types -> no assigning to OOo.
Comment 57 Olaf Felka 2009-12-03 12:18:25 UTC
reassigned
Comment 58 dirk.voelzke 2009-12-04 10:14:56 UTC
Forgot to build a module.
Comment 59 dirk.voelzke 2009-12-04 10:29:09 UTC
Please verify.
Comment 60 Olaf Felka 2010-02-01 07:05:03 UTC
*** Issue 108803 has been marked as a duplicate of this issue. ***
Comment 61 Raphael Bircher 2010-02-05 01:30:02 UTC
*** Issue 108966 has been marked as a duplicate of this issue. ***
Comment 62 Raphael Bircher 2010-02-05 01:33:23 UTC
*** Issue 100729 has been marked as a duplicate of this issue. ***
Comment 63 jwf_usa 2010-02-05 05:50:35 UTC
sure would be great if this could make it into OOo 3.2 and not have to frustrate
some new users.
Comment 64 ramcleod 2010-03-17 12:51:35 UTC
The inability of OpenOffice to override Microsoft Office default associations
makes it almost impossible to recommend to any user, personal or corporate.

All computers my organisation has procured over the last 12 months have come
with 'trial versions' of Microsoft Office, which - even once uninstalled - leave
default associations to Microsoft Office.  OpenOffice is effectively useless on
these computers without much tiresome additional work.

I was about to roll out Open Office to a corporate laptop fleet, but now I am
going to explore options for getting cheap Microsoft Office licences instead: My
staff's time compensating for the inadequacies of OpenOffice is more valuable
than the cost of Microsoft Office licences.

Sort this out or you will lose more potential users.
Comment 65 Olaf Felka 2010-03-25 12:09:14 UTC
OF Verified in cws installer10. We have followup issue 110382. I don't see this
issue as critical that we must have a fix in this cws.
Comment 67 rorrison 2010-03-25 13:18:27 UTC
I didn't see a way to comment on the test case directly, but CSV should be added
to the list of Excel file types.
Comment 68 Olaf Felka 2010-03-25 14:08:56 UTC
CSV is not on the list documents that defaults to OOo.  So it's not in the
testcase. This will be a new wish for enhancement.
Comment 69 bernicl 2010-03-25 14:18:07 UTC
I've just installed "OOo-Dev_DEV300_m75_Win32Intel_install_en-US.exe", under
Win2000Pro SP4, with MSO2000 and file extension assigned to MSO.
I've run custom setup but i cannot see any dialog where i can set file
association, as described in:
http://quaste.services.openoffice.org/index.php?option=com_tcs&task=tcs_show&tcsid=3112
Nor i can see any file type dialog if i choose "modify" on the already installed
OOo.
Comment 70 Olaf Felka 2010-03-25 14:30:03 UTC
Read this issue carefully (ok, there's a lot to read :-)). This feature is not
in the master yet but in a child work space and will be integrated soon.
.
Comment 71 bernicl 2010-03-25 14:39:47 UTC
Ah sorry. Issue #110382 talk about DEV300m63, so i tought it was already
available in dev. Thank you, i'll wait for intergration.
Comment 72 craaaaig 2010-07-04 07:40:32 UTC
Please make file association configuration easily accessible to users. A pick
list in Options | File  Associations would be fine. We need to be able to select
from each of the MSO filetypes; limiting this to an all or nothing choice would
be frustrating - out here in working world we're still evaluating Oo against
MSO. Crippling the ability to easily switch back and forth works against Oo. Thanks.
Comment 73 Olaf Felka 2010-07-05 06:43:39 UTC
In dev300_m84 you can select the mime types at installation time.
Comment 74 rorrison 2010-07-05 14:35:49 UTC
So if Microsoft Office usurps its file associations (as it does when an update
is applied) the answer for OpenOffice users is to reinstall?

(This is an issue for people, like me, who have both installed.)

As was said in comment #2: "If it could also have an option to repair those
associations if they get poached by some other app, that would be even better."
Comment 75 bernicl 2010-07-06 06:55:37 UTC
JFY: i've just tried dev300_m84 under Win2000 and the MS Office file association
are settable again. As per spec, they are changeable only in custom installation
and under the "modify" installation. Thanks of!
For the rest i can't see other differences with OOo-2.4.x.

Thank you for reintroducing this functionality and let's wait for OOo 3.3!
Comment 76 dirk.voelzke 2010-07-06 07:22:39 UTC
Hi,
using Windows Vista or Windows 7, you can use 'Windows Start Menu/Default
Programs/Set your program defaults' to control the file associations, and you
can change the default program in the property page of a document for all
documents of this kind (this works with Windows XP, too). Do you really need
another way in OpenOffice.org to change these settings. I don't think so.
Dirk
Comment 77 grillon 2010-07-12 15:39:07 UTC
I do. I don't use XP, Vista or 7 - I use 2000 instead.
I don't think we should rely on OS to be able to change associations. Some OSs
permit that, some don't, and some may not do it correctly. So, IMHO, having this
option available in OOo is the safe choice.
BTW, if OOo is in charge of associations, it can also be set (option) to check
it at every start, as many other apps do. So, if another office suite (guess
which) steals associations, OOo gets it back when used again, at user's will.
In short: making associations settings available inside OOo is safe, comfortable
and useful.
Best regards.
Comment 78 littledoe64 2010-07-27 06:17:48 UTC
What do I need to do to fix OpenOffice 3.2? I can not uninstall it from my 
computer because it has missing components.   
Comment 79 emersonprado 2010-11-19 17:57:10 UTC
Summing up ideas in order to suggest a target behaviour, replacing the proposed
one (which seems to me hard for average users). Or we could use the old behaviour.

IMHO, an user-friendly way to change associations inside the suite is critically
needed for these reasons:
1.Associations may fail during installation for whatever reason (as happened to me)
2.Apps may hijack associations (as M$O does)
3.Users may change minds (as everyone do)
So, regardless of having or not options during install (or first use, so
installation can be silent), we must have them inside the program to correct as
needed.

Besides, I think the options should not be just "all" or "none", by the reasons
already exposed enough. I see the best option as having one checkbox for each
file format, then buttons for "None", "Only OD", "Only unregistered" and "All".
So it'd be easy to achieve every situation mentioned here.
Sure, with an user-friendly expanation for those options, what is not hard at all.

Plus, an option to restore associations at startup. Just in case some other app
hijack them.

BTW: this is not limited to Windows. I have just moved to Linux (Mint Debian)
and faced the same problem. Here in Brasil we use BrOffice instead, so I
uninstalled OOo and installed BrOo. Open Document files are associated, but M$O
files aren't.