Issue 97296

Summary: Impress crashed: Click Custom Animation pan after canceling ' Edit File ' in Standard bar
Product: Impress Reporter: amy2008 <amy2008>
Component: codeAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, ooo.redflag, peter.junge
Version: DEV300m37   
Target Milestone: OOo 3.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description amy2008 2008-12-16 03:40:30 UTC
Can reproduce it in Impress with DEV300m37 on WinXP and Ubuntu

How to reproduce it
1 Create a new Impress document
2 Switch to 'Slide Sorter' view, Save the new file as test.odp
3 After step2, you can find that 'Edit File' button in Standard bar is active.
  click 'Edit File' button, test.odp becomes read-only file. Then, click the
  'Edit File' button once more to cause test.odp to become compiled
4 Subsequently, click Custom Animation pan

Result
OOo crashed

Expectation
OOo works well

Li Meiying
Comment 1 wolframgarten 2008-12-16 08:26:41 UTC
Reproducible. Reassigned.
Comment 2 groucho266 2009-01-12 13:19:48 UTC
In DrawController::getCurrentPage() the WeakReference mpCurrentPage was checked
for validity with the wrong method.  Maybe because the WeakReference was
introduced after the DrawController code was written.

Fixed by using WeakReference<>::is() to check the pointer.

Modified file is /sd/source/ui/unoidl/DrawController.cxx rev. 266156.
Comment 3 groucho266 2009-01-20 09:59:09 UTC
@WG: Please verify.
Comment 4 wolframgarten 2009-01-26 15:08:15 UTC
Verified in CWS.
Comment 5 wolframgarten 2009-02-17 08:41:13 UTC
'Tested in OOO310_m1. Closed.