Issue 97478

Summary: Crash when "Increase Spacing" on demoted text
Product: Impress Reporter: doze_worm <zhuangyuelin>
Component: codeAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P2 CC: issues, kpalagin, peter.junge
Version: OOO300m9Keywords: crash
Target Milestone: OOo 3.1   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description doze_worm 2008-12-22 08:41:38 UTC
[Steps]
1. Create a Impress doc.
2. Select "Title, Text" from "Layouts" bar, type some words in text region in
the slide. Switch the View Mode to Outline, put the cursor at the text, keep
pressing "Demote" button at the "Text Formatting" bar until the "Demote" button
become gray.
3. Left-click the dorp-menu at the right-side of the "Text Formating" bar,
"Visual Buttons" -> "Increase Spacing", to show up the "Increase Spacing" button.
4. Switch the View Mode back to Normal, put the cursor at the text, left-click
"Increate Spacing" button on the "Text Formating" bar.

[Result]
Crash and quit

[Expectedness]
Set the space of text correctly.

[Addition]
In step 3,4, "Decreasing Spacing" has the same result.
Comment 1 kpalagin 2008-12-26 13:48:17 UTC
Confirming with m37 on WinXP - as described.
Comment 2 amy2008 2008-12-31 02:28:48 UTC
CC
Comment 3 wolframgarten 2009-01-05 14:12:05 UTC
Reproducible. Reassigned.
Comment 4 groucho266 2009-01-19 12:53:43 UTC
Crashed in sd/source/ui/view/drtxtob1 when handling SID_PARASPACE_(DE|IN)CREASE
slots when a style sheet was missing.

Fixed by checking the existence of the style sheet.

This does not fix the root cause that leads to the style sheet being missing.
Comment 5 groucho266 2009-01-21 12:17:17 UTC
@WG: Please verify.
Comment 6 wolframgarten 2009-01-26 14:50:48 UTC
Verified in CWS.
Comment 7 wolframgarten 2009-02-16 16:55:35 UTC
Tested in OOO310_m1. Closed.