Issue 97567

Summary: Export as PDF under Page Preview and Reload writer file crashes OOo
Product: Writer Reporter: amy2008 <amy2008>
Component: codeAssignee: stefan.baltzer
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: issues, jbf.faure, ooo.redflag, peter.junge, stefan.baltzer
Version: DEV300m37   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description amy2008 2008-12-25 03:40:43 UTC
Can reproduce it with DEV300m37 on WinXP and Fedora

How to reproduce it
1 Open a new Writer document, enter some characters 'testing' and save as t1.odt
2 Click 'Page Preview ', then 'Export Directly as PDF' to export t1.odt as pdf 
  file
3 File - Reload, 'Cancel all changes?' - Yes

Result
OOo crashes

Expectation
Reload successfully

Regards
Li Meiying
Comment 1 jbf.faure 2008-12-31 16:39:56 UTC
I reproduce the crash on OOo 3.0.1 RC1 FR (OOO300_m14) under Ubuntu 8.04.

Regards
JBF
Comment 2 h.ilter 2009-01-06 09:32:55 UTC
Report ID: ru7g8vc
Comment 3 frank.meies 2009-01-14 08:23:02 UTC
Please have a look.
Comment 4 Oliver Specht 2009-01-14 09:15:10 UTC
Reassigned to cd
The stack looks like this:

014af368 5efca6db sfxmi!SfxBindings::LeaveRegistrations+0xc
[o:\ooo300\src.m9\sfx2\source\control\bindings.cxx @ 2334]
014af8f4 5efcc183 sfxmi!SfxViewFrame::ExecReload_Impl+0x19e7
[o:\ooo300\src.m9\sfx2\source\view\viewfrm.cxx @ 857]
014af900 5efdc585 sfxmi!SfxStubSfxViewFrameExecReload_Impl+0xe
[o:\ooo300\src.m9\sfx2\wntmsci12.pro\inc\sfxslots.hxx @ 453]
014af9d4 5efdf366 sfxmi!SfxDispatcher::Call_Impl+0x3ff
[o:\ooo300\src.m9\sfx2\source\control\dispatch.cxx @ 306]
014afa50 5efdf285 sfxmi!SfxDispatcher::PostMsgHandler+0xdf
[o:\ooo300\src.m9\sfx2\source\control\dispatch.cxx @ 1619]
014afa5c 5c7310af sfxmi!SfxDispatcher::LinkStubPostMsgHandler+0xe
[o:\ooo300\src.m9\sfx2\source\control\dispatch.cxx @ 1579]
014afa6c 5efff4b9 tlmi!Link::Call+0x11
[o:\ooo300\src.m9\tools\inc\tools\link.hxx @ 142]
014afa7c 5efff4d6 sfxmi!SfxHintPoster::DoEvent_Impl+0xe
[o:\ooo300\src.m9\sfx2\source\notify\hintpost.cxx @ 84]
014afa88 5c7310af sfxmi!SfxHintPoster::LinkStubDoEvent_Impl+0xe
[o:\ooo300\src.m9\sfx2\source\notify\hintpost.cxx @ 87]
014afa98 5bd79ab9 tlmi!Link::Call+0x11
[o:\ooo300\src.m9\tools\inc\tools\link.hxx @ 142]
014afaa0 5bd7abb2 vclmi!ImplHandleUserEvent+0x46
[o:\ooo300\src.m9\vcl\source\window\winproc.cxx @ 1999]
014afafc 5bc5aed1 vclmi!ImplWindowFrameProc+0x2cc
[o:\ooo300\src.m9\vcl\source\window\winproc.cxx @ 2499]
014afb14 5bdbe195 vclmi!SalFrame::CallCallback+0x16
[o:\ooo300\src.m9\vcl\inc\vcl\salframe.hxx @ 286]
014afb24 5bdc3e76 vclmi!ImplHandleUserEvent+0x24
[o:\ooo300\src.m9\vcl\win\source\window\salframe.cxx @ 4503]
014afb64 5bdc4088 vclmi!SalFrameWndProc+0x714
[o:\ooo300\src.m9\vcl\win\source\window\salframe.cxx @ 6047]
014afbb0 7e368734 vclmi!SalFrameWndProcW+0x30
[o:\ooo300\src.m9\vcl\win\source\window\salframe.cxx @ 6204]
Comment 5 carsten.driesner 2009-01-27 13:41:53 UTC
We are short before code freeze for OOo 3.1. As time is running out I have to
shift this issue to 3.2.
Comment 6 carsten.driesner 2009-09-15 09:34:05 UTC
cd: Due to missing time I have to shift this issue to the next release.

If one think that this is an important issue then please raise it as a
showstopper. It can also be set to OOo 3.2.1 as soon as this target is available.
Comment 7 carsten.driesner 2010-05-31 16:20:53 UTC
cd->sba: I am not able to reproduce this problem on DEV300m79. Could you please
have a look.
Comment 8 stefan.baltzer 2010-08-20 12:03:39 UTC
Can not reproduce in OOO330_m4 (tested on WindowsXP and Fedora).
Set to Worksforme.
Comment 9 stefan.baltzer 2010-08-20 12:04:30 UTC
Closing issue as worksforme.