Issue 97574

Summary: Under a table, insert a .doc file with OLE object, then undo lead a crash
Product: Writer Reporter: doze_worm <zhuangyuelin>
Component: codeAssignee: writerneedsconfirm <swneedsconfirm>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P2 CC: amy2008, issues, kpalagin, ooo.redflag, peter.junge
Version: OOO300m9Keywords: crash
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description doze_worm 2008-12-25 06:53:15 UTC
[Steps]
1. Create a write doc, "Insert -> Object -> OLE Object", just click OK button on
the "Insert OLE Object" dialogbox.
2. save the doc file as the type of "Microsoft Word 97/2000/XP"
3. Create a write doc, "Ctrl + F12" to insert a table, put the cursor beneath
the table, "Insert -> File...", select the file that saved in step 2.
4. Press "Undo" button, the insert file doesn't disappear. Press "Undo" again.

[Result]
Crash and quit

[Expectation]
Undo successfully
Comment 1 kpalagin 2008-12-26 12:34:30 UTC
Confirming with m37 on WinXP - as described.
Upping priority, "crash" keyword.
Comment 2 amy2008 2008-12-31 02:35:24 UTC
CC
Comment 3 michael.ruess 2009-01-05 14:15:02 UTC
Same problem as issue 97570.

*** This issue has been marked as a duplicate of 97570 ***
Comment 4 michael.ruess 2009-01-05 14:17:59 UTC
Closing duplicate.