Issue 97664

Summary: scandinavic vowels 'ä', 'å' & 'ö' in folder or file name crash OOo
Product: General Reporter: mukhin <kirill.muhin>
Component: uiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P2 CC: issues, maho.nakata
Version: OOo 3.0   
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description mukhin 2008-12-30 13:57:12 UTC
I'm very pleased with new version, except:

Since downloaded OOo 3.0 it went down every time I've tried to open a file (or
file from a folder) which name consists scandinavic vowels 'ä', 'å' and 'ö'.

It's pretty irritating because of common use of letters in scandinavic and
particularly in my case in finnish language.

Keep up a great work!
Comment 1 robg 2009-01-16 20:52:21 UTC
Seems to work fine for me under OS X 10.5.2 with 3.0 build 3958; tested both
saving a file to an existing folder to scandi chars, creating a new folder with
them and opening files from new + existing folders.

Any specific component / file format in play? Because I only tried odt

Comment 2 robg 2009-01-16 20:57:06 UTC
I'd like to add: I have a pretty fresh OS X + OOo installation with not too much
tinkering around, perhaps it's as someone mentioned elsewhere, related to other

*scratches head*

Comment 3 mukhin 2009-01-18 19:44:43 UTC

I have OS X 10.5.6
Every time I try to save with ä,ö,å in file name, OOo changes the names 

'ä' to %E4
'ö' to %E5
'å' to %E6

and rejects to open them: starts OOo Document Recovery over and over without any

When changing a file name back to ö,ä,å and try to open then, OOo shows an
error: '"filename" does not exist.'. Error is shown each time twice.

When trying to save to a folder with ö,ä,å, there appears another folder
straight just behind the first, where letters are changed to o,a,a and question
marks, as "täynnä" shows like 'ta?ynna?'

I've freshly installed OS X on december 23. and OOo installed on top. The first
time I've noticed the problem was right away.

I've downloaded the US English -version. Might there be a problem with that?

- Kirill
Comment 4 mukhin 2009-01-18 19:55:33 UTC
Oh, and it works (or doesn't work) the same with .odt and .odb, others haven't
tried yet.

- Kirill
Comment 5 pekkasiponen 2009-02-08 13:53:24 UTC
the äöå characters seem to work fine on my Mac OS 10.4.11 and OpenOffice 3.0.1
Comment 6 philipp.lohmann 2009-03-13 15:28:43 UTC
cannot reproduce that on 10.5.6 (english OOo version, tried with ä and ö
letters, both with native and OOo file dialog). Since it does not seem to be
that easy to reproduce, I'll lessen the prio somewhat.
Comment 7 Rob Weir 2013-07-30 02:21:47 UTC
Reset assignee on issues not touched by assignee in more than 2000 days.