Issue 9776

Summary: Improve overall presentation of comments in Navigator
Product: Writer Reporter: temcat <temcat>
Component: codeAssignee: max.odendahl
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOo 1.0.0   
Target Milestone: ---   
Hardware: All   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description temcat 2002-12-02 22:34:55 UTC
Besides the question of word-wrapping discussed by me in the issue 9775, I would
suggest reviewing the overall presentation of comments in the Navigator. I
imagine the following structure here:

[AV1] This is a comment, and it is
      conveniently wrapped to the
      window so that I can easily 
      read it.
[BG2] Never ever use this evil
      program, get back to my 
      wonderful world of Micro$oft!

Note the use of authors' initials (if you show the whole comment here, why not
show its author? this is one strange thing about the Navigator right now.)

Alternatively, if one uses full names of the authors (as I suggested in issue
9774), it might even look like this:

[1]  <bold>Artem Vakhitov:</bold> 
     This is a comment, and it is
     conveniently wrapped to the
     window so that I can easily 
     read it.
[2]  <bold>Bill Gates:</bold>
     Never ever use this evil
     program, get back to my
     wonderful world of
     Micro$oft!

And if comments are assigned to a range of text as I suggested in issue 9773,
the commented text (instead of the comment itself) can be displayed in the
yellow box that shows up in the Navigator when you bring the cursor over a comment.

Thank you for your attention,
Artem Vakhitov
Comment 1 h.ilter 2002-12-06 12:55:54 UTC
Reassigned to FT
Comment 2 eric.savary 2003-04-16 15:45:06 UTC
Set to "NEW"
Comment 3 eric.savary 2003-04-16 15:45:42 UTC
Set to "NEW"
Comment 4 falko.tesch 2003-10-15 13:31:47 UTC
Comments or notes?
Comment 5 temcat 2003-10-15 14:00:07 UTC
Comments or notes, I don't know the exact English term, but it's the
thing that has icon looking like a sheet of paper with an arrow
pointing to it, and not that with the "pin" icon.
Comment 6 temcat 2003-10-22 17:56:25 UTC
It's notes, now I know.
Comment 8 Mathias_Bauer 2007-05-05 14:20:18 UTC
assigned to mod
Comment 9 eric.savary 2007-06-15 14:06:05 UTC
Just correcting some flags in this issue.
Comment 10 eric.savary 2008-02-05 19:02:39 UTC
I'm writing "Notes2" to make this issue appear in a query.
Comment 11 max.odendahl 2009-07-20 05:23:35 UTC
dup of 23181

*** This issue has been marked as a duplicate of 23181 ***
Comment 12 max.odendahl 2009-07-20 05:23:57 UTC
.