Issue 97788

Summary: XIndexReplacer is not working in OOo3.0
Product: Writer Reporter: scarlettulip13 <scarlettulip13>
Component: codeAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: chandlerb, debyld, issues, orw
Version: OOo 3.0Keywords: needmoreinfo
Target Milestone: ---   
Hardware: PC   
OS: Windows 98   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description scarlettulip13 2009-01-06 05:54:42 UTC
Hi 

We have been using XIndexReplacer to edit the Numbering Rules ( mostly to set
NumberingType, LeftMargin and FirstLineIndent). 

Actually we have been using it for some time already. And also different
versions of OOo (version 2.3, 2.4 and 3.0) with the Mac OS X, windows, and Ubuntu. 

XIndexReplacer is working very well for OOo2.3 and 2.4. but not 3.0. It has been
throwing IllegalArgumentException. I found this old issue 23300 very similar to
my case. Could you please check it. 

Thanks.
Comment 1 michael.ruess 2009-01-06 09:04:38 UTC
MRU->OS: could you please have a look. Thanks!
Comment 2 Oliver Specht 2009-01-07 17:14:45 UTC
->scarlettulip13: Can you attach your code as example. The issue 23300 is not
related. It's fixed for a long time.
Comment 3 scarlettulip13 2009-01-16 04:06:52 UTC
The errors is caused by the attribute changes. 
Comment 4 Oliver-Rainer Wittmann 2009-01-16 07:36:39 UTC
OD->OS:
This issue is related to issue 97957 - probably the same root cause.
If yes, I will take care for it.

OD->scarlettulip13: For convenience it would be cool, if you could attach your
extension/macro or an example to assure that your issue is fully address. Thanks
in advance.
Comment 5 Oliver-Rainer Wittmann 2009-01-16 07:37:51 UTC
forgot to CC myself
Comment 6 Rob Weir 2013-07-30 02:40:11 UTC
Reset assignee on issues not touched by assignee in more than 1000 days.