Issue 97969

Summary: overwriting own templates unsuccessfully
Product: General Reporter: amy2008 <amy2008>
Component: codeAssignee: thorsten.martens
Status: CLOSED FIXED QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: cno, issues, michael.ruess, ooo.redflag, peter.junge, rb.henschel,, zhuangyuelin
Version: DEV300m37Keywords: regression
Target Milestone: OOo 3.2   
Hardware: PC   
OS: All   
Issue Type: PATCH Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 72764, 84292    
Description Flags
The fix to this issue none

Description amy2008 2009-01-12 06:34:13 UTC
Can reproduce it with DEV300m37 on WinXP and Fedora.
Can reproduce it with OOo2.4.1 on WinXP

How to reproduce it
1 Open a new document, like Writer Calc Drawing.
2 File - Templates - Save, Templates dialog displays, select Presentation 
  Backgrounds or Presentation, select any one in Templates list, OK
3 Hint 'Name already in use. Do you want to overwrite document template?', Click
  'Yes' button

After step 3, an error dialog appears, the dialog show 'General input/output 
error', save templates unsuccessfully

Save templates successfully

Li Meiying
Comment 1 amy2008 2009-01-12 06:49:38 UTC
I guess these templates in Presentation Backgrounds or Presentation are Read-
Only. Everyone, pls give me a hint
Comment 2 Regina Henschel 2009-01-12 18:38:01 UTC
Yes, the folder in the installation path is always readonly from inside a
running OOo. Therefore it is not listened in the path in Tools > Options > OOo >
Path. And from all of the other path you can enter there, only exact one has
write ability. This is no OS setting, but defined in OOo.
There is a spec:
Comment 3 michael.ruess 2009-01-23 15:33:43 UTC
MRU->MAV: overwriting templates which the user generated by himself is not
possible anymore. Save a template via "File.Template.Save" and try to overwrite
the same way -> mentioned error message.
worked fine in OOo 3.0.
Comment 4 Regina Henschel 2009-01-23 21:35:02 UTC
Indeed, there is no error message in OOo3.0, but for me it doesn't work "fine".

1. Start OOo, click on button 'Templates', choose your template, click on button
2. Open an explorer of your operating system and go to the template folder.
Notice the filename of the chosen template.
2. Change something on the template.
3. File > Templates > save. Use the same template name as before. Answer
overwrite warning with Yes.
4. Wait till OOo is ready. Goto the explorer. Notice, that the existing filename
is changed.
5. Close document. You get a "file not saved warning".
In case you click "Discard", you have got a changed template, but it has a
altered filename. That is not "fine".
In case you click "Save", the current document is saved with the original
filename and you have got two files for the same template. That is not "fine" too.

I use OOo on WinXP.
Comment 5 Mathias_Bauer 2009-02-05 17:05:03 UTC
As I currently cannot see why this could be a showstopper I have changed the
target. Please use the "releases" list in case you want to nominate this issue
as a showstopper.
Comment 6 mikhail.voytenko 2009-02-05 17:24:59 UTC
mav->mru: Sorry the scenario is not quite clear, but it looks like a duplicate
to issue 16712, or is the scenario, that you mean, different?
Comment 7 michael.ruess 2009-02-06 09:07:47 UTC
MRU->MAV: no, not directly. Besides, I am not able to reproduce issue 16712
I am talking of a regression from OOO3.0.1 to dev-3.1. Following steps:
New document, type some characters, File.Template.Save and assign a name, type
some more characters, File.Template.Save and choose same as before -> described
error message.
This definitely worked in 3.0.1.
Comment 8 cno 2009-06-25 10:39:51 UTC
hint: before saving again under the same name: change the field Title unde
File|Properties > Description.
No you can replace the existing template.
See issue 68233
Comment 9 cno 2009-06-25 10:43:17 UTC
"No you can replace the existing template."
should be "Now ..." (of course)
Comment 10 mikhail.voytenko 2009-06-25 10:55:39 UTC
mav->cornouws: Sorry, but the solution can not help, the title does not affect
the functionality in this case. You are probably mixing this issue with another
one, where a template with the same title is inserted.
Comment 11 cno 2009-06-25 11:02:36 UTC
sorry if I made a mistake. All I did was taking the comment from mru (desc8).
His steps do lead to the described error message (working in DEV300m50)
But when changing the documents Title before the second File|Template|Save, the
error does not occur.
I thought that was relevant.
Comment 12 mikhail.voytenko 2009-06-25 11:18:50 UTC
mav->cornouws: It is very good that you have written the results of your
investigation. But according to my knowledge changing of the title should not
affect functionality, this is why I have checked the workaround you have
suggested on Windows DEV300m50, and it did not help. So I can not currently
explain how can it help in your case ( except you provide a different template
name in the Save dialog ).
Comment 13 cno 2009-06-25 11:41:14 UTC
cornouws@mav: OK, now I cannot reproduce. Also not with a new template name.
So I thought somewhere in the configuration three something changed. Or that it
only would work with the first try.
So I started with a new usre profile ... but could not reproduce my first test ..
Until I did exactly the same steps:

File|Template|Save > OK
  change file
File|Template|Save > error
  change Title
File|Template|Save > OK

That inspired me for the next test:

File|Template|Save > OK
  change file
File|Template|Save > error
  change file (or not)
File|Template|Save > OK

So the *second attempt to overwrite does work*. Changing the documents Title is
not what did the trick.

Comment 14 mikhail.voytenko 2009-06-25 11:41:51 UTC
mav->cornouws: Ok, I think I can explain it now. The title has indeed nothing to
do with the workaround:
- create a new writer document
- File/Templates/Save ( store as a new template )
- edit
- File/Templates/Save ( store as the same template ) => failure
- try one more time File/Templates/Save ( store as the same template ) => now it

No title change is necessary. It looks like the template stays locked after the
first export and the first try to overwrite it unlocks it. So the information
you have posted is indeed very helpful. Thanks.
Comment 15 mikhail.voytenko 2009-06-25 11:46:36 UTC
mav->cornouws: You were 37 seconds faster with your comment. :)
Comment 16 cno 2009-06-25 12:10:42 UTC
@mav: Handicap of mine: often to fast ;-)
But great we found the same thing and that it helps solving the issue.
CU -Cor
Comment 17 2009-07-29 09:27:30 UTC
Created attachment 63834 [details]
The fix to this issue
Comment 18 mikhail.voytenko 2009-07-31 13:08:01 UTC
Integrated in cws fwk116.
Comment 19 mikhail.voytenko 2009-09-03 18:16:18 UTC
mav->tm: Please verify the issue.
Comment 20 mikhail.voytenko 2009-09-03 18:16:48 UTC
Comment 21 thorsten.martens 2009-09-10 11:59:35 UTC
checked and verified in cws fwk116 -> OK ! (Fix fixes the 2. mentioned problem
from mru)
Comment 22 thorsten.martens 2009-09-28 11:36:34 UTC
Comment 23 michael.ruess 2010-01-06 15:30:44 UTC
*** Issue 107749 has been marked as a duplicate of this issue. ***