Issue 98149

Summary: [F-NAME] Old addin "astroadd.dll" will not work correctly since 3.0
Product: Calc Reporter: Rainer Bielefeld <rainerbielefeld_ooo_qa>
Component: programmingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P4 CC: issues, rainerbielefeld_ooo_qa, randy
Version: OOo 3.0   
Target Milestone: ---   
Hardware: PC   
OS: Windows, all   
URL: http://de.openoffice.info/viewtopic.php?f=2&t=20522
Issue Type: DEFECT Latest Confirmation in: 4.2.0-dev
Developer Difficulty: ---
Attachments:
Description Flags
Addin, manuals and sample documents none

Description Rainer Bielefeld 2009-01-16 15:09:47 UTC
I have been using that addin, that provides additional astronomic functions for
CALC, for years. But with 3.0, that addin dos no longer work correctly, all
fields containing astroadd functions show message "#Name?".

There is a workaround to get the correct calculations: you only have to use
search / erplace for all equals signs, and the calculations will be done. but
after you saved and reloaded the document again, you will get the ugly messages
again.

Steps to reproduce: 
0. unzip "astroadd-1.5.3.zip" 
1. copy/paste "astroadd.dll" to your folder similar to
  <C:\Programme\OpenOffice.org\Basis 3.0\program\addin\astroadd.dll>
2. open demo document "astrodemo2.sdc" FROM THE ZIP
   expected: values are shown in the cells, charts with contents
   actual: Error messages, empty charts
3. Menu 'Edit -> Find & Replace', Search for "=", Replace with "=" in
   formulas for all sheets
   Calculations will be done.

No idea whether that is specific to "astroadd.dll" or a general addin problem.

NEW due to discussion on a.m. URL
Comment 1 Rainer Bielefeld 2009-01-16 15:14:17 UTC
Created attachment 59433 [details]
Addin, manuals and sample documents
Comment 2 randyjones 2010-06-10 16:22:15 UTC
This appears to be the same problem as I am having in issue 101386.
Comment 3 ooo 2010-06-11 16:14:00 UTC
Grabbing issue.
Comment 4 Rainer Bielefeld 2015-03-01 07:58:17 UTC
Workaround from <http://de.openoffice.info/viewtopic.php?f=2&t=20522&p=94584&hilit=astroadd.dll#p94584> still required with AOO420m1(Build:9800)  -  Rev. 1661141
Comment 5 Marcus 2017-05-20 10:45:04 UTC
Reset the assignee to the default "issues@openoffice.apache.org".