Issue 98432

Summary: Creating a new template category popup an error message
Product: General Reporter: sgautier.ooo
Component: uiAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: guenter.marxen, issues, rb.henschel
Version: DEV300m39Keywords: oooqa
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description sgautier.ooo 2009-01-24 16:39:39 UTC
Hi
In DEV300_m39 .deb version, when you create a new template category an error
message pop up 'Untitled already exist'. Click ok, the new category is created
and you can name it. Again, create a new category, an error message pop up
'Untitled1 already exist', click ok, the new category is created and you can
name it. Create a new category, the pop up will say 'Untitled12 already exists',
etc...

Kind regards - Sophie
Comment 1 Regina Henschel 2009-01-24 20:59:46 UTC
The problem is already in OO2.4.1, but OOo2.4.1 gives no error message. If you
generate a new category, then OOo generates a folder in the writeable template
path. This folder has the name "Unbenannt" for a German UI or "Untitled" for an
English UI. The connection between folder name and category name is entered in
the file "groupuinames.xml". If you create another new category OOo tries to use
the folder name "Untitled" and notices that it already exists. Therefore it
generates a folder "Untitled1". OOo2.4.1 does this silently, DEV300m39 produces
an error message. I think there is a bug, but not in generating the error
message. The but is using the folder name "Untitled" instead of the category
name, which the user has entered.

This sounds similar (not duplicate) to issue 97969, where an error message is
produced when file > template > save to an already existing template name.
Comment 2 g.marxen 2009-08-09 19:30:03 UTC
The bug also exists in OOO310m11 and OOO310m18 (OOo 3.1.1 RC1). 

If you repeat the steps, folders Unbenannt, Unbenannt1, Unbenannt11 etc. are
created after a warning, that Unbekannt already exists. 

G. Marxen
Comment 3 g.marxen 2009-08-09 19:40:24 UTC
Short addition: My tests under XP Pro with all patches. 
Comment 4 thackert 2009-08-10 15:20:48 UTC
Hello sgauti, *,
as Guenther has reported this problem to the Germanophone OOo dev list, I can
confirm this issue ... :(
Further observation:
1. Open Datei - Dokumentvorlage - Verwalten... (should be something like "File -
Templates - Manage" or the like ... ;) ).
2. Rightclick on "My templates" (roughly translated) on the left and choose "New"
3. Name it "test"
4. Rightclick on "My templates" again and choose "New" again.
An error message occurs, saying something like "Unnamed already exist".
5. An new folder below "My templates" is created named "Unnamed"
You are not able to rename this folder.
6. Rightclick on "My templates" again and choose "New"
You get the error message "Unamed1 already exists". A new folder named
"Unnamed1" is created.
Again, you are not able to rename it to something else like "test1" or the like
... :(
If you now look in ~/.openoffice.org/3/user/template, you will find the folders
"Unbenannt", "Unbenannt1" and "Unbenannt11". Neither I cannot find my created
folder "test" (what I would expect here) nor "Unbenannt1", "Unbenannt2" and
"Unbenannt3", what IMHO would be more logical ...
HTH
Thomas.