Issue 9860

Summary: Table has no top border when over 2+ pages
Product: Writer Reporter: jameslee <lista>
Component: codeAssignee: michael.ruess
Status: CLOSED FIXED QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues, www.openoffice.org, zefo
Version: OOo 1.0.1   
Target Milestone: ---   
Hardware: PC   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description jameslee 2002-12-05 12:07:13 UTC
Create a table with lots of rows such that is that wraps over more than one
page. Select all borders on. Select repeat header off.

On the 2nd and subsequent pages of the table there is no border at the top of
the table.
Comment 1 h.ilter 2002-12-06 13:21:38 UTC
Reassigned to MRU
Comment 2 michael.ruess 2003-05-23 11:43:59 UTC
This is a conceptional problem and is not easy to fix. In Writer the
table borders are not a grid, they are cell attributes, and this makes
it a bit difficult to calculate on page breaks.

MRU->OD: There have been some fixes in this direction in the past. I
think we should also catsch this one at least for OO2.0.
Comment 3 Oliver-Rainer Wittmann 2003-05-23 16:18:53 UTC
OD->FL (23.05.2003):
Further investigations needed in order to address with 'defect'. Thus,
please take over and discuss with AMA.
Comment 4 jameslee 2003-07-01 11:13:11 UTC
> This is a conceptional problem and is not easy to fix. In Writer the
> table borders are not a grid, they are cell attributes, and this
makes
> it a bit difficult to calculate on page breaks.

In this is a (poor) workaround, by highlighting the top row cells and
editing the table proerties the top border of the individual cells can
be re-added. It's a poor workaround as the borders get messed up when
the data are changed and the page break shifts.

The problem is not as conceptually hard as is being made out.
Something somewhere can not only draw a line at the top of the page
but draw a complete box, fill it with headings and space the rest of
the table down. This seems much harder that just drawing the line.
Could not the code which draws the headings be made to draw the single
line? So instead of it thinking headings or nothing it thinks heading
as a box or heading as a single line.
Comment 5 frank.loehmann 2004-04-07 18:25:52 UTC
FL->OD: Please copy (column by column) the line style from the last row of the
previous page, if table headers are turned off and if there is no own border
currently defined. In most cases this will fix the problem and if it does not,
the user could also assign an own line style to the border. 
Comment 6 Oliver-Rainer Wittmann 2004-04-20 13:11:49 UTC
OD->FL:
Please correct the classification and the target of this issue.
IMHO, this is an enhancement/feature. If it's classified as an
enhancement/feature, we need a specification for it. The priority of this issue
is IMHO P4, not P3 - thus, the issue has to be retargeted.
Comment 7 Oliver-Rainer Wittmann 2004-04-20 13:15:51 UTC
forgot to re-assign
Comment 8 frank.loehmann 2004-04-21 09:51:59 UTC
change type to feature
Comment 9 zefo 2004-04-29 00:40:26 UTC
another workaround:

turn table headers on (even if you don't use them)
change the height of the header to a very small number

it is quite ugly workaround but it does work.. hopefully someone will find this
feature/bug worth coding/patching.

cheers,

-- joe
Comment 10 Martin Hollmichel 2004-08-09 14:02:27 UTC
according to http://www.openoffice.org/servlets/ReadMsg?list=releases&msgNo=7690
this issue will be set to OOoLater
Comment 11 michael.ruess 2005-02-02 11:14:37 UTC
*** Issue 41838 has been marked as a duplicate of this issue. ***
Comment 12 michael.ruess 2005-02-03 07:35:43 UTC
*** Issue 41838 has been marked as a duplicate of this issue. ***
Comment 13 michael.ruess 2005-02-08 08:07:22 UTC
*** Issue 42231 has been marked as a duplicate of this issue. ***
Comment 14 michael.ruess 2006-10-30 09:26:29 UTC
*** Issue 70988 has been marked as a duplicate of this issue. ***
Comment 15 michael.ruess 2007-09-21 08:43:03 UTC
*** Issue 81803 has been marked as a duplicate of this issue. ***
Comment 16 schaber 2007-09-21 09:46:41 UTC
Hi!

Please fix that issue. It has been reported already 5 years ago, and there is no
proper workaround.
Comment 17 kpalagin 2007-09-23 19:37:05 UTC
*** Issue 52718 has been marked as a duplicate of this issue. ***
Comment 18 frank.loehmann 2007-09-24 12:28:18 UTC
Set target.
Comment 19 ooouser20070909 2007-10-18 16:00:43 UTC
Issue 61410 is another duplicate of this issue. In my opinion it's a defect.
Comment 20 michael.ruess 2007-11-01 14:05:52 UTC
*** Issue 83204 has been marked as a duplicate of this issue. ***
Comment 21 frank.meies 2008-01-11 13:00:20 UTC
I definitely consider this a defect => changed issue type to "defect"

I'll take over.
Comment 22 frank.meies 2008-01-14 07:53:23 UTC
Fixed in cws osfme01, paintfrm.cxx
Comment 23 frank.meies 2008-01-14 09:24:36 UTC
Ready for QA.
Comment 24 michael.ruess 2008-01-15 09:48:24 UTC
*** Issue 85260 has been marked as a duplicate of this issue. ***
Comment 25 michael.ruess 2008-01-16 14:38:40 UTC
Verified fix in CWS osfme01.
Comment 26 stefan.baltzer 2008-01-22 10:50:12 UTC
Verified in CWS c21v001, too.
Comment 27 mail 2008-03-22 12:57:07 UTC
The issue is also in the RC6. 
Comment 28 Mechtilde 2008-03-22 12:58:21 UTC
-> Reopen
Comment 29 mail 2008-03-22 12:59:01 UTC
i tested the OS Windows XP with JRe.
Comment 30 thorsten.ziehm 2008-03-27 12:57:09 UTC
Set Issue back to state 'fixed/verified'. This issues is in a CWS, which isn't
integrated in OOo 2.4.
See
http://eis.services.openoffice.org/EIS2/cws.ShowCWS?Id=6283&OpenOnly=false&Section=Overview
for more details. Therefore this issue is fixed and verified, but not integrated
now. So the state 'reopened' isn't correct. Perhaps the target of this issue has
to be adjusted, because it isn't integrated in 2.4. But I do not know the plan,
when this CWS will be integrated.
Comment 31 thorsten.ziehm 2008-03-27 12:57:52 UTC
=> fixed/verified
Comment 32 Mechtilde 2008-03-27 16:33:13 UTC
set target to 3.0

It isn't integrated in 2.4 and 2.4 is released
Comment 33 frank.meies 2008-05-13 15:04:51 UTC
Fixed on cws fmebugs04.
Comment 34 frank.meies 2008-05-13 15:10:51 UTC
.
Comment 35 michael.ruess 2008-05-20 14:15:52 UTC
Verified fix in CWS fmebugs04 for OO 3.0 branch.
Comment 36 michael.ruess 2008-06-10 11:33:19 UTC
Checked fix in DEV300m18 build.