Issue 98760

Summary: macro cannot be removed in ImageMap
Product: General Reporter: doze_worm <zhuangyuelin>
Component: scriptingAssignee: ab
Status: CLOSED IRREPRODUCIBLE QA Contact: issues@framework <issues>
Severity: Trivial    
Priority: P3 CC: issues, ooo.redflag, peter.junge
Version: OOO300m9   
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    

Description doze_worm 2009-02-03 05:25:36 UTC
[Steps]
1. Create a Writer doc.
2. "Insert" -> "Picture" -> "From File..." to insert a picture.
3. "Edit" -> "ImageMap", popup the "ImageMap Editor" dialog-box, click the
"Rectangular" button and draw a select region on the picture.
4. Press "Macro..." button, assign any macro to an event in the pop-up "assign
Macro" dialog-box, e.g. Assign the Helloworld.bsh in "OOo-dev Macros" ->
"HelloWorld" to the event "MouseOver", and press OK button to close the dialog-box.
5. Press "Apply" button in "ImageMap Editor" dialog-box, then close it.
6. "Edit" -> "ImageMap" to reopen the "ImageMap Editor", and left-click on the
select region to active the "Macro..." button. Press "Macro..." button to open
the "Assign Macro" dialog-box.

[Result]
The script that orginal be assigned to the MouseOver event dosen't display, and
the macro cannot be removed. But in the doc, the macro is active and has effect.

[Expectation]
When reopen the ImageMap Editor, original settings can be displayed and modify
in Macro.

[Addition]
Test on DEV300m40(Build:9381) in windows XP and DEV300m41(Build:9383) in Linux.
Comment 1 ab 2009-04-21 08:28:59 UTC
I tried with OOO300m9 and DEV300m45 on Windows and could 
not reproduce the problem. Could anyone else reproduce this?
Comment 2 ab 2009-05-18 09:25:17 UTC
Setting on WORKSFORME for now
Comment 3 Mechtilde 2009-07-12 19:59:21 UTC
worksforme -> closed