Issue 99052

Summary: with cursor not in a table: Edit: Select All: selects nothing
Product: Writer Reporter: Graham Perrin <grahamperrin>
Component: uiAssignee: writerneedsconfirm <swneedsconfirm>
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: DEV300m40   
Target Milestone: ---   
Hardware: All   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---

Description Graham Perrin 2009-02-09 16:21:29 UTC
1.	launch OOo-dev

2.	command-N

3.	click the table button in the toolbar

4.	accept the 2 x 2 default

5.	paste text (sample provided) to each of the four cells

6.	observe that the second row spans a soft page break

7.	position the cursor below the table

8.	Edit menu | Select All


= Expected =

Selection of all within the document.


= Bug =

Nothing is selected.


= Workaround =

Repeat the Select All command.
Comment 1 Graham Perrin 2009-02-09 16:28:42 UTC
According to help, Select All: 

> Selects the entire content of the current file, frame, or text object.
Comment 2 Graham Perrin 2009-02-09 16:33:30 UTC
Alternatively: 

1. select some text below (beyond the boundary of) the table

2. command-A to select all

3. selection is lost

4. Table toolbar appears
Comment 3 Graham Perrin 2009-02-09 16:36:44 UTC
Workaround: 

• position the cursor at the beginning of the first cell

• key Return.

This may be a duplicate of issue 7747.
Comment 4 michael.ruess 2009-02-09 17:40:24 UTC
This definitely is a dup of issue 7747.

*** This issue has been marked as a duplicate of 7747 ***
Comment 5 michael.ruess 2009-02-09 17:40:51 UTC
Closing duplicate.