Issue 99485

Summary: Help menu needs quite long to open (for fist time of session) on Mac
Product: Writer Reporter: frieder2008 <bertholdleimbach>
Component: viewingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, michael.ruess, thomas.klarhoefer
Version: OOO310m1   
Target Milestone: ---   
Hardware: Mac   
OS: Mac OS X, all   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 98052    
Issue Blocks:    

Description frieder2008 2009-02-21 17:47:32 UTC
Strange behavior of the help-item in the main menu-bar

When you open OpenOffice after a cold start and click on any menu-item in the main-menu-bar every 
menu-item opens almost immediately, with the exception of the help-menu-item. This takes about 3 
seconds, which leaves you the impression that something is wrong. At least appears annoying 

After a second opening of OpenOffice (warm-start) the roll-down of the help-menu is quite quick, but 
still slower then the other roll-down-menu-windows.
Comment 1 michael.ruess 2009-03-10 17:25:45 UTC
Setting KLA on cc.
MRU->PB: the help menu in deed needs a little longer to be opened on MacOS. Does
this have a special reason, is there a special library which needs to be loaded?
Comment 2 carsten.driesner 2009-03-13 11:33:59 UTC
cd->mru: Yes, I think this is a duplicate to 100172. The menu needs the
accelerator mappings to add them to menu items. I don't know why the Help menu
is special here. All menus must see a performance penalty.