Issue 99606

Summary: 4 copies are printed out when CopyCount=2
Product: App Dev Reporter: richardli <richard.li>
Component: apiAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: issues, mechtilde, rainerbielefeld_ooo_qa
Version: 3.3.0 or older (OOo)Keywords: needmoreinfo, oooqa
Target Milestone: ---   
Hardware: PC (x86_64)   
OS: Windows XP   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
The java program that generates 4 copies in printing none

Description richardli 2009-02-25 04:11:46 UTC
Using UNO interface to do the printing, when I set CopyCount=2, it prints out 4
copies.  After further investigation, I have the following findings:

| Collate    | CopyCount | no. of copies printed out |
| true/false |         1 |                         1 |
| false      |         2 |                         4 |
| true       |         2 |                         2 |

I think it is a bug generated by fixing issue #63866.
Comment 1 Rainer Bielefeld 2009-02-25 08:36:17 UTC
@richardli: 
Pls. attach a small sample file containing your Macro
Comment 2 richardli 2009-02-25 09:02:40 UTC
Created attachment 60466 [details]
The java program that generates 4 copies in printing
Comment 3 Mechtilde 2010-01-08 13:46:51 UTC
I think that isn't a problem of spreadsheet in general.

It seems to be aproblem using a java programm

Therefore I set new component api
Comment 4 loudo 2010-02-08 13:01:15 UTC
Same problem here. If I set Collate to false (or if I don't specify Collate), i 
got the square number of copies. But if I set Collate to true, the number of 
copies printed is ok.
CopyCount  | no. of copies printed out |
         1 |                         1 |
         2 |                         4 |
         3 |                         9 |
Comment 5 Rob Weir 2013-02-02 02:59:04 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.