Issue 99748

Summary: Bug: Autocorrect: Correct two initial capitals
Product: Internationalization Reporter: therkiel <theriel>
Component: i18npoolAssignee: AOO issues mailing list <issues>
Status: UNCONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: hdu, issues, philipp.lohmann
Version: OOo 2.4.1Keywords: oooqa
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---
Attachments:
Description Flags
Video File Reproducing Bug none

Description therkiel 2009-03-01 14:19:57 UTC
I'm a linguist working with Khoisan languages. I noticed Open Office 
autoformats capital letters after punctuation marks, making them lowercase, and 
for the longest time I couldn't figure out what option that was under. For 
instance, the language !Ora was changed to !ora, and ǂHaba as ǂhaba. 

Finally a friend suggested the option "Correct two initial capitals" and it 
worked; when I turned that off, then I was able to type names and words 
properly. Why are |, !, ǂ etc. seen as capital letters? I want it to correct it 
if I type something like !ORa, but !Ora is a perfectly normal word. 

Is this intentional?  I asked in the dev irc channel, the regular channel, and 
the forum, and got no reply anywhere.  

It's pretty easy to reproduce the bug: just type ! followed by any letter.  I 
haven't gone through every possible punctuation mark to see which affects it, 
but at the very least ǃ ǂ ǀ and ǁ do.  

Thanks!
Comment 1 Rainer Bielefeld 2009-03-01 15:37:38 UTC
I checked with "Ooo 3.0.1 (DE) Multilingual version GERMAN UI WIN XP: [OOO300m15
(Build 9379)]" and can NOT confirm that !ORa will be corrected to Ora, same with
 "2.4.1  Multilingual version English UI WIN XP: [680m17(Build9310)]"

@therkiel:
Before you file further issues or post again here, please read our guidelines on
<http://qa.openoffice.org/issue_handling/pre_submission.html> and  
<http://www.openoffice.org/bugs/bug_writing_guidelines.html>, then
contribute a clear step by step instruction containing all observations (error
messages ...), _every_key_press_and_every_mouse_click_ how to reproduce the
problem, and explain why you believe that your results are unexpected.
That means (for example): 
 do not write something like „I am not able to ...“, but
 „6. left mouse click on …
     expected: …, colour of … changes, … 
     actual: no …., colour remains white, no …

Please: 
- specify your OS and Platform
- contribute complete information cocerning your OS and OOo localization
- tell us why you use outdated 2.4.1
- attach a sample file, if sample file requires a particular font set, please
  link a source
- Check whether your needs match with those from  Issue 97214
- Suggest a solution: Add exceptions for correction for those languages, ...
Comment 2 therkiel 2009-03-02 06:19:01 UTC
Created attachment 60571 [details]
Video File Reproducing Bug
Comment 3 therkiel 2009-03-02 06:29:09 UTC
My apologies.  As you misunderstood me, I'll be more specific, particularly 
since I have since realized it is partially caused by another programme.

OpenOffice.org 3.0.1 OOO300m15 (Build 9379) US English.  
Platform Ubuntu 8.10 US English, Kernel 2.6.27-11-generic

There are no specific fonts required, but the bug does not reproduce when SCIM 
is not loaded.  I am using SCIM 1.4.7, using Keyboard IPA Unicode 5.1 (v1.2) 
http://scripts.sil.org/cms/scripts/page.php?
site_id=nrsi&id=UniIPAKeyboard#96398e9e is a package for this keyboard 
mapping.  Although the website says it needs Doulos SIL to work properly, this 
is only in reference to certain non-standard IPA characters, and does not 
affect the bug. 

The needs do not match 97214, as this is not multiple letters being adjusted, 
but rather punctuation marks.

To reproduce the bug, with SCIM and IPA Unicode 5.1 loaded:

Open Openoffice Writer
Make sure Autocorect Option: Correct Two Initial Capitals is on
Type: !Ora
Expected result: Word should stay as !Ora.
Actual Result: word changes to !ora.  

My apologies on fix suggestions, but I am not a programmer, and wouldn't know 
how to fix this.  
Comment 4 ooo 2009-03-03 14:43:46 UTC
@hdu, pl: what is so special about SCIM input method that it confuses
AutoCorrection? Any idea?
Comment 5 ooo 2009-03-03 14:44:27 UTC
@hdu, pl: what is so special about SCIM input method that it confuses
AutoCorrection? Any idea?
Comment 6 philipp.lohmann 2009-03-03 14:53:58 UTC
pl->er: nothing (especially as autocorrection takes place after the word is
compelted, isn't it). However it may be that the entered text comes in as
extended text input instead of single key events; that is basically a choice of
the input method. What gave you the impression that SCIM makes the difference in
the first place ?
Comment 7 ooo 2009-03-03 15:42:13 UTC
@pl: because therkiel said so in #desc4: "the bug does not reproduce when SCIM 
is not loaded".
Comment 8 Marcus 2017-05-20 11:33:42 UTC
Reset assigne to the default "issues@openoffice.apache.org".