Issue 99838

Summary: WW8: OOo-object cannot be activated in MSWord
Product: Writer Reporter: doze_worm <zhuangyuelin>
Component: formattingAssignee: AOO issues mailing list <issues>
Status: CONFIRMED --- QA Contact:
Severity: Trivial    
Priority: P3 CC: amy2008, issues, michael.ruess, ooo.redflag, peter.junge, thomas.lange
Version: OOO310m3   
Target Milestone: ---   
Hardware: Unknown   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84292    
Attachments:
Description Flags
a doc file to reporduce the problem none

Description doze_worm 2009-03-04 03:03:27 UTC
[Steps]
1. Create a Writer doc.
2. "Insert" -> "Drawing Object" -> "Formula", Type y=ax2+bx+c in it.
3. Save as .doc file.
4. Open the .doc file with MS WORD 2003/2007

[Result]
The operator "+" misses in WORD. And the formula cannot be edited in MS WORD.
Comment 1 doze_worm 2009-03-04 03:07:43 UTC
Created attachment 60659 [details]
a doc file to reporduce the problem
Comment 2 michael.ruess 2009-03-05 12:07:38 UTC
The display problem cannot be reproduced here; Word 2003 shows the attached
document properly.

MRU->MAV: please care about the mentioned activation problem. It is not possible
to activate any OOo  object in MS Word in an exported document.
Comment 3 michael.ruess 2009-04-28 11:58:10 UTC
IMO this problem is severe enough and worth fixing in OOo 3.2.
Comment 4 Mathias_Bauer 2009-05-15 13:52:43 UTC
I could successfully export a Writer document with a simple formula to Word
format (don't forget the Load/Save settings!) and edit in Word 2003.
Comment 5 Mathias_Bauer 2009-05-15 13:55:02 UTC
The missing "+" sign is a font problem and it only happens for the metafile.
Once the formula is edited in Word, the "+" becomes visible. Thomas, any comment
from your side? In case you think that the font problem can be fixed, mru could
reopen the issue for you (or maybe sj).
Comment 6 michael.ruess 2009-06-30 16:07:28 UTC
Reopening issue. Problem is not that the object conversion - It must be possible
to activate our own objects in a doc opened in Word (if OOo is either installed
on this machine).
The changed summary says it - only the activation problem is handled now in this
issue.
Comment 7 michael.ruess 2009-06-30 16:09:08 UTC
Reassigned to MAV for caring about OOo's OLE-server problem in exported doc files.
Comment 8 amy2008 2009-07-01 04:12:00 UTC
cc
Comment 9 mikhail.voytenko 2009-08-31 12:59:36 UTC
Changing the target to OOo3.x because of not enough resources.

mav->mru: Please set the target back if you believe that the bug is important
enough to be treated as a show-stopper.
Comment 10 Marcus 2017-05-20 11:15:33 UTC
Reset assigne to the default "issues@openoffice.apache.org".