Issue 99842

Summary: wrong colour displayed for underlining text
Product: Draw Reporter: doze_worm <zhuangyuelin>
Component: codeAssignee: wolframgarten
Status: CLOSED FIXED QA Contact: issues@graphics <issues>
Severity: Trivial    
Priority: P3 CC: amy2008, Armin.Le.Grand, hdu, IngridvdM, issues, jbf.faure, ooo.redflag, peter.junge, rainerbielefeld_ooo_qa
Version: OOO310m3Keywords: oooqa, regression
Target Milestone: OOo 3.1.1   
Hardware: All   
OS: All   
Issue Type: DEFECT Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on:    
Issue Blocks: 84405, 98419, 101565    
Attachments:
Description Flags
example document
none
minimal bugdoc with underline and overline none

Description doze_worm 2009-03-04 04:47:00 UTC
[Steps]
1. Create a(n) Writer/Impress doc.
2. "Insert" -> "Drawing Object" -> "Chart...", to insert a chart.
3. "Insert" -> "Title", and type any word in any of the six text-box in "Title"
dialog, e.g., type "TEST" in Subtitle, press OK button.
4. "Format" -> "Title" -> "Subtitle...", select "Font Effects" bar in "Title"
dialog, set "Double" to Underlining and "light Red" to Underline color, press OK
button.
5. Click on the blank space on the doc page to quit the edit mode of chart.

[Result]
The color of the underlining of subtitle is black. Only in chart edit-mode, the
color of underlining of title displays correctly.
Comment 1 Rainer Bielefeld 2009-03-04 06:39:22 UTC
I checked with "Ooo Dev 3.1.0 multilingual version English UI WIN XP: [OOo310m2
(Build 9385)]" and can confirm the reported effect

Works fine with "Ooo 3.0.1 (DE) Multilingual version GERMAN UI WIN XP:
[OOO300m15 (Build 9379)]"

There is a similar effect in  Issue 56520, but I doubt that there is a
connection between these issues.
Comment 2 kla 2009-03-04 07:49:24 UTC
@iha: pls have a look
Comment 3 IngridvdM 2009-03-05 11:13:45 UTC
@weiz, please have a look.
Comment 4 weiz 2009-04-20 03:15:06 UTC
Created attachment 61674 [details]
example document
Comment 5 weiz 2009-04-20 03:15:42 UTC
@iha, maybe the "CharUnderlineColor" property of chart is overridden by the same
property of text in the applications. And this is a global problem, please see
the example document.
Comment 6 IngridvdM 2009-04-20 16:39:36 UTC
@weiz, thanks for analyzing the problem!
@hdu, the font underline color is rendered correctly only in text edit mode. The
drawinglayer and also the metafile renderer do use a wrong color for underlining
of texts in OLE objects. Please look at the attached example document from weiz
and follow the instructions there.
Comment 7 hdu@apache.org 2009-04-21 11:16:36 UTC
The rTextlineColor argument in the TextDecoratedPortionPrimitive2D constructor requests the black 
underline color:

# p rTextlineColor 
$1 = (const BColor &) @0xbfffd2f0: {
  <B3DTuple> = {
    mfX = 1, 
    mfY = 0, 
    mfZ = 0
  }
in DEV300_m46:
#0  drawinglayer::primitive2d::TextDecoratedPortionPrimitive2D::TextDecoratedPortionPrimitive2D 
(this=0xfb5a964, rNewTransform=@0xbfffd358, rText=@0xbfffd644, aTextPosition=0, 
aTextLength=30, rDXArray=@0xbfffd33c, rFontAttributes=@0xbfffd318, rLocale=@0xbfffd324, 
rFontColor=@0xbfffd2d8, rOverlineColor=@0xbfffd2c0, rTextlineColor=@0xbfffd2f0, 
eFontOverline=FONT_UNDERLINE_NONE, eFontUnderline=FONT_UNDERLINE_DOUBLE, 
bUnderlineAbove=false, eFontStrikeout=FONT_STRIKEOUT_NONE, bWordLineMode=false, 
eFontEmphasisMark=FONT_EMPHASISMARK_NONE, bEmphasisMarkAbove=false, 
bEmphasisMarkBelow=false, eFontRelief=FONT_RELIEF_NONE, bShadow=false) at 
drawinglayer/source/primitive2d/textdecoratedprimitive2d.cxx:783
#1  (anonymous namespace)::impTextBreakupHandler::impCreateTextPortionPrimitive 
(this=0xbfffd8d8, rInfo=@0xbfffd3f0) at svx/source/svdraw/svdotextdecomposition.cxx:386
#2  (anonymous namespace)::impTextBreakupHandler::impHandleDrawPortionInfo (this=0xbfffd8d8, 
rInfo=@0xbfffd3f0) at svx/source/svdraw/svdotextdecomposition.cxx:529
#3  (anonymous namespace)::impTextBreakupHandler::decomposeBlockTextPrimitive (this=0xbfffd8d8, 
pInfo=0xbfffd3f0) at svx/source/svdraw/svdotextdecomposition.cxx:591
#4  Outliner::DrawingText (this=0x3d8a8a10, rStartPos=@0xbfffd610, rText=@0xbfffd644, 
nTextStart=0, nTextLen=30, pDXArray=0xfb54e90, rFont=@0xbfffd5cc, nPara=0, nIndex=0, 
nRightToLeft=0 '\0', pWrongSpellVector=0x0, pFieldData=0x0, bEndOfLine=1, bEndOfParagraph=1, 
bEndOfBullet=0, pLocale=0xbfffd5f4, rOverlineColor=@0xbfffd618, rTextLineColor=@0xbfffd640) at 
inc/tools/link.hxx:142
#5  ImpEditEngine::Paint (this=0x52b3000, pOutDev=0xbfffd6d8, aClipRec={nLeft = 0, nTop = 0, 
nRight = 2147483646, nBottom = 2147483646}, aStartPos={<Pair> = {nA = 0, nB = 0}, <No data 
fields>}, bStripOnly=1 '\001', nOrientation=0) at svx/source/editeng/impedit3.cxx:3303
#6  EditEngine::StripPortions (this=0x3d8b1ca0) at svx/source/editeng/editeng.cxx:1695
#7  Outliner::StripPortions (this=0x3d8a8a10) at svx/source/outliner/outliner.cxx:1768
#8  SdrTextObj::impDecomposeBlockTextPrimitive (this=0x3df337a0, rTarget=@0xbfffd9ec, 
rSdrBlockTextPrimitive=@0x6372d30, aViewInformation=@0xbfffde74) at 
/so/ws/DEV300/ooo/svx/source/svdraw/svdotextdecomposition.cxx:162
#9  drawinglayer::primitive2d::SdrBlockTextPrimitive2D::createLocalDecomposition (this=0x6372d30, 
aViewInformation=@0xbfffde74) at svx/source/sdr/primitive2d/sdrtextprimitive2d.cxx:250
#10 0x1878e600 in drawinglayer::primitive2d::BasePrimitive2D::get2DDecomposition 
(this=0x6372d30, rViewInformation=@0xbfffde74) at 
drawinglayer/source/primitive2d/baseprimitive2d.cxx:80
Comment 8 hdu@apache.org 2009-04-21 11:41:13 UTC
ah, the tuple elements are doubles, so BColor={1,0,0} means RED...
Comment 9 hdu@apache.org 2009-04-21 15:45:40 UTC
.
Comment 10 hdu@apache.org 2009-04-21 15:46:32 UTC
Fixed in CWS vcl101.
Comment 11 hdu@apache.org 2009-04-28 14:00:22 UTC
@wg: please review in CWS vcl101
Comment 12 hdu@apache.org 2009-05-04 08:52:13 UTC
*** Issue 101504 has been marked as a duplicate of this issue. ***
Comment 13 ejanuskevicius 2009-05-04 12:34:38 UTC
aditionally, copy/paste of selected text replaces specified colors for
over/underlining with text color.
Comment 14 wolframgarten 2009-05-04 12:40:33 UTC
Verified in CWS.
Comment 15 wolframgarten 2009-05-11 15:01:06 UTC
Target set for 3.1.1 showstopper.
Comment 16 hdu@apache.org 2009-05-11 15:40:40 UTC
prepare backporting to OOo3.11
Comment 17 hdu@apache.org 2009-05-11 15:41:31 UTC
reopen for backport
Comment 18 hdu@apache.org 2009-05-11 15:41:59 UTC
.
Comment 19 hdu@apache.org 2009-05-12 08:32:16 UTC
For target OOo3.11 the fix now is also in CWS ooo311gsl01
Comment 20 hdu@apache.org 2009-05-12 10:26:59 UTC
Created attachment 62191 [details]
minimal bugdoc with underline and overline
Comment 21 hdu@apache.org 2009-05-12 11:15:36 UTC
@wg: please also verify in CWS ooo311gsl01
Comment 22 wolframgarten 2009-05-14 08:20:35 UTC
Verified in CWS.
Comment 23 wolframgarten 2009-07-21 13:04:43 UTC
Tested in m52. I have written follow up i103692.