Issue 99877

Summary: Can not change separator between outline number levels
Product: Writer Reporter: mafshar <mohammad.afshar>
Component: viewingAssignee: michael.ruess
Status: CLOSED DUPLICATE QA Contact: issues@sw <issues>
Severity: Trivial    
Priority: P3 CC: issues
Version: OOO300m9   
Target Milestone: ---   
Hardware: PC   
OS: Windows XP   
Issue Type: ENHANCEMENT Latest Confirmation in: ---
Developer Difficulty: ---

Description mafshar 2009-03-04 16:08:39 UTC
I have defined an outline numbering for my document from "Tools >> Outline
Numbering...". By default OpenOffice.org puts "." (dot) between outline numbers.
like:
1 Heading 1
1.1 Heading 2
1.1.1 Heading 3

I need to change those dots between outline numbers to other signs (like dash).
like:
1 Heading 1
1-1 Heading 2
1-1-1 Heading 3

Unfortunately using "Before" and "After" separator do not do this. If you change
the "Before" or "After" separator to dash, the result will be like this:
-1 Heading 1
-1.1 Heading 2
-1.1.1 Heading 3
or
1- Heading 1
1.1- Heading 2
1.1.1- Heading 3

I will be really grateful if you add this feature to OpenOffice.org, cause this
is the only problem i have with OpenOffice.org

Regards
Mohammad Afshar
Comment 1 eric.savary 2009-03-04 20:44:28 UTC
Reassigned
Comment 2 michael.ruess 2009-03-05 06:26:33 UTC
That is possible. In the Tools.Outline settings, you can define the separator
for every level independently.
Comment 3 michael.ruess 2009-03-05 06:27:50 UTC
Change the separator "After" for Level 1 and Level 2 to "-" and you will get
what you desire.
Comment 4 michael.ruess 2009-03-05 06:28:42 UTC
Closed.
Comment 5 mafshar 2009-03-05 06:55:11 UTC
Dear mru,

I have already done what you said, but az i mentiond in problem description, if
i set the BEFORE or AFTER separator of Level 1, 2, 3, ... (even independently)
to "-" the result will be like this:
{if only set the BEFORE separator to "-"}
-1 Heading 1
-1.1 Heading 2
-1.1.1 Heading 3

{if only set the AFTER separator to "-" as you said in your comment}
1- Heading 1
1.1- Heading 2
1.1.1- Heading 3

{if set both BEFORE and AFTER separator to "-"}
-1- Heading 1
-1.1- Heading 2
-1.1.1- Heading 3

so as you see the problem was not solved and is still open. I want to see this:
1 Heading 1
1-1 Heading 2
1-1-1 Heading 3

Regards
Mohammad Afshar
Comment 6 michael.ruess 2009-03-05 07:48:20 UTC
Sorry, I mis-understood.
What you desire is already tracked as issue 21387.

*** This issue has been marked as a duplicate of 21387 ***
Comment 7 michael.ruess 2009-03-05 07:49:47 UTC
Closing duplicate.