Issue 99999

Summary: OOo 3.2 release stoppers / blockers
Product: Build Tools Reporter: Martin Hollmichel <nesshof>
Component: codeAssignee: Martin Hollmichel <nesshof>
Status: CLOSED FIXED QA Contact: issues@tools <issues>
Severity: Trivial    
Priority: P2 CC: carsten.driesner, cno, frank.schoenheit, issues, jbf.faure, khirano, mdxonefour, mechtilde, merschmann, mux2005, oliver.brinzing, olivier.hallot.ooo, rene, ruediger.timm, stefan.baltzer, stefan.weigel
Version: current   
Target Milestone: OOo 3.2   
Hardware: All   
OS: All   
URL: http://wiki.services.openoffice.org/wiki/OOoRelease32
Issue Type: TASK Latest Confirmation in: ---
Developer Difficulty: ---
Issue Depends on: 53184, 60401, 86464, 94242, 94900, 96538, 98927, 99849, 99866, 99971, 100658, 100764, 100905, 101139, 101639, 101821, 101879, 102048, 102116, 102224, 102257, 102294, 102304, 102434, 102464, 103047, 103179, 103374, 103464, 103611, 103745, 103747, 103757, 104057, 104155, 104221, 104421, 104508, 104682, 104685, 104695, 104753, 104856, 104861, 104867, 104886, 104901, 104911, 104915, 104937, 104974, 104986, 104987, 104992, 105052, 105065, 105100, 105124, 105148, 105149, 105154, 105158, 105161, 105172, 105183, 105185, 105194, 105216, 105234, 105235, 105238, 105263, 105267, 105275, 105343, 105350, 105354, 105360, 105365, 105371, 105373, 105386, 105418, 105457, 105471, 105476, 105489, 105508, 105511, 105512, 105561, 105565, 105571, 105605, 105606, 105653, 105654, 105670, 105710, 105712, 105716, 105719, 105724, 105753, 105760, 105767, 105769, 105825, 105835, 105852, 105856, 105880, 105891, 105892, 105895, 105926, 105941, 105945, 105947, 105958, 105959, 105960, 105988, 105992, 106033, 106041, 106045, 106057, 106067, 106068, 106072, 106075, 106079, 106080, 106081, 106082, 106083, 106084, 106085, 106129, 106130, 106142, 106146, 106158, 106164, 106171, 106183, 106194, 106214, 106218, 106261, 106263, 106292, 106343, 106349, 106351, 106367, 106369, 106390, 106434, 106476, 106497, 106515, 106523, 106550, 106572, 106574, 106624, 106643, 106678, 106710, 106730, 106732, 106757, 106766, 106816, 106833, 106854, 106859, 106863, 106876, 106901, 106904, 106930, 106941, 106978, 106980, 107003, 107006, 107035, 107047, 107049, 107064, 107075, 107076, 107087, 107143, 107151, 107166, 107170, 107204, 107239, 107248, 107263, 107275, 107283, 107358, 107365, 107401, 107440, 107485, 107501, 107512, 107525, 107528, 107554, 107610, 107688, 107741, 107763, 107794, 107804, 107839, 107845, 107904, 107957, 107965, 107966, 108005, 108012, 108019, 108040, 108263, 108313, 108325, 108331, 108423, 108426, 108488, 108512, 108534, 108559, 108610, 108813    
Issue Blocks:    

Description Martin Hollmichel 2009-03-07 13:12:35 UTC
track 3.2 releases
Comment 1 tommy27 2009-04-05 08:51:26 UTC
i suggest to consider Issue 87672 as release blocker for OOo 3.2

http://www.openoffice.org/issues/show_bug.cgi?id=87672

actually that issue has a P2 priority and a OOo 3.x target milestone.
Comment 2 chuckcoleman 2009-04-07 15:49:52 UTC
I nominate issue 92011 as a release blocker.

http://www.openoffice.org/issues/show_bug.cgi?id=92011

It has a P3 priority and 3.x target.
Comment 3 chuckcoleman 2009-04-07 15:51:01 UTC
I forgot to mention that I frequently trip over this bug.
Comment 4 ohallot 2009-07-23 15:40:41 UTC
I nominate bug 103464 as critical for Release 3.2.

All bugs are important, but this one splashes in the face of the top management
in front of the audiences. Could no be less discret. 
Comment 5 moritzmhq 2009-07-27 10:00:43 UTC
I nominate <a href="http://www.openoffice.org/issues/show_bug.cgi?id=2593">
2593</a>, which is the last real showstopper for using OOwriter as a lawyer....
Comment 6 chuckcoleman 2009-08-31 23:58:46 UTC
I also nominate issue 94624 as a release blocker, as it makes equations in Word
documents unreadable on the Mac.  It has a 3.2 target.
Comment 7 Mechtilde 2009-09-02 12:32:57 UTC
change some flags for better finding

should we bring the issues described here to the releases list?
Comment 8 Mechtilde 2009-09-02 12:34:52 UTC
sorry for overriding
Comment 9 Mechtilde 2009-09-02 19:49:27 UTC
change Type for better finding
Comment 10 merschmann 2009-09-03 14:11:53 UTC
Changing description according to prior versions (for better finding)
Comment 11 Oliver Brinzing 2009-09-06 10:01:39 UTC
adding http://www.openoffice.org/issues/show_bug.cgi?id=102294
(date 1.1. changes to 01.01.08)
Comment 12 Oliver Brinzing 2009-09-06 10:05:35 UTC
adding http://qa.openoffice.org/issues/show_bug.cgi?id=99904
(soft cell format is lost during drag operation)
Comment 13 Oliver Brinzing 2009-09-06 10:08:15 UTC
adding http://www.openoffice.org/issues/show_bug.cgi?id=98927
(PrintHiddenText and PrintHiddenText not saved to "settings.xml")
should be easy to fix
Comment 14 Oliver Brinzing 2009-09-06 10:09:54 UTC
nominanting http://www.openoffice.org/issues/show_bug.cgi?id=87596
(Dialog Model Width and Height not working anymore)
Comment 15 Oliver Brinzing 2009-09-06 10:12:09 UTC
adding http://www.openoffice.org/issues/show_bug.cgi?id=98928
(calc annotations (cell notes) are shown behind some form controls)
Comment 16 Oliver Brinzing 2009-09-06 12:46:55 UTC
nominating http://www.openoffice.org/issues/show_bug.cgi?id=104672
(wrong page preview for documents with control elements)
Comment 17 Oliver Brinzing 2009-09-06 13:00:11 UTC
nominating http://www.openoffice.org/issues/show_bug.cgi?id=94623
(View/Zoom/Optimal not centering)
Comment 18 IngridvdM 2009-09-08 13:48:09 UTC
adding issue 104867 (charts do not update anymore after changes in calc)
Comment 19 IngridvdM 2009-09-08 13:49:55 UTC
adding issue 104886 (mac: metafile replacements for OLE objects are not rendered
antialiased anymore)
Comment 20 clippka 2009-09-08 18:16:26 UTC
added issue 103179 as it screws up interoperability with odf created from
microsoft office, also issue 96406 as it is the same area and hinders
interoperability with koffice.

added issue 104579 as it is a regression to OOo 3.1.1 which results in data loss
in impress

added issue 96538 as it is a regression to OOo 3.0 that realy screws up
numberings in impress
Comment 21 Frank Schönheit 2009-09-09 09:08:30 UTC
adding issue 104901. See releases@ooo for a justification.
Comment 22 philipp.lohmann 2009-09-09 13:04:32 UTC
adding issue 104508 on behalf of tbo
Comment 23 joachim.lingner 2009-09-10 08:40:00 UTC
added issue  103747
Comment 24 mdxonefour 2009-09-15 14:53:28 UTC
MD: Adding 104937 and 105052
Comment 25 Oliver Brinzing 2009-09-16 18:56:59 UTC
added http://www.openoffice.org/issues/show_bug.cgi?id=105100
(m58/59: com.sun.star.task.XJob - broken "OnStartApp" event ?)
Comment 26 eric.savary 2009-09-18 11:01:30 UTC
added issue 105148
Comment 27 carsten.driesner 2009-09-18 11:02:45 UTC
cd:  Add myself on CC.
Comment 28 parity 2009-09-21 11:02:53 UTC
I want to nominate issue 94900 as a blocker issue for OOo 3.2. Actually it is
not possible to sort Subitems in Impress by copy+paste without ending up in
different fontsizes. Since very many users are affected by this bug, I think it
is worth a blocker.
Comment 29 carsten.driesner 2009-09-22 15:47:10 UTC
cd: adding issue 105263
Comment 30 stefan.baltzer 2009-09-22 17:03:55 UTC
Adding issue 104155 "Some docx documents crash on load". 
Already fixed in CWS writerfilter32bugfixes01.
Comment 31 uwe.luebbers 2009-09-22 17:20:11 UTC
added 94900
Comment 32 uwe.luebbers 2009-09-22 17:21:47 UTC
added 104057 and 104992
Comment 33 uwe.luebbers 2009-09-22 17:37:30 UTC
removed 105266 and added it to beta meta issue 104695
Comment 34 joachim.lingner 2009-09-23 10:11:43 UTC
Adding issue 105183 (nss update)
Comment 35 joachim.lingner 2009-09-23 10:16:05 UTC
Adding issue 104856 and issue 105194 (libxmlsec update, digital signatures)
Comment 36 uwe.luebbers 2009-09-23 11:57:42 UTC
added 105275
Comment 37 uwe.luebbers 2009-09-24 15:27:26 UTC
added 105234 and 103464
Comment 38 staffmm 2009-09-24 17:12:03 UTC
It would a amazing if we could finally have works compatibility in openoffice.

I'm aware of off shoots, such as Go-Oo.

But, if works compatiblity could be incorporated into the mainstream build of 
Oo, it would be a huge bonus, and would likely allow us, as a school, to finally 
move to Oo completely, as we wouldn't be relying on still using Office 2003, 
because of its Works compatibility addon.

http://qa.openoffice.org/issues/show_bug.cgi?id=8938

Thanks,

Matthew Millar
Comment 39 eric.savary 2009-09-24 22:41:39 UTC
Adding issue 105343
Comment 40 uwe.luebbers 2009-09-28 16:02:42 UTC
added 105035
Comment 41 uwe.luebbers 2009-09-28 16:12:30 UTC
added 105124
Comment 42 uwe.luebbers 2009-09-28 16:26:36 UTC
added 105371
Comment 43 uwe.luebbers 2009-09-28 16:34:37 UTC
added 105116, 105382, 105387 
Comment 44 uwe.luebbers 2009-09-28 16:42:41 UTC
and removed them, to attach it to beta meta issue
Comment 45 uwe.luebbers 2009-09-28 16:49:05 UTC
added 105386
Comment 46 uwe.luebbers 2009-09-28 17:54:38 UTC
added 105365
Comment 47 uwe.luebbers 2009-09-28 17:58:28 UTC
added 102224 
Comment 48 uwe.luebbers 2009-09-28 18:06:32 UTC
added 102048
Comment 49 uwe.luebbers 2009-09-28 18:13:07 UTC
added 105354
Comment 50 uwe.luebbers 2009-09-28 18:23:02 UTC
added 105430
Comment 51 uwe.luebbers 2009-09-29 17:27:15 UTC
added 105453
Comment 52 uwe.luebbers 2009-09-29 17:49:04 UTC
added 105373
Comment 53 uwe.luebbers 2009-09-30 10:43:29 UTC
added 105471
Comment 54 uwe.luebbers 2009-09-30 11:54:03 UTC
Added 105457 
Comment 55 uwe.luebbers 2009-09-30 12:32:38 UTC
removed 105326, because beta stopper
Comment 56 uwe.luebbers 2009-09-30 12:36:21 UTC
removed 105453 because beta stopper
Comment 57 joerg.skottke 2009-09-30 12:48:40 UTC
Added issue 105476 which is a crash in the help application (currently Solaris 
x86 only)
Comment 58 uwe.luebbers 2009-09-30 16:28:49 UTC
added 105430
Comment 59 uwe.luebbers 2009-10-02 11:21:59 UTC
added 105235,94242,105512,105508,105511,105489,
Comment 60 uwe.luebbers 2009-10-05 12:06:03 UTC
added 105605
Comment 61 uwe.luebbers 2009-10-05 16:23:53 UTC
added 102464
Comment 62 uwe.luebbers 2009-10-06 17:10:17 UTC
added 99866,103047,105654,105653
Comment 63 joerg.skottke 2009-10-07 09:13:53 UTC
Added issue 105670 which is a broken presentation template
Comment 64 mux2005 2009-10-07 18:02:59 UTC
I think issue 105322 should be a release blocker. It is a regression causing
data loss simply by saving an existing document.
Comment 65 joerg.skottke 2009-10-08 10:50:00 UTC
Added issue 105719 - when exporting BASIC libraries as extensions we end up with
a zero sized .oxt file.
Comment 66 uwe.luebbers 2009-10-08 15:06:20 UTC
added 105712
Comment 67 joerg.skottke 2009-10-09 13:15:59 UTC
Added issue 105760 - Extensible Help is broken
Comment 68 uwe.luebbers 2009-10-09 16:05:03 UTC
added 105716 
Comment 69 uwe.luebbers 2009-10-09 16:33:07 UTC
removed 105035 because "closed/duplicate"
Comment 70 uwe.luebbers 2009-10-12 12:02:45 UTC
added 105767
Comment 71 uwe.luebbers 2009-10-13 16:33:53 UTC
Added 105852,105856,105753,105065,105835
Comment 72 uwe.luebbers 2009-10-14 14:43:39 UTC
added 105724,105825,
Comment 73 uwe.luebbers 2009-10-16 15:57:36 UTC
added 105960,105958,103757,
Comment 74 stefan.baltzer 2009-10-16 16:11:50 UTC
Adding issue 102304 "Hypenation-dialog doesn't show hyphens anymore".
Comment 75 stefan.baltzer 2009-10-19 14:10:52 UTC
Adding issue 86464: "Help: Index tab page listbox is empty, Help page is blank".
Comment 76 uwe.luebbers 2009-10-19 16:03:09 UTC
added 104421
Comment 77 uwe.luebbers 2009-10-19 17:13:49 UTC
added 102257,106045,
Comment 78 eric.savary 2009-10-20 12:16:00 UTC
Added issue 106033
Comment 79 uwe.luebbers 2009-10-20 15:03:55 UTC
added 106068,106067,
Comment 80 joachim.lingner 2009-10-21 12:06:25 UTC
added issue 105926
Comment 81 uwe.luebbers 2009-10-21 14:34:58 UTC
added 106079,106080,106081,106082,106083,106084,106085,106130,106146,
Comment 82 stefan.baltzer 2009-10-21 17:25:13 UTC
Adding issue 106158 "Generating new AutoCorrect entry removes all entries".
Comment 83 Oliver Brinzing 2009-10-22 09:59:24 UTC
added http://qa.openoffice.org/issues/show_bug.cgi?id=101139
(after copying a protected sheet copy is unprotected)
Comment 84 uwe.luebbers 2009-10-23 15:15:22 UTC
Added 106164,106194,103611,101139,
Comment 85 mux2005 2009-10-23 16:59:36 UTC
I nominate issue 106151 as a blocker. It's a regression that may break a lot of
macro code and extensions. 
Comment 86 eric_openoffice 2009-10-25 16:38:52 UTC
Sound effects and sound playback in general brocken under Mac OS X 10.6.x.

Certain groups of OOo users consider sound in Impress to be an important feature
and so I nominate Issue 106261 as a showstopper for Mac OS X 10.6.x

http://qa.openoffice.org/issues/show_bug.cgi?id=106261
Comment 87 uwe.luebbers 2009-10-26 13:40:45 UTC
added 106214
Comment 88 uwe.luebbers 2009-10-27 16:37:24 UTC
Added 105769,106343,106351,
Comment 89 uwe.luebbers 2009-10-28 12:46:41 UTC
Added 106367
Comment 90 uwe.luebbers 2009-10-28 13:40:39 UTC
Added 106183,106349,
Comment 91 fyva 2009-10-29 18:51:37 UTC
Please, consider issue 105243 . This is a regression that happened between 3.1.0
and 3.1.1 .
Comment 92 Marcus 2009-10-30 11:10:14 UTC
added 103374
Comment 93 Marcus 2009-10-30 17:22:27 UTC
added 102434
Comment 94 stefan.baltzer 2009-11-05 15:36:41 UTC
Added issue 106479 "linguistic: languages incorrectly marked as supported"
Comment 95 stefan.baltzer 2009-11-05 16:09:19 UTC
Correction: 
Removed issue 106479 I mistakenly added.
Added issue 106497 "linguistic: languages incorrectly marked as supported"
Comment 96 uwe.luebbers 2009-11-09 12:45:29 UTC
added 105880
Comment 97 uwe.luebbers 2009-11-09 17:56:00 UTC
Added 106732
Comment 98 joachim.lingner 2009-11-10 08:17:41 UTC
Added issue 106624.
Comment 99 joerg.skottke 2009-11-10 13:58:38 UTC
Added issue 106766: Crash when closing extension update -> regression from m3 to m4.
Comment 100 uwe.luebbers 2009-11-10 16:27:21 UTC
added 106523
Comment 101 uwe.luebbers 2009-11-10 16:36:02 UTC
added 100658
Comment 102 uwe.luebbers 2009-11-12 15:29:57 UTC
Added 106859,105238,106730,
Comment 103 eric_openoffice 2009-11-13 10:29:16 UTC
As discussed on the Mac Porting Mailinglist I'm adding Issue 106863 "Spotlight
search in native file picker freezes OOo" to this showstopper list. 
Comment 104 uwe.luebbers 2009-11-16 11:00:39 UTC
Added 106930
Comment 105 uwe.luebbers 2009-11-16 17:44:23 UTC
Added 106941,106904,105710,106816,
Comment 106 uwe.luebbers 2009-11-17 17:20:31 UTC
Added  106901,
Comment 107 uwe.luebbers 2009-11-19 14:31:47 UTC
Added 107006
Comment 108 uwe.luebbers 2009-11-19 14:39:28 UTC
Added 106854
Comment 109 uwe.luebbers 2009-11-19 17:44:44 UTC
Added 107035
Comment 110 eric.savary 2009-11-20 12:16:43 UTC
Added 107075 - Calc crashes on calling the functions AutoPilot while Orca is running
Comment 111 uwe.luebbers 2009-11-20 12:21:34 UTC
Added 107049,107003,107075,
Comment 112 uwe.luebbers 2009-11-20 14:58:15 UTC
Added 107076
Comment 113 uwe.luebbers 2009-11-23 12:03:55 UTC
Added 107064,107047,
Comment 114 uwe.luebbers 2009-11-23 12:29:42 UTC
Added 107139,
Comment 115 uwe.luebbers 2009-11-24 15:49:34 UTC
Added 101821,107170,107151,
Comment 116 uwe.luebbers 2009-11-24 18:03:29 UTC
Added 107143,
Comment 117 uwe.luebbers 2009-11-25 12:29:58 UTC
Added 107087,
Comment 118 uwe.luebbers 2009-11-27 11:15:13 UTC
Added 107204,107166,
Comment 119 uwe.luebbers 2009-11-27 16:16:43 UTC
Added 107263,107248,107275,
Comment 120 uwe.luebbers 2009-12-04 12:08:03 UTC
Added 107401,107440,107365,106833,107358,
Comment 121 uwe.luebbers 2009-12-07 11:53:48 UTC
Added 107485,
Comment 122 uwe.luebbers 2009-12-07 14:00:26 UTC
Added 105988,
Comment 123 uwe.luebbers 2009-12-08 13:24:40 UTC
Added 107501,107525,
Comment 124 joachim.lingner 2009-12-08 14:05:13 UTC
adding issue 107528
Comment 125 uwe.luebbers 2009-12-08 18:54:31 UTC
Added 105172,
Comment 126 uwe.luebbers 2009-12-10 13:05:59 UTC
Added 107512,
Comment 127 uwe.luebbers 2009-12-10 16:07:23 UTC
Added 104974,
Comment 128 uwe.luebbers 2009-12-21 11:49:06 UTC
Added 107804, 
Comment 129 Rainer Bielefeld 2009-12-23 08:05:30 UTC
I nominate regression Issue 107839 "Problem to select slides with linked
pictures, also in DRAW"
Comment 130 Rainer Bielefeld 2009-12-25 09:30:56 UTC
I nominate Issue 107882, WRITER without ability to send mail merge emails would
be not acceptable
Comment 131 uwe.luebbers 2009-12-28 10:57:00 UTC
removed 107882
Comment 132 uwe.luebbers 2009-12-28 11:07:19 UTC
Added 107845,107877,
Comment 133 uwe.luebbers 2009-12-28 12:58:55 UTC
Added 107966,107965,
Comment 134 jms32935 2010-01-03 22:44:13 UTC
 Issue 53184, which is a P3 problem that is targeted for this release, is Not
fixed correctly in OOo_3.2.0rc1.  See the issue comments...
http://qa.openoffice.org/issues/show_bug.cgi?id=53184
Comment 135 stefan.baltzer 2010-01-04 14:36:46 UTC
Adding issue 105565 as discussed in Release Status Meeting today.
Comment 136 stefan.baltzer 2010-01-04 17:53:19 UTC
Adding issue 105565 as discussed in Release Status Meeting today.
Comment 137 Rainer Bielefeld 2010-01-13 13:22:01 UTC
Nominate Issue 108004: hyperlinks do not change focus to already opened OOo document
Comment 138 uwe.luebbers 2010-01-13 15:37:51 UTC
removed 108004, please read the issue.
Comment 139 uwe.luebbers 2010-01-14 16:25:37 UTC
Added 108325
Comment 140 Rainer Bielefeld 2010-01-21 05:15:02 UTC
I nominate Issue 107967. Please excuse me for the late decision, but the efforts
I saw until now to eliminate this crash problem are really not sufficient.
Please decide whether you can risk to release a version with such an instability
risk in all RC I used until now (while I am writing these words, OOo is
recovering in background after my first crash).
Comment 141 uwe.luebbers 2010-01-22 14:26:20 UTC
Added 108423,
Comment 142 uwe.luebbers 2010-01-22 14:29:16 UTC
Added 108488,
Comment 143 uwe.luebbers 2010-01-22 14:33:13 UTC
Added 108512,
Comment 144 uwe.luebbers 2010-01-22 14:36:31 UTC
Added 108534,
Comment 145 uwe.luebbers 2010-01-22 14:46:43 UTC
Added 108559
Comment 146 uwe.luebbers 2010-02-01 17:49:59 UTC
Added 107763,107957,108426,108610,108813,
Comment 147 e_christenson 2010-02-06 02:11:01 UTC
I nominate the comments on issue 99999 as almost unreadable.  Referencing 
issues by number without at least a quick description should be quite gauche (a 
faux pas that should be denigrated).  This also goes for the dependencies at 
the top of the issue.

I also note that an issue this large needs some organization.  Since there are 
no release notes (or at least weren't in the middle of January), it would be 
very helpful to organize this issue (and its dependencies) by topic.
Comment 148 cno 2010-02-06 07:46:09 UTC
@  e_christenson:
It is usefull that I know which issue is added. I see no problem in going to
that issue to find more info.
Wrt to topics: there is only one topic here: issues that must be fixed.
If you would like of need some more organising, of course you can do that.
Cor
Comment 149 jms32935 2010-02-06 08:36:08 UTC
 Regarding readability of comments, and "going to that issue to find more info"...

 It would help readers going to issues if the issue numbers in comments were
entered as clickable links instead of just bare numbers.  For example, Added
issue 53184 vs just Added 53184.  If I understand correctly, merely adding the
word "issue" in that example makes it a clickable link.  (I hope that worked,
sorry if it didn't, but I won't know for sure until I submit...)
Comment 150 tommy27 2010-02-07 12:26:06 UTC
@jms32935

good point. i 100% agree with you
Comment 151 uwe.luebbers 2010-02-08 12:21:59 UTC
Removed 105430, because the status "reopened" only affects the DEV codeline.
Comment 152 tommy27 2010-02-13 21:53:23 UTC
let's close this issue. 

OOo 3.2 is already released
Comment 153 tommy27 2010-02-13 21:53:29 UTC
let's close this issue. 

OOo 3.2 is already released
Comment 154 mdxonefour 2010-02-15 09:48:44 UTC
MD: OOo 3.2 is released. Closing meta issue accordingly.
Comment 155 mdxonefour 2010-02-15 09:55:05 UTC
.