Issue 100007 - Export to pdf replaces roman numerals by Arabic numerals.
Summary: Export to pdf replaces roman numerals by Arabic numerals.
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Math
Classification: Application
Component: code (show other issues)
Version: OOo 3.0.1
Hardware: Unknown Linux, all
: P3 Trivial (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on: 86811 107358
Blocks:
  Show dependency tree
 
Reported: 2009-03-07 17:49 UTC by liesvanrompaey
Modified: 2009-12-02 09:09 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
original OO document (553.55 KB, application/vnd.sun.xml.writer)
2009-03-08 15:17 UTC, liesvanrompaey
no flags Details
PDF version of document (74.85 KB, application/pdf)
2009-03-08 15:18 UTC, liesvanrompaey
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description liesvanrompaey 2009-03-07 17:49:24 UTC
I make math courses. I use OO Writer (3.0.1.). I use OO Math to insert formulas.

In the OO document everything looks fine.

When I export the document to pdf, the formulas are no longer readable, because
some of the numbers (never all of them) have been replaced bij numbers in Arabic
script.

When I try to export again, I do not get the same results. Other numbers (more
or less, again never all of them) have been replaced. If I repeat the export
often enough I sometimes get a document with no "errors".

The problem seems to occur more frequently when the numbers are under a square
root or in the denominator of a fraction.

Example at: http://materiaal.edulogos.org/Screenshot-21.png



Sorry if I picked the wrong subcomponent.
Comment 1 Rainer Bielefeld 2009-03-08 07:57:47 UTC
@liesvanrompaey:
Please attach a sample document!
Comment 2 liesvanrompaey 2009-03-08 15:17:38 UTC
Created attachment 60813 [details]
original OO document
Comment 3 liesvanrompaey 2009-03-08 15:18:38 UTC
Created attachment 60814 [details]
PDF version of document
Comment 4 Rainer Bielefeld 2009-03-08 19:39:00 UTC
I checked with "Ooo 3.0.1 (DE) Multilingual version GERMAN UI WIN XP: [OOO300m15
(Build 9379)]" and "wortels.odt". I can NOT confirm the reported effect distortions.

Same with 2.4.1.

Comment 5 hdu@apache.org 2009-03-09 14:41:40 UTC
I can't reproduce it either (in 3.0.1 or OOO310_m4) yet. It reminds me of issue 86811, which was fixed for 
OOo2.4.1 by hbrinkm. From the symptoms this issue looks as if the "digit language" of the formula 
objects got overwritten somewhere starting with reek2.18. Is it possible to reduce the problematic 
document down to as few lines as possible?
Comment 6 liesvanrompaey 2009-03-09 18:08:48 UTC
I can't explain why or how, but the problem doesn't occur anymore.

On the OO formum another user mentioned the same problem. I'm quoting his
comment: "I am running OOo 2.4 in Kubuntu Hardy (8.04) amd64. Interestingly, if
I remember correctly, I tried a PDF export at university using OOo 2.4 but in
Windows XP (32-bit edition). As far as I remember, there was no corruption.
Perhaps 32-bit editions are safe for some reason?"
Comment 7 michael.ruess 2009-03-24 12:17:54 UTC
Closing issue.