Issue 100090 - Impress showing blank slide show
Summary: Impress showing blank slide show
Status: CONFIRMED
Alias: None
Product: Impress
Classification: Application
Component: viewing (show other issues)
Version: OOo 3.0.1
Hardware: Unknown Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
: 101208 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-03-10 12:18 UTC by nemuelpah
Modified: 2017-05-20 11:28 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Pictures (90.12 KB, application/octet-stream)
2011-09-17 13:57 UTC, Ray
no flags Details
Templates of resume and business cards (deleted)
2011-10-04 16:05 UTC, Weisi Ding
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description nemuelpah 2009-03-10 12:18:14 UTC
I just upgrade to OOo3.0.1. I've got a problem with Impress. After creating a
new .odp documents and save it, I could not have the proper slide show. When I
clicked on "Slide Show" (or press F5) it showed a white full screen. If I press
the ESC it ends the slide show. The same problem happened when I open a ppt file.
Comment 1 wolframgarten 2009-03-10 12:24:08 UTC
Please try to uncheck tools/options/view/graphics output/use hardware acceleration.
Comment 2 eric.bachard 2009-03-11 07:13:53 UTC
+cc for me

Interesting, I got the same issue implementing OpenGL transitions. Before the transogl03, I had the blank 
screen at the end, now got it at the begining. Looks like we render an empty frame (but the issue is 
maybe something different, I can be wrong)

@wg : you mean this is hardware acceleration related ?  Can you tell me more ? Thanks in advance

Comment 3 nemuelpah 2009-03-11 08:43:32 UTC
Thanks for the help. I tried the wg suggestion (uncheck
tools/options/view/graphics output/use hardware acceleration) and it is now
working well. But, I have the same question as ericb 'is this a hrdware problem?'
Comment 4 wolframgarten 2009-03-11 09:10:30 UTC
Reassigned. @af: can you add some info about the reason , please? I think this
is duplicate already.
Comment 5 groucho266 2009-03-11 10:11:27 UTC
@ nemuelpah,ericb: When turning off the hardware acceleration makes the blank
screen go away, then this indicates a bug in the hardware dependent part of the
slide show implementation.  The canvas, for instance.  However, I would have to
be able to reproduce this problem to be sure.
Can you tell us what OS, graphics cards and drivers you are using?

@ericb: When the changes in transogl03 made the blank screen move from the end
to the start of the presentation then you may be very close to the root cause. 
Do you have any idea what change may have caused that?
Comment 6 eric.bachard 2009-03-11 11:35:14 UTC
@wg : in fact, I'm searching since months (ssa was the first to identify the issue, but like me, was not 
able to find the exact root).

So I'm searching, and after being discussed a lot of times with Thorsten and other, we agreed this issue 
could be caused by either :

- we render an empty slide (and Caolan debug stuff is very helpfull since we have the slide numbers )
- there is a timers issue somewhere.

What let me think this can be a timer issue, is the flicker does not appear every times. 

I'll investigate, but not before this week end, because my day job eats all my energy, sorry :/


Can be important: 

if you read my changes in ogltrans4mac cws, in particular in the 
OGLTransistionerTransitionImpl_MACOSX.mm , I commented the canvasArea stuff, because it was 
returning NULL (causing crashes). The bad thing is I modified Radek (or Caolan maybe) implementation, 
because OGLTransitionerImpl::createWindow() didn't work as expected. As a first approach, to make it 
work again (I'll retry the right way asap) I reused OGLTransitionerImpl::initWindowFromSlideShowView.

To save yout time, the commented code is : 
/*
    awt::Rectangle aCanvasArea = mxView->getCanvasArea();
    pWindow->SetPosSizePixel(aCanvasArea.X, aCanvasArea.Y, aCanvasArea.Width, aCanvasArea.Height);
    GLWin.Width = aCanvasArea.Width;
    GLWin.Height = aCanvasArea.Height;
    OSL_TRACE("canvas area: %d,%d - %dx%d", aCanvasArea.X, aCanvasArea.Y, aCanvasArea.Width, 
aCanvasArea.Height);

*/

I'll keep you informed if I find other information, or simply progress
Comment 7 wolframgarten 2009-04-22 08:42:12 UTC
*** Issue 101208 has been marked as a duplicate of this issue. ***
Comment 8 zjj303 2010-09-11 19:52:59 UTC
OS: windows XP SP3 v.5973
OOc Version: Dev_000330m6 Build:9524
Intel T2130, 2gb ram, intel 943 motherboard, intel GMA 950, 80gb hard disk
no other application was running
network connected

I don't have the version 3.0.1, so I use 330m6 and 3.3.0 beta1 to test.

But in both version, I can't reproduce the problem with the following steps:

1. opened the OOc presentation and created a empty slide
2. added a new slide and wrote something on both
3.saved the impress as .odp file
4. pressed F5, the slides showed perfectly
5. modified the transition to random and try again, it still worked
6. exit OOc, used MS powerpoint to create a .ppt file
7. opened OOc, loaded that .ppt file and pressed F5, no problem
8. uncheck tools/options/view/graphics output/use hardware acceleration
9. went back to step1 and retested it. nothing wrong

then, I used DEV_3.3.0 beta1 to test it, yet the problem didn't occur.

As wg said, after uncheck tools/options/view/graphics output/use hardware
acceleration, slides showed normally and perhaps that's a hardware dependent
bug. I agree so. Also, it may be resulted in drivers and graphic card configuration.
Because I don't have another computer for testing. So, I think to do a
following-test like this may help:
update drivers and retest; change another graphic card and retest; set
acceleration mode to D3D or OpenGL and retest.

If this bug did exist , it would make users lose confidence on OOc as its basic
job, to design presentation, did not work.

Comment 9 brainfreeze91 2010-09-12 02:08:49 UTC
OS: Win 7 32-bit
OOo version: Developer snapshot 330m7
Graphics: ATI Radeon 3100 (thought this might be pertinent considering it might
be a hardware problem)

I was able to recreate the error using these steps:
-Made a new presentation
-Made 2 slides with some writing on them
-Saved as .odp and exited
-Reopened, and immediately pressed F5
-On my initial run, the screen flashed black and white for several seconds, then
after some clicking showed the slides
-Continued opening, reopening, pressing F5 and the slide show button, and
unchecking and rechecking the "use hardware acceleration" box, but could not
repeat the several-second black and white flash.
-Instead every time it went to slide show there was a very, very short flash of
black and white and the slides immediately appeared.

My error appeared when I pressed F5 right when the project loaded. Maybe this
problem has to do with the way Impress loads its presentations? It might not
initially load the tools needed to start the presentation but instead start
loading those tools once the project is displayed.
It might be a hardware implementation problem like previous posters mentioned,
though disabling the use of hardware acceleration produced no difference for me.
(The initial test where the problem occurred was using hardware acceleration
though.)

It seems like this might be a duplicate error to Issue 101208 like previously
mentioned, but that issue is closed now and I still am getting that error in the
latest build (I updated the beta of OOo right before testing this error).
Comment 10 Ray 2011-09-17 13:53:06 UTC
I am able to reproduce the 'full white screen' problem as reported.

- Intel Q6600 with 4Gb
- Windows 7 Ultimate x64 
- OO 3.4.0 DEV300m106 (build 9582)

Steps to reproduce:

1) Start OO (using Quickstarter) 
2) Choose Presentation and start with a new (blank) presentation
3) Select default text in body text frame (picture step3a.png/step3b.png)
4) Enter a text 'This is a text' (picture step4.png)
5) <F5>
=> Presentation shows a white screen
7) <Enter> or <space> and I get "Click to exit presentation" message and exit with <ESC>
8) <F5>
=> Again presentation shows a white screen

I did some follow-up tests:
I start with the sequence above up to step 7
9) Add another line in the slide
10) <F5>
=>) White screen no text

When I cycle through <F5> - <Esc> I am consistently able to get the white screen. As soon as I force focus on the frame itself the slide is properly shown:
Step 1 to 7
11) In edit mode press <ESC>
=> Frame is selected (picture step11.png) 
12) Select <F5>
=> Text is properly displayed
This also happens when I defocus the edit frame with a mouse click somewhere else on the screen.

I have extended the test to more slides:
Step 1 - 7
13) Insert new slide (right mouse in slides panel OR menu insert/slide)
14) Add some text in title (picture step13.png)
15) Press <f5>
=> White screen no text
16) <Left Arrow> 
=> Text on slide 1 is shown (!!)
17) <Right Arrow>
=> Blank screen with no text

I also tried this /after/ I had a properly shown a slide (steps 1-7 and 11/12).
Continuing with step 13 - 17 showed correct slides /except/ the last added. 

The difference can be illustrated by picture empty.png and not_empty.png. As soon as the text is shown in the specific slide as shown in the 'slide pane', the slide is properly shown in the slideshow. It seems that the presentation slides are not 'aware' of the latest update in the edit mode.

With this thought I extended the test:
Step 1 - 7 and 11/12 => slide is correctly displayed
Step 13/14 
18) Defocus
19) Press <F5>
=> Title is correctly shown
20) <Esc>
21) Select text in body by directly selecting /the default text/ 
22) Add text (picture AddedText.png)
23) <F5>
=> Title is shown but added text is missing ((picture AddedTextShow.png - red box comment by me)

Note: I also noticed one instance where the edit mode text was different from what was shown in the 'slide panel', but the show did present the complete text from the edit mode. I have not researched this further to reproduce at this point (picture TextDifferent.png).

I also tried this on a DELL Insprion M6300, Windows 7 Professional x86, 4Mb
Same version OO. The (mis)behaviour is the same.

I also verified the behavior with Powerpoint Professional Plus 2010 (14.0.6106.5005), but that does not exhibit this problem. The biggest difference I notice is that when I am typing a text in a Powerpoint slide this text is simultaneously entered/updated in the slide in the slides panel. 

The setting (on or off) of, in other reports mentioned, [tools/options/view/graphics output/use hardware acceleration], has no effect on this behaviour.

I also checked the original report with a saved presentation.  
1) save the 1 slide presentation as ODP
2) Quit OO
3) Restart by opening saved ODP
4) Press <F5>
=> Text is shown
5) Add new slide
6) Add text
7) Press <F5>
=> Last slide is shown as white (no text)

As mentioned earlier: this problem could undermine confidence in OO (presentation) as a trustworthy alternative to Powerpoint.
Comment 11 Ray 2011-09-17 13:57:52 UTC
Created attachment 76785 [details]
Pictures

Pictures as mentioned in comment 10
Comment 12 Weisi Ding 2011-09-27 17:25:58 UTC
Intel i5 with 4Gb
Windows 7 Ultimate x64 
OO 3.4.0

I can replicate the bug in the comment written by Ray, but I still have problems to replicate the bug in the original report.

I found that the latest updated text couldn't show correctly without saving.Once I saved the file I was working on, everything showed correctly.

   1. I added a text to the file without saving, the new text didn't show up until I saved it. I repeated it several times on the same file, the same problem happened. This problem only happened if I input texts.

   2.Before I saved the file, I entered a text in the body part, then entered a text in the title part. The body part showed correctly, the text in the title part disappeared. If I changed the order, entered a text in the title part first, entered a text in the body part later, title part showed correctly, the text in the body part disappeared.
Comment 13 Weisi Ding 2011-10-04 16:05:21 UTC
Created attachment 76860 [details]
Templates of resume and business cards

I downloaded some templates of resume and business cards from openoffice.org. I used these templates to do follow-up test.
Comment 14 Weisi Ding 2011-10-04 16:15:23 UTC
Sorry. Comment 13 is a mistake. Please delete it.
Comment 15 Rob Weir 2013-02-02 02:55:15 UTC
This Issue requires more information ('needmoreinfo'), but has not been updated
within the last year. Please provide feedback as requested and re-test with the the latest version of OpenOffice - the problem(s) may already be addressed. 

You can download Apache OpenOffice 3.4.1 from http://www.openoffice.org/download

Please report back the outcome of your testing, so this Issue may be closed or
progressed as necessary - otherwise the issue may be Resolved as Invalid in the
future.
Comment 16 Rob Weir 2013-04-05 14:24:21 UTC
The content of attachment 76860 [details] has been deleted by
    Rob Weir <robweir@apache.org>
who provided the following reason:

attached to wrong issue

The token used to delete this attachment was generated at 2013-04-05 10:24:08 EDT.
Comment 17 Rob Weir 2013-04-05 14:25:14 UTC
Comments indicate at least 3 confirmations of the bug, so I'm changing status to CONFIRMED.
Comment 18 Marcus 2017-05-20 11:28:08 UTC
Reset assigne to the default "issues@openoffice.apache.org".