Issue 100107 - Add Maori (New Zealand) [mi-NZ] locale data.
Summary: Add Maori (New Zealand) [mi-NZ] locale data.
Status: CLOSED DUPLICATE of issue 89907
Alias: None
Product: Internationalization
Classification: Code
Component: localedata (show other issues)
Version: OOO310m3
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: ooo
QA Contact: issues@l10n
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-03-10 20:27 UTC by lcn
Modified: 2013-08-07 15:00 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description lcn 2009-03-10 20:27:30 UTC
I would like to select Maori (New Zealand) language as default language.

In Writer, it is not available in Tools/Language/For all text/More… (aka
Tools/Options…/Language settings/Languages/Default languages for documents).

In Writer, it is available in Tools/Language/For selection/More… and
Tools/Language/For paragraph/More…
It's not the same languages in for Tools/Language/For all text/More…,
Tools/Language/For selection/More… and Tools/Language/For paragraph/More… ?

Because of this problem, maori language can't be used in Calc and Impress.
Comment 1 lcn 2009-03-12 10:24:21 UTC
I played with Calc OOO310m3.

If Maori spell checker extension is installed.
Maori spell ckecker can be used in Calc and Impress.

In Calc, you go to Format/Cell…/Font. In the language selection, Maori (New
Zealand) is avialable.

In Impress, you select the text, go to Format/Character…. In the language
selection, Maori (New Zealand) is avialable.

In Draw, you go to Format/Cell…/Font. In the language selection, Maori (New
Zealand) is avialable.
Comment 2 lcn 2009-03-12 10:37:46 UTC
Tools/Spelling or Tools/Spelling and grammar depends of the language of character.
So, before using the spell checker, select the text and apply a language.

In Tools/Spelling or Tools/Spelling and grammar, you can't select the language
for a paragraph or for all the document.
Comment 3 thomas.lange 2009-03-12 10:41:39 UTC
Since the language Maori (New Zealand) is available in the Format/Character
dialog in e.g. Writer it is available for spell checking etc. if respective
dictionaries are installed.

That the same language is not available in the list boxes of the "Tools/Options
- Language Settings - Languages" dialog is, AFAIK, simply due to the fact that
there is no locale data for Maori provided yet. If I'm not mistaken the language
list boxes in that dialog require locale data in order to have a language
listed. But if it is available here or not does not have any impact on spell
checking etc. But of course you can't have Maori set as default document
languages as long as the locale data is missing.

Thus if you want Maori to be fully functional please provide locale data for it.

TL->ER: This one seems to be for you if locale data will be provided.
Please correct what I have said above if something was wrong.
 
Comment 4 lcn 2009-03-12 11:25:24 UTC
Thank for the explanation.
I can't do the translation of the locale data.

Close this issue if you want.
Or wait for the translated locale data file from someone else.



Comment 5 ooo 2009-03-12 12:25:08 UTC
We can keep the issue and set the needhelp keyword, so maybe someone interested
can jump in.

For how to submit locale data please see
http://wiki.services.openoffice.org/wiki/How_to_submit_new_Locale_Data
Comment 6 ooo 2009-03-12 14:03:31 UTC
Better summary. ISO codes mi-NZ, mapping to LCID 0x0481.
Comment 7 lohmaier 2009-03-30 14:49:19 UTC
localedata for Maori attached to issue 89907

*** This issue has been marked as a duplicate of 89907 ***
Comment 8 lohmaier 2009-03-30 14:50:38 UTC
closing dupe - the other issue unfortunately was assigned to the reporter.

and sorry, no localedata attached yet, my fault. Duplicate anyway