Issue 100318 - Windows Shortcuts not working in OO-dialogs
Summary: Windows Shortcuts not working in OO-dialogs
Status: CLOSED DUPLICATE of issue 4306
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 2.4.1
Hardware: PC Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-18 18:01 UTC by sos
Modified: 2017-05-20 10:01 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: 4.0.0
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description sos 2009-03-18 18:01:41 UTC
Windows shortcuts are seen als a "file" and not as a "shortcut" when suing OO-
dialogs instead off System Dialogs 
I found a soluting for Filepickerdialogs run from the API:
Sub test( ) 
Dim oleService , wso
Dim sFilePickerArgs  
sFilePickerArgs = Array
(com.sun.star.ui.dialogs.TemplateDescription.FILEOPEN_SIMPLE) 'FILESAVE_AUTOEXTE
NSION)
dlgFile = CreateUnoService ("com.sun.star.ui.dialogs.FilePicker")
with dlgFile
	   	.Initialize(sFilePickerArgs())
		.SetMultiselectionMode (false)
		.Title = "Kies Attachement"
	    .setDisplayDirectory(ConverttoURL(spath )) 
  	END with

	sSluitpicker = dlgFile.Execute ()
	If 	sSluitpicker = 1 Then
		Dim selFiles() As Object
		selFiles = dlgFile.GetFiles()
		sFilePath = convertfromurl(selFiles(0))
	   	END If
	If 	sSluitpicker = 0 Then
    exit sub
    endif
if  ucase( right(sfilepath,4)) = ".LNK" then ' it's a Shortcut
print "hier"
oleService = createUnoService("com.sun.star.bridge.OleObjectFactory") 
wso = oleService.createInstance("Wscript.Shell") ' is pressent on every Windows 
machine
'fso = oleService.createInstance("Scripting.FileSystemObject")
linkje = wso.CreateShortcut(sFilepath)
print linkje.targetpath 
endif
print "Normal filepicker procedure"
End Sub

please do something simular for the dialogs run in the GUI

Thanks
Fernand
Comment 1 Edwin Sharp 2013-04-12 12:49:40 UTC
Opening a shortcut brings the target file correctly.
Rev. 1466899 Win 7
Comment 2 Rainer Bielefeld 2014-02-02 07:49:45 UTC
Wrongly marked as FIXED, Summary explicitly mentions " OO-dialogs" (opposite of OS-Dialogs! 

Still Reproducible with server installation of "AOO 4.1.0-Dev – English UI / German locale - [AOO410m1(Build:9750) - Rev. 1562493 - 2014-01-30]" on German WIN7 Home Premium (64bit)", own separate user profile.

So reopened!
Comment 3 Rainer Bielefeld 2014-02-02 08:17:05 UTC
This one is a DUP of "Bug 4306 - AOO File dialog opens *.lnk itself as document instead of opening linked document"

*** This issue has been marked as a duplicate of issue 4306 ***