Issue 100448 - Figure cross-reference error in master document
Figure cross-reference error in master document
Status: CLOSED DUPLICATE of issue 11174
Product: Writer
Classification: Application
Component: formatting
PC Windows XP
: P3 Trivial with 6 votes (vote)
: ---
Assigned To: Oliver Specht
: needmoreinfo, oooqa
Depends on:
  Show dependency treegraph
Reported: 2009-03-21 17:50 UTC by celem
Modified: 2013-08-07 14:44 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Bugdoc (895.05 KB, application/x-gzip)
2009-03-23 09:30 UTC, eric.savary
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description celem 2009-03-21 17:50:58 UTC
I have the same "Figure cross-reference error in master document" with OO Writer
on Windows XO as reported on Ubuntu in LaunchPad bug #289614, see

Some references to figure captions inserted into subdocuments are incorrect in
master document.

Figure caption added using right click on image and choosing "caption".
Reference to caption added using "insert"->"cross-reference".

This only occurs on some cross-references. Everything is correct in the
subdocument but the reference is incorrect in the master (i.e. is refers to the
wrong figure).

See the URL for an example of the problem.

I am using version 3.0.1, OOO300m15, build 9379, on Windows XP
Comment 1 eric.savary 2009-03-23 09:30:45 UTC
Created attachment 61108 [details]
Comment 2 eric.savary 2009-03-23 09:39:00 UTC
Please check this in a native OOo build.
This is not reproducible in a native 3.0.1.

Feel free to reopen when you have a reproducible scenario and can tell exactly
where this happens.

(Else I filed issue 100472 for the document crashes OOO310m6)
Comment 3 eric.savary 2009-03-23 09:46:08 UTC
Comment 4 ccheney 2009-03-23 18:18:07 UTC

"I am using version 3.0.1, OOO300m15, build 9379, on Windows XP" what part of
that is not a native build... perhaps you should read the bug reports before
telling the users to use what they already are?
Comment 5 ccheney 2009-03-23 18:19:00 UTC

Note this user did file the bug report on the Ubuntu bug tracker for some
unknown to me reason... but he is using WINDOWS XP!
Comment 6 celem 2009-03-23 21:37:01 UTC
I did not file an issue on the Ubuntu bug tracker, rather I posted a comment to
an existing bug started by jackocleebrown who uses both Windows XP SP3 and
OpenOffice 2.4.1. I also use Ubuntu but not for this particular OpenOffice
project. My Ubuntu comment was done to indicate that the problem spans both
operating systems and thus is an OpenOffice Writer problem and not OS related.
Comment 7 eric.savary 2009-03-24 14:46:10 UTC
So please attach a sample document where this problem is reproducible or if it
is reproducible with the document I attached from your link, please tell us
where exactly (which figure and reference).

Please also try a dev 3.1, this may be already fixed
Comment 8 celem 2009-03-24 18:48:59 UTC
I deposited a copy of my document that exhibits the problem. It is 28Mb and
consists of a Master file and multiple sub documents. The site has a
password of “289614” and will exist for one week.

Open the document named Master.odm

Incorrect figure references in the Master document start appearing on page 52
where Figure 11 is referenced as 19.  Oddly, the next references on page 53
through 57 are correct and then on page 58 the references for figures 16 and 18
are correct but the figure 21 reference is wrong - it should have been 17.

These inconsistent errors continue randomly throughout the master document
Comment 9 eric.savary 2009-03-25 21:08:51 UTC
@OS: I couldn't find out what happens there.
I will add a shorten version of the sample document.
The problem is there visible on page 3.
Comment 10 eric.savary 2009-03-26 21:10:41 UTC
@OS: Due to MTU Problems @ home I can't attach the file. I'll send it by e-mail.
Comment 11 dynapb 2009-10-27 21:36:32 UTC
This is a problem for me also.  I changed from MS Word Master Documents which 
suck the big one to OOo Writer because it seemed a lot more stable.  I am just 
getting my Master doc together in OOo and ran into this bug.  It needs to be 
fixed to keep OOo a strong compeditor to MSWord.  I use OOo 3.1 and XP.

This issue looks the same as 11174 which shows it's for All Operating Systems.
Comment 12 eric.savary 2010-04-17 09:43:20 UTC

*** This issue has been marked as a duplicate of 11174 ***
Comment 13 eric.savary 2010-04-17 09:43:37 UTC