Issue 100467 - changes in standard values of the table do not get saved
Summary: changes in standard values of the table do not get saved
Status: CONFIRMED
Alias: None
Product: Base
Classification: Application
Component: code (show other issues)
Version: OOO310m7
Hardware: PC All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords: needhelp
Depends on:
Blocks:
 
Reported: 2009-03-22 23:46 UTC by ud
Modified: 2013-01-29 21:47 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Example (2.91 KB, application/vnd.sun.xml.base)
2009-03-22 23:48 UTC, ud
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description ud 2009-03-22 23:46:40 UTC
I created an table in HSQLDB with integer fields. I set default values. Later i
want to change the default value by using the edit tables menu. But the changes
do not get saved. I want to create an example but there were a lot of different
results so i do not get the one working way.

Please play a little bit like: change default values, save, close table, refresh
tables, edit tables again. Important is to click the view/Refresh tables button.

-Please notice, this example was build with OOO310m7
-Open attached Database
-right click to open the table "Example"
-go to row "ONE" and change default value from 1 to 10
-save table by clicking
-go to row "TWO" and change default value from 3 to 20
-save table by clicking
=> You can see that the default value is lost in field "ONE"
-close table
-click on view/Refresh tables
-edit table "Example" again
=> In my example the default values always go back to previous
   values after doing this 
=> If i rename the column sometimes i get the default value for the
   row saved.
=> Once i couldn't get any default values in 310m7 any more, but
   after opening the same file in OOo3.0.1 the default values from
   before where back again, also in OOO310m7.
Comment 1 ud 2009-03-22 23:48:32 UTC
Created attachment 61106 [details]
Example
Comment 2 Mechtilde 2009-04-24 21:45:21 UTC
I can reproduce it under GNU/Linux,

 but I  don't know if it works as designed
Comment 3 ud 2009-10-17 19:24:25 UTC
I checked in OOO320m2 and the problems i had, i could not reproduce them again
on WinXP SP3. So i can say that it WORKSFORME.