Issue 100633 - crash after moving frame onto another frame due to invalid RTF import
Summary: crash after moving frame onto another frame due to invalid RTF import
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.0.1
Hardware: Unknown All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Depends on:
Reported: 2009-03-28 22:44 UTC by raal
Modified: 2017-05-20 11:19 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

test file (400.39 KB, application/msword)
2009-03-28 22:47 UTC, raal
no flags Details
bug description (55.84 KB, application/vnd.oasis.opendocument.text)
2009-03-28 22:48 UTC, raal
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description raal 2009-03-28 22:44:58 UTC
1 - open file testfile.doc
2 - drag frame (name "Rámec3")
3 - move to frame name "Rámec2"
3 - drop
4 - OOo crash

Actual results:
OOo crash

Expected results:
OOo does not crash

Reproducible always

See file bug_description.odt with screenshots.
Comment 1 raal 2009-03-28 22:47:33 UTC
Created attachment 61246 [details]
test file
Comment 2 raal 2009-03-28 22:48:16 UTC
Created attachment 61247 [details]
bug description
Comment 3 eric.savary 2009-03-29 17:05:10 UTC
Reproduced in OOO310m6. Don't know where to reassign.

@raal: Thanks for the clear description! :)
Comment 4 michael.ruess 2009-03-30 13:58:30 UTC
MRU->OD: open the attached document, select frame3 (the one containing "Datum...
Vyrizuje...") abd move it onto Frame2 on the right -> crash. Worked fine in OOo 2.4.
I also get a crash when just opening and closing the document. Maybe these are
the same crashes. I have submitted a report for each; maybe we can compare these
Comment 5 Oliver-Rainer Wittmann 2009-04-03 12:18:12 UTC
First look reveals that the attached document <testfile.doc> is a text document
in RTF file format.
Comment 6 Oliver-Rainer Wittmann 2009-04-03 14:15:09 UTC
defect cause:
The RTF import filter produces an inconsistent document structure:
It tries to insert only table cells without a table into a text frame. This does
not work and causes the assertion "falscher StartNode" during the RTF import to
pop two times.
The result of this defect is that the content of the text frame on the right is
located inside the document text instead of inside the text frame.

The crash on drag-and-drop of the text frame on the left is caused by the
inconsistent document structure.
I do not know, if this also causes the crash on document close.

OD->HB: Please take over - the RTF filter is your playground ;-)
Comment 7 michael.ruess 2009-04-03 14:20:28 UTC
Adding RTF to summary.
Comment 8 openoffice 2009-07-17 12:26:41 UTC
made summary more specific
Comment 9 openoffice 2009-08-05 14:18:52 UTC
Tried to load the attached file with Word 2007. It was opened as text file
showing the rtf code. Further investigation yields that the rtf is not according
to the format definition.

Setting new target.
Comment 10 Marcus 2017-05-20 11:19:30 UTC
Reset assigne to the default "".