Issue 100686 - wizards: Euro converter wizard don't work when searching for calc documents in a dir
Summary: wizards: Euro converter wizard don't work when searching for calc documents i...
Status: RESOLVED FIXED
Alias: None
Product: Calc
Classification: Application
Component: code (show other issues)
Version: OOo 3.0.1
Hardware: Unknown Windows XP
: P3 Trivial (vote)
Target Milestone: ---
Assignee: nospam
QA Contact: issues@sc
URL:
Keywords: needmoreinfo, oooqa
Depends on:
Blocks: 90439
  Show dependency tree
 
Reported: 2009-03-30 16:40 UTC by oooforum (fr)
Modified: 2013-08-07 15:13 UTC (History)
4 users (show)

See Also:
Issue Type: PATCH
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
This WORKED for me with 1.1.4 (7.89 KB, application/vnd.sun.xml.writer)
2009-04-06 08:24 UTC, Rainer Bielefeld
no flags Details
fix for this (2.31 KB, patch)
2010-06-08 13:00 UTC, caolanm
no flags Details | Diff

Note You need to log in before you can comment on or make changes to this issue.
Description oooforum (fr) 2009-03-30 16:40:28 UTC
1) Run File > Wizards > Euro-converter 
2) Select source and target directory
3) Push [ Convert ] button
The conversion status bar don't progress
No file has been converted

So, it's a defect but this wizard seems to be deprecated. European currencies
are Euro since 2002.
Comment 1 Rainer Bielefeld 2009-04-06 08:18:12 UTC
I also don't get it working with 1.1.4 (German) WIN XP: [645m52 (Build 8824)]"
and attached test document.

@oooforum:
What Platform and OS did you test?
Comment 2 Rainer Bielefeld 2009-04-06 08:24:13 UTC
Created attachment 61402 [details]
This WORKED for me with 1.1.4
Comment 3 Rainer Bielefeld 2009-04-06 08:41:11 UTC
My mistake: Euro converter wizard and "testsource.sxw" WORKS for me with 1.1.4,
but it does not work with 3.0.1 (for a folder containing "testsource.sxw" and
it's source "testsource.odt"

I checked with "Ooo Dev 3.2.0 multilingual version German UI WIN XP: [DEV300m44
(Build 9395)]" and successfully converted "testsource.sxw", but "testsource.odt"
in the same folder has not been converted

This might be a DUP of Issue 97390?
Comment 4 pmladek 2009-05-13 17:16:01 UTC
I still see this problem with OOo-3.1.
Comment 5 caolanm 2010-06-08 13:00:35 UTC
Created attachment 69869 [details]
fix for this
Comment 6 caolanm 2010-06-08 13:04:38 UTC
This is a problem in wizards. When doing a recursive check for file to convert
we use queryTypeByURL on each found file which returns a type name e.g. "calc8",
but we compare against a list of media type, e.g. application/x-starcalc
Somewhere alone the line IIRC the api that wizards used to use was removed and
got half-heartedly converted to the new api. I guess it came unstuck around there. 

I believe this fixes it, definitely didn't work before this fix and works for me
with it.
Comment 7 ingo.schmidt-rosbiegal 2010-06-08 13:38:51 UTC
is -> va: please have a look at this patch.
Comment 8 weko 2010-06-08 13:45:55 UTC
@ih: That's yours. ;-)
Set new target.
Comment 9 ingo.schmidt-rosbiegal 2010-09-02 09:56:13 UTC
This is a patch.
Comment 10 oooforum (fr) 2011-01-27 14:44:56 UTC
When this patch will be integrated?
The status is still set to NEW and not FIXED

Thanks
Comment 11 Martin Hollmichel 2011-03-15 12:50:56 UTC
set target to 3.x since not release relevant for 3.4.
Comment 12 Pedro Giffuni 2011-10-12 18:48:02 UTC
Committed as revision 1182521.

Thanks!