Issue 100730 - Command-` (back-tick) shortcut fails to switch to next window
Summary: Command-` (back-tick) shortcut fails to switch to next window
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOO310m7
Hardware: Mac All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-03-31 17:12 UTC by thatseattleguy
Modified: 2017-05-20 10:35 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description thatseattleguy 2009-03-31 17:12:40 UTC
Canonically in the standard Mac interface, the key shortcut command(cloverleaf)-`(backtick) should 
switch focus to the next open document window within the application. (Identical to control-tab in 
Windows, and the within-app analog to alt-tab or command-tab on the Mac).

This shortcut is important because there is no other way - short of mousing up to the Window menu - 
to switch between active documents.

In OOO310m7, this functionality appears broken. Upon entering the key combination, the next window 
"flashes" up, but then the user is returned to the current window.
Comment 1 thatseattleguy 2009-03-31 17:19:41 UTC
Apologies. Additional testing shows this varies between sub-apps.

For example, command-` changes to "formula view" in Calc, but command-shift-` has partial support 
for switching windows.

In Writer it's command-`, but it only works partially (switches focus between only two  windows, not all 
active windows).

Since the keys are inconsistent they're useless if the user has multiple document types open at the 
same time (since they'd have to switch keys after they determine what kind of document is in the 
currently open window).

Suggesting here that this function is so basic and so important (switching between open document 
windows is about as simple and as necessary a functionality as you can get in an office suite) that it 
should be assigned a consistent and working shortcut by default across all OoO sub-apps in the Mac 
port. I assume control-tab is universal in the Windows port, so that Mac shouldn't be left out.

Comment 2 serent 2009-10-06 02:41:11 UTC
I agree that Command-` should switch windows within OOo. This is the standard
behavior for MacOS apps and is incredibly useful since many people work with
more than one document at a time and need to switch between them.

It was only by viewing this ticket that I discovered Command-Shift-` did
anything similar, however switching windows is a common enough use case that I
think this functionality should be mapped to the simpler Command-`.
Comment 3 Jenny Kieffaber 2013-11-09 21:58:39 UTC
Testing this bug with the environment listed below, I believe this should be updated to Status: OBSOLETE, FIXED, or IRREPRODUCIBLE.  I was able to successfully switch focus between 3 or more windows in the following products: Text Document, Spreadsheet, Presentation, Drawing, and Formula.


Hardware: MAC OSX Version 10.8.5 Build 12F45
Version: AOO401m5(Build:9714)  -  Rev. 1524958
Comment 4 Edwin Sharp 2014-03-03 13:51:20 UTC
Fixed per comment 3