Issue 100897 - Enable simple quotes subsitution by default in AutoCorrection
Summary: Enable simple quotes subsitution by default in AutoCorrection
Status: CONFIRMED
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOO300m9
Hardware: All All
: P3 Minor (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-06 17:21 UTC by nalimilan
Modified: 2015-08-04 10:29 UTC (History)
4 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: 4.1.0-dev
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description nalimilan 2009-04-06 17:21:59 UTC
Typographic rules say that you should use curved single quotes ’ instead of
straight ' as character for apostrophe. This is the recommended use in Unicode,
where U+2019 RIGHT SINGLE QUOTATION MARK (’) is said to be the right char, in
place of U+0027 APOSTROPHE (').

OpenOffice.org is able to do this substitution easily if it's enabled from
Tools->AutoCorrection, "Typographic Quotes" tab, "Simple quotes" area. But that
should be enabled by default; else, most users don't notice this option, and
they get poorly-looking documents, where OO.o can be considered as failing with
respect to MS Office or Abiword 2.8. For now, I always need to enable it when I
install a new system.

So please just turn this feature one by default, that will make many users get
correct documents without noticing it!
Comment 1 eric.savary 2009-04-06 17:36:09 UTC
Reassigned
Comment 2 Edwin Sharp 2014-04-04 08:00:43 UTC
Confirmed with
AOO410m15(Build:9761)  -  Rev. 1583666
2014-04-01 13:50 - Linux x86_64
Debian
Comment 3 Regina Henschel 2015-08-04 10:29:21 UTC
There are principal problems see bug 5839 and bug 22271. Therefore I suggest a "Wontfix".