Issue 100925 - Improved default fonts for CJK on newer windows
Summary: Improved default fonts for CJK on newer windows
Status: CLOSED FIXED
Alias: None
Product: General
Classification: Code
Component: www (show other issues)
Version: OOO310m1
Hardware: All All
: P3 Trivial with 1 vote (vote)
Target Milestone: OOo 3.3
Assignee: Mathias_Bauer
QA Contact: issues@framework
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-07 15:44 UTC by kongnan
Modified: 2017-05-20 10:22 UTC (History)
3 users (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
lucida sans unicode : bad (33.68 KB, image/jpeg)
2009-04-07 15:46 UTC, kongnan
no flags Details
lucida sans unicode : bad (7.73 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-04-07 15:48 UTC, kongnan
no flags Details
snap with wink, watch with flash player. (787.26 KB, application/x-shockwave-flash)
2009-04-09 04:30 UTC, kongnan
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description kongnan 2009-04-07 15:44:30 UTC
(sorry for my poor english)

Lots of chinese characters display incorrectly in "lucida sans unicode".
But that font is default font somewhere. 
For example, Calc's Page header/footer 's font is "lucida".
Shell context menu->new->OOoCalc, the default font is "lucida" too.
Comment 1 kongnan 2009-04-07 15:46:53 UTC
Created attachment 61429 [details]
lucida sans unicode : bad
Comment 2 kongnan 2009-04-07 15:48:31 UTC
Created attachment 61430 [details]
lucida sans unicode : bad
Comment 3 redflagzhulihua 2009-04-09 03:17:59 UTC
Hi kongnan,

For me, Lucida is not the default font. Can you please delete your user profile
and try again?

And make sure you set correct values in settings in Tools-Options-Language
settings-Language.

Or further step, you may need check the locale settings of your OS.

regards,
Lihua
Comment 4 kongnan 2009-04-09 03:58:00 UTC
Hi LiHua, it's the default font SOMEWHERE not EVERYWHERE (sorry for my poor 
english again...), please check the "pageHeader" of Calc, and in os 
contextmenu>new>OOoWriter(not ooocalc: my mistake), Thanks!
btw: OOo langsetting is CHS, Os langsetting is CHS. I manage many pcs.
regards, KongNan

HI LiHua, 很高兴得到您的回复。它不是总是默认字体,而只是有时作为默认字体(我的英文很糟糕,
但我猜想用中文与您沟通会很合适),请检查Calc的页眉等部分,而右键新建一个Writer文档的话其默
认字体也是Lucida(上文提到新建Calc是我的失误)。谢谢!
BTW: OOo语言是简体中文,系统语言也是简体中文,我管理的计算机都是如此。
孔南,2009-04-09
Comment 5 kongnan 2009-04-09 04:30:55 UTC
Created attachment 61467 [details]
snap with wink, watch with flash player.
Comment 6 kongnan 2009-04-09 04:38:43 UTC
in the demo flash, the mouse moving over the "font combo" is to indicate the 
font (but not to change font). i didn't change any font setting during the full 
demo.
Comment 7 redflagzhulihua 2009-04-09 04:45:40 UTC
Hi kongnan,
My header/footer font is Arial Unicode MS. And I didn't find any difference by
create a writer Doc with different ways.
Why CJK font setting is different between header/footer font setting and
document font setting? Interesting.
In my mind, it should be a CJK font at least.

regards,
Lihua
Comment 8 kongnan 2009-04-09 04:59:03 UTC
Have you watched the demo flash? Can we communicate with IM tool? 
QQ,GoogleTalk,MSN...
您是否已经看过了我的演示动画?我们能否用即时通信工具沟通?例如QQ, Google Talk, MSN...
Comment 9 redflagzhulihua 2009-04-09 05:01:32 UTC
And I tried with the font Lucida Sans Unicode. The font display is OK. 
Is there any possibility that your system configuration causes the display problem?
Comment 10 kongnan 2009-04-09 05:13:41 UTC
I'm confused... 
I try many times on many different pcs: winxp, win2k, CRT, LCD, 4:3, 16:9... 
but the result is SAME. 
without m$ office installed. but i always install the latest JRE from 
java.sun.com just before install OOo. I tried to uncheck "Use JRE" in OOo 
option, but it doesn't work too.
can we communicate with IM tool?Thanks

我也很困惑...
我在不同的计算机上尝试过多次:WinXP,2000; 传统显示器,液晶显示器; 4:3, 16:9...但结果都
一样。
机器上没有安装 m$ office. 但我总是在刚要装 OOo 之前,安装从Sun下载的JRE最新版本。我尝试
在OOo选项中禁用JRE,也无效。
我们能用即时通信工具交流吗?谢谢。
Comment 11 redflagzhulihua 2009-04-09 06:06:22 UTC
Sure, zhulihua365@msn.com
Comment 12 merschmann 2009-04-09 09:50:35 UTC
Framework issue.
Please do not block releases with unconfirmed issues.
Comment 13 kongnan 2009-04-13 06:56:22 UTC
I tested other Western fonts and found all of them can't work correctly.
Maybe OOo should use a CJK font as default font for CJK charactors. 


[NOT SURE]Other user may have the same issue, see the following links:
http://www.oooforum.org/forum/viewtopic.phtml?t=82597
http://manchusky.qq.topzj.com/thread-376253-1-3.html
http://bbs.linux-cn.com/thread-5271-1-10.html
Comment 14 amy2008 2009-04-17 08:57:54 UTC
Hi KongNan,
With your attachment file NoLucidaForCJK.ods, I open it in OOo310m9, characters
display correctly with "lucida sans unicode". 

Regards
Li Meiying
Comment 15 blueice7 2009-08-28 04:38:59 UTC
Reassign issue to owner of selected subcomponent.
Comment 16 Mathias_Bauer 2009-11-11 14:00:36 UTC
Herbert, do you have a suggestion for the best possible owner of this issue?
Comment 17 hdu@apache.org 2009-11-11 14:14:21 UTC
If I understand this correctly the complaint is that the default fonts for chinese locales are lacking?

If yes, then please review the configuration file named "VCL.xcu" (either from the installation set or e.g. 
from here
http://hg.services.openoffice.org/DEV300/file/bec9b2b2628f/officecfg/registry/data/org/openoffice/VC
L.xcu) and check the nodes for "zh-cn", "zh-tw", "zh-hk" and "zh-sg". Suggestions for default fonts that 
work well on in all OOo applications on Windows, OSX, Ubuntu, Solaris, etc. would be very appreciated.
Comment 18 Mathias_Bauer 2010-05-14 13:07:50 UTC
I still don't feel that I'm the right owner of this task. 

Could someone please follow the suggestion of hdu?
Comment 19 kongnan 2010-05-19 13:29:29 UTC
In OOo 3, the default font for chinese characters is "Andale Sans UI", but 
still too bad.  T_T
Comment 20 kongnan 2010-05-19 13:46:01 UTC
In "classic" windows, the default font is "宋体".
In "modern" windows, the default font is "微软雅黑".
For your reference. 
Comment 21 kongnan 2010-05-19 13:46:22 UTC
In "classic" windows, the default font is "宋体".
In "modern" windows, the default font is "微软雅黑".
For your reference. 
Comment 22 hdu@apache.org 2010-06-01 12:51:18 UTC
Added MSYaHei (微软雅黑) as default font for CJK locales in CWS vcl112. TNR (宋体) was already there for 
some entries, so these entries were not changed.
Comment 23 kongnan 2010-06-02 07:40:16 UTC
Quote: "TNR (宋体)"
TNR is "Times New Roman". "宋体" is SimSun.
Time New Roman != 宋体. TNR doesn't contain chinese characters.
--------------------------------------------------------------------
Quote:"(宋体) was already there for some entries, so these entries were not 
changed."
I don't quite understand, please make sure all entries contain 宋体 simsun.
Comment 24 hdu@apache.org 2010-06-02 10:14:55 UTC
Ok, so 宋体 translates to SimSun whereas
http://translate.google.de/#zh-CN|en|宋体 suggested that it was TNR.

Please check the zh-* entries in
http://hg.services.openoffice.org/cws/vcl112/file/tip/officecfg/registry/data/org/openoffice/VCL.xcu
Comment 25 hdu@apache.org 2010-06-08 10:06:08 UTC
The changed entries are in CWS vcl112
Comment 26 kongnan 2010-07-21 12:37:35 UTC
Why do we have to specify a font name there? I think use the system default 
font as fall-back will be better.

For example, windows' default font can be found in:
HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\GRE_Initialize\GUIFont.Facename
or HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows 
NT\CurrentVersion\FontSubstitutes