Issue 101049 - Paste Special - less user friendly
Summary: Paste Special - less user friendly
Status: CLOSED DUPLICATE of issue 17563
Alias: None
Product: Writer
Classification: Application
Component: editing (show other issues)
Version: OOo 3.0.1
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: writerneedsconfirm
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks:
 
Reported: 2009-04-13 18:42 UTC by optimizer
Modified: 2009-04-13 22:50 UTC (History)
1 user (show)

See Also:
Issue Type: ENHANCEMENT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description optimizer 2009-04-13 18:42:02 UTC
I had suggessted the paste special menu receive some AI, to sort the most 
commonly used feature to the top, or provide a sort feature. I think this might 
be partially done, maybe not - a manual sort feature may also be good.
But unfortunately, on this release of OO I see that the user experience has 
gone backwards.
I want to be able to Paste Special Unformatted Text (or any other format for 
that matter) in one keystroke (or 1 after an initial setup).
We've moved the other way, and this OO release needs 3 (or more keystrokes) 
actions - Ctrl-V, Paste Special menu, Text Import menu.
Maybe you need all this, but the user needs a single keystroke option too.
1/ Have a paste special (saved options) button, that just does it
2/ Have an "edit special paste settings" option on the edit menu
3/ On the "Paste Special" and the "Text Import" screens, have buttons to save 
this as the paste special setting.

Thank you
Comment 1 Regina Henschel 2009-04-13 20:45:19 UTC
You can define a shortcut of your choice by editing the configuration file. The
command is ".uno:ClipboardFormatItems?SelectedFormat:short=1". Define the
shortcut with anyone command in "customize"-dialog, close OOo, open the
configuration file and exchange the command. For a macro see issue 17563.

I personally do not like to get yet another option in the tool > options
settings, before the dialog is reworked in general. 
Comment 2 eric.savary 2009-04-13 22:49:55 UTC
This is a duplicate of issue 17563.

For a configurable, customizable clipboard, I invite you to oin the ux-discuss
mailing list.

*** This issue has been marked as a duplicate of 17563 ***
Comment 3 eric.savary 2009-04-13 22:50:11 UTC
closed