Issue 101149 - ^. freezes writer (Find & replace)
Summary: ^. freezes writer (Find & replace)
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: code (show other issues)
Version: OOO300m9
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@sw
URL:
Keywords:
Depends on:
Blocks: 84292
  Show dependency tree
 
Reported: 2009-04-17 04:04 UTC by amy2008
Modified: 2013-08-07 14:44 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description amy2008 2009-04-17 04:04:38 UTC
Can reproduce it in OOo310m9 on WinXP and Fedora9

How to reproduce it
1 Create a new Writer file
2 Insert some paragraphs, word number is more than 60000
3 CTRL + F, input '^.' without single quotation marks in the "Search for" text,
  input nothing in the "Replace with" text, click "More options", check 
  "Regular Expressions", then click "Replace All" button

Result
An dialog to turn off the "undo" function is opened, click "Yes" or "Cancle" 
can make OOo freezing, if click "No", dialog shows "Search key replaced 60000 
times"

Expectation
OOo works well
Comment 1 amy2008 2009-04-17 06:28:30 UTC
At step2, word number should be character number
Comment 2 michael.ruess 2009-04-17 10:54:15 UTC
MRU->SBA: please have a look at this "Find & replace" issue. Thanks!

MRU->AMY2008: please file your issues for the default owner. This is
automatically "writerneedsconfirm". Thanks!
Comment 3 merschmann 2009-04-17 12:25:02 UTC
No crash with OOo 3.1RC1 (m9) on Windows XP here.

Comment 4 amy2008 2009-04-20 02:19:11 UTC
Meiying -> MRU, sorry, I will remember it.
Comment 5 amy2008 2009-04-20 03:54:55 UTC
Meiying -> volkerme,
Have you followed the reproduce steps, especally the step2, there is a need of
60000 character numbers.
Would you like checking it once more?
Regards
Li Meiying
Comment 6 stefan.baltzer 2009-04-20 16:40:59 UTC
I produced a Writer document by copy and paste text, no complex doc structure
(No Heading/tables/numberings or objects). 
Tools - Word count: 65110 words and 392502 characters.
I did as described, clicked "Yes" in "Switch off Undo" dialog.
Waited a while...
...and got 392502 replacements (Replace all characters with nothing).
-> This variant works as expected woth OOO310_m9 on WinXP.

Amy2008, can you attach a bugdoc, please?
Comment 7 amy2008 2009-04-22 09:35:38 UTC
sba,
Now, I can't reproduce it neither.
The steps you have done are quite right.
Set workforme

Regards
Li Meiying
Comment 8 stefan.baltzer 2009-04-30 18:29:44 UTC
Thx for re-checking. Closing issue.