Issue 101267 - sum if function
Summary: sum if function
Status: CLOSED DUPLICATE of issue 95144
Alias: None
Product: Calc
Classification: Application
Component: programming (show other issues)
Version: OOo 1.0.3
Hardware: Unknown Windows Vista
: P3 Trivial (vote)
Target Milestone: ---
Assignee: Unknown
QA Contact: issues@sc
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-04-22 11:58 UTC by vishnugolani
Modified: 2009-04-25 11:48 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description vishnugolani 2009-04-22 11:58:05 UTC
i am giving below the formula which working if msoffice2007
=SUM(SUMIFS('C:\privet\2009\[monthly20091trial.xls]JAN-
09'!$C$5:$C$19,'C:\privet\2009\[monthly20091trial.xls]JAN-
09'!$B$5:$B$19,"Oyester"),SUMIFS('C:\privet\2009\[monthly20091trial.xls]JAN-
09'!$C$5:$C$19,'C:\privet\2009\[monthly20091trial.xls]JAN-
09'!$B$5:$B$19,"Oyester 
Topup"),SUMIFS('C:\privet\2009\[monthly20091trial.xls]JAN-
09'!$C$5:$C$19,'C:\privet\2009\[monthly20091trial.xls]JAN-09'!$B$5:$B$19," "))

its doesn't work if open office. instead of sumif i tried following formula
=SUM('file:///C:/privet/open office/monthly09.ods'#$'JAN-09'.B5:B12="*oyster*" * 
'file:///C:/privet/open office/monthly09.ods'#$'JAN-09'.C5:C12)
but its also not working.

i am trying that in current speared sheet i fatch the value of other speared 
sheet.
The result shows #VALUE...
In detail i got three column name date, description, and amount.
i want total of amount with description contains oyster.
Comment 1 Regina Henschel 2009-04-22 15:18:21 UTC
SUMIFS is not implemented yet, see issue 95144. How to workaround the problem is
explained in the chapter function SUM in the help.

Please use a mailing list or forum to get help, how to translate an Excel
expression to Calc. The ways Excel and Calc work differ in some aspects, for
example "wild card" vs. "regular expression".
http://support.openoffice.org/

*** This issue has been marked as a duplicate of 95144 ***
Comment 2 Regina Henschel 2009-04-22 15:19:00 UTC
closing duplicate
Comment 3 vishnugolani 2009-04-24 18:54:40 UTC
can any buddy help me to solve this problem?
Comment 4 frank 2009-04-25 11:47:40 UTC
closing double.

This is not a User Forum but a bugtracking system.
If you need help please use the link provided by Regina for getting support.

Frank

*** This issue has been marked as a duplicate of 95144 ***
Comment 5 frank 2009-04-25 11:48:37 UTC
closed again as double.

Do not re-open as it will again be closed as such.