Issue 101304 - Crash when loading files with circular external references to empty cells
Summary: Crash when loading files with circular external references to empty cells
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: open-import (show other issues)
Version: OOO310m9
Hardware: All All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa, regression
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-04-23 11:28 UTC by niklas.nebel
Modified: 2013-08-07 15:15 UTC (History)
1 user (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
First example file (7.19 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-04-23 11:32 UTC, niklas.nebel
no flags Details
Second example file (7.17 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-04-23 11:33 UTC, niklas.nebel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description niklas.nebel 2009-04-23 11:28:32 UTC
If a file is loaded that has a formula reference to an empty cell in another
file, the source file is loaded without asking. If the source file has a formula
reference to an empty cell in the first file, this is repeated until memory runs
out.

Example files are attached.
Comment 1 niklas.nebel 2009-04-23 11:32:34 UTC
Created attachment 61755 [details]
First example file
Comment 2 niklas.nebel 2009-04-23 11:33:38 UTC
Created attachment 61756 [details]
Second example file
Comment 3 merschmann 2009-04-23 20:43:31 UTC
Worked in 3.0.0 - WinXP
Comment 4 niklas.nebel 2009-04-24 16:24:37 UTC
Fixed in CWS "calclinkfixes".
Comment 5 niklas.nebel 2009-04-27 11:47:00 UTC
reassigning to QA for verification
Comment 6 niklas.nebel 2009-05-19 15:35:15 UTC
taking the issue back for fixing in 3.1.1
Comment 7 niklas.nebel 2009-05-19 16:42:32 UTC
Also fixed in CWS "calc311fixes", for 3.1.1.
Comment 8 niklas.nebel 2009-05-26 18:56:42 UTC
reassigning to QA for verification
Comment 9 oc 2009-05-28 08:55:45 UTC
verified in internal build cws_calc311fixes (OOo311) and 
verified in internal build cws_calclinkfixes (OOo32)
Comment 10 thackert 2009-08-08 15:45:58 UTC
Hello nn, *,
I have tested this with OOO310m18 (3.1.1 RC1) under Debian SID AMD64, where this
issue is fixed. @nn: Could you verify (and close it) as well, if it is fixed on
your system?
TIA
Thomas.
Comment 11 thackert 2009-08-11 18:15:20 UTC
Hello nn, *,
as you do not answer (and it works for me), I close this issue. If you still can
reproduce your issue, feel free to reopen it again ... ;)
Have fun
Thomas.