Issue 101312 - WW8: MS Word 2003 doc - hugh memory leak while loading
Summary: WW8: MS Word 2003 doc - hugh memory leak while loading
Alias: None
Product: Writer
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0.1
Hardware: PC Windows, all
: P2 Trivial (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: oooqa
Depends on: 33737
  Show dependency tree
Reported: 2009-04-23 23:47 UTC by jezzper
Modified: 2017-05-20 11:13 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

An example MS Word document which shows the issue (178.50 KB, text/plain)
2009-04-24 08:03 UTC, jezzper
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jezzper 2009-04-23 23:47:32 UTC
Trying to import a very simple MS Word 2003 document causes Writer to eat away
memory very fast. Uses several GB within a few minutes.

The document only contains a few characters, a picture and a Form field.      

The import does not succeed and Writer just continues to use more and more RAM
until the hole OS becomes unresponsive, because of the memory use.
Comment 1 eric.savary 2009-04-24 00:07:06 UTC
Which OS?
Which document (please attach it here)?
Not a P1.
Comment 2 jezzper 2009-04-24 08:03:59 UTC
Created attachment 61771 [details]
An example MS Word document which shows the issue
Comment 3 jezzper 2009-04-24 08:39:36 UTC
I have had the issue on version 3.00, 3.01 and in Lotus Symphony which is bassed
on OO on XP.

I have tried opening it on Ubuntu with OO 2.4 and it worked fine.

Comment 4 eric.savary 2009-04-24 16:49:48 UTC
Yes, it's a huge one!
Reproduces in 310m8 on Vista.
Machine was not answering during several minutes.
Comment 5 Oliver-Rainer Wittmann 2009-04-30 10:33:08 UTC
Investigation reveals that the graphic is anchored as-character inside the
<Formtext> field.
This is currently not supported by OOo Writer.

I assume that the version on the tested Ubuntu system is the one
from Novell, which already has the enhanced field support enabled.

Please take over as you are/will be working together with Florian Reuter from
Novell to bring the latest stuff of the enhanced field support into OOo.
Comment 6 flr 2009-04-30 10:47:29 UTC
I tested it with my latest patched and it work fine. I've started creating a CWS
field01 where I plan to upload the latest patches...
Comment 7 bjoern.michaelsen 2009-08-28 18:00:05 UTC
retargeting 3.3
Comment 8 hans_werner67 2011-02-03 12:08:34 UTC
pls. reassign or close issues.
Comment 9 Mathias_Bauer 2011-03-28 16:09:11 UTC
As we still didn't activate the buggy code for field support, there is no reason to work on this problem anytime soon.
Comment 10 Marcus 2017-05-20 11:13:43 UTC
Reset assigne to the default "".