Issue 101512 - Structure tab in function-wizard is empty (only for function IF)
Summary: Structure tab in function-wizard is empty (only for function IF)
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOo 3.1 RC2
Hardware: All All
: P3 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: oooqa, regression
: 101775 (view as issue list)
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-05-03 19:09 UTC by jr
Modified: 2013-08-07 15:15 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
structure tab in OOo 3.0 - OK (10.45 KB, image/png)
2009-05-03 19:10 UTC, jr
no flags Details
structure tab in OOo 3.1 - NOT OK (9.26 KB, image/png)
2009-05-03 19:11 UTC, jr
no flags Details
Small test doc (6.53 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-05-03 19:12 UTC, jr
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description jr 2009-05-03 19:09:54 UTC
Tested with 3.1.0 RC 2, Linux and WinXP

If a formula contains an IF-function, the structure-tab in the function-wizard
only shows ")" and not the correct structure.

This was ok in 3.0.1. I will attach screenshots and a small test doc.
Comment 1 jr 2009-05-03 19:10:57 UTC
Created attachment 61959 [details]
structure tab in OOo 3.0 - OK
Comment 2 jr 2009-05-03 19:11:44 UTC
Created attachment 61960 [details]
structure tab in OOo 3.1 - NOT OK
Comment 3 jr 2009-05-03 19:12:20 UTC
Created attachment 61961 [details]
Small test doc
Comment 4 jr 2009-05-03 19:29:48 UTC
Adding keywords
Comment 5 niklas.nebel 2009-05-07 12:52:48 UTC
taking the issue
Comment 6 niklas.nebel 2009-05-07 12:53:57 UTC
Fixed in CWS "calc50" (rev. 271660, 271661).
Comment 7 niklas.nebel 2009-05-11 17:35:53 UTC
*** Issue 101775 has been marked as a duplicate of this issue. ***
Comment 8 niklas.nebel 2009-05-11 17:45:41 UTC
Also in CWS "calc311fixes", for 3.1.1.
Comment 9 niklas.nebel 2009-05-26 18:56:29 UTC
reassigning to QA for verification
Comment 10 oc 2009-05-29 14:10:44 UTC
verified in internal build cws_calc311fixes (OOo311) and
verified in internal build cws_calc50 (OOo32)
Comment 11 thackert 2009-08-08 16:29:32 UTC
Hello jrahemipour, *,
I have tested it under Debian SID AMD64 and the Germanophone version of
OOO310m18. This issue seems to be fixed. Could you test it again under WinXP,
please?
HTH
Thomas.
Comment 12 jr 2009-09-11 15:15:30 UTC
Checked in 3.1.1 -> fixed -> closing