Issue 10154 - Bold text does not stay formatted (something to do with formatting to eol)
Summary: Bold text does not stay formatted (something to do with formatting to eol)
Status: CLOSED IRREPRODUCIBLE
Alias: None
Product: Writer
Classification: Application
Component: ui (show other issues)
Version: OOo 1.0.1
Hardware: PC Windows ME
: P3 Trivial (vote)
Target Milestone: ---
Assignee: h.ilter
QA Contact: issues@sw
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2002-12-17 10:07 UTC by Unknown
Modified: 2013-08-07 14:42 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description Unknown 2002-12-17 10:07:47 UTC
I have a document where selecting text and setting to bold (either CTRL-B or 
hitting the Bold toolbar button) sets the text, as you would expect, to bold.

However, when you save, close and then re-open the document the text is no 
longer bold.

There IS bold text in the document.  It started life as a Word document.
I am saving the document in Word format.

Ah - interesting - I have just tried setting _part_ of a line to bold, and this 
has saved fine.

<back in a mo>

Oooh!  This seems to be something to do with trying to run the bold format to 
the end of the line (I have not tried any other format settings).

What I did:
1.
Highlight a whole line.
Format as bold
Save
Exit
Reopen
line is NOT bold.

2.
add SPACE to end of line
highlight line up to the SPACE (NOT including the SPACE)
format as bold
save
exit
re-open
ta daaaa - the text is still bold

3.
so for fun I:
removed the space from the end of the line (with the text still bold)
save
exit
re-open
the text is still bold.

I also had the same problem when trying to go from bold to plain!

HTH, sorry to go on but just trying to give as much info as poss.

Let me know if you want more info.

Cheers
Guy
guy.rossler@ntlworld.com
Comment 1 h.ilter 2003-01-13 14:20:48 UTC
In cause of that I can't reproduce, please provide me a bugdoc, thanks.
Comment 2 Unknown 2003-03-20 08:30:09 UTC
Hi, sorry for not looking at this again quickly, I had a message 
saying you could not reproduce the problem.

Try this:
I was saving the document in MS Office format.

As soon as I changed to saving in the native Openoffice format all 
works fine.

So, if you set up a document to save as MS Word format and follow the 
steps below, hopefully, you will see the problem (famous last words!!)

Let me know if you need any more info.

Regards
guy
Comment 3 prgmgr 2003-06-20 15:37:21 UTC
Guy, thank you for using and supporting OOo.

Please attach the original OOo document that consistently reproduces
this problem.
Comment 4 prgmgr 2003-06-20 15:46:27 UTC
*** Issue 12128 has been marked as a duplicate of this issue. ***
Comment 5 prgmgr 2003-06-20 15:49:27 UTC
Guy, this problem has been resolved in 1.1 Beta 2.

It should be in 1.1 release.


Closing this issue for now.  If the problem persists, feel free to
reopen this issue.
Comment 6 prgmgr 2003-06-20 15:49:38 UTC
.