Issue 101555 - Incorrect default CJK font when create document with context menu
Summary: Incorrect default CJK font when create document with context menu
Status: CLOSED DUPLICATE of issue 58014
Alias: None
Product: General
Classification: Code
Component: code (show other issues)
Version: OOo 3.1 RC2
Hardware: All Windows, all
: P3 Trivial with 1 vote (vote)
Target Milestone: ---
Assignee: stefan.baltzer
QA Contact: issues@framework
Keywords: CJK
Depends on:
Reported: 2009-05-05 09:12 UTC by redflagzhulihua
Modified: 2009-07-29 16:35 UTC (History)
8 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Note You need to log in before you can comment on or make changes to this issue.
Description redflagzhulihua 2009-05-05 09:12:13 UTC
Create an OOo Document with context menu(eg, right click on the desktop > New > 
Open Office Text Document)
Open the document
You can see the default font is not a CJK font. Format > Character..., In the 
Character dialog, you can see CJK font setting is not correct.

But if you create a document via Start > Programs > 3.1 > Writer, the CJK font is correct.
Comment 1 redflagzhulihua 2009-05-05 09:13:33 UTC
This reproduced in OOo3.1 RC2. 
Comment 2 amy2008 2009-05-08 08:50:04 UTC
The ID of the error report is r8nfqkc
Comment 3 amy2008 2009-05-08 08:55:23 UTC
Writer in the wrong issue, sorry
------- 附加注释人: amy2008 2009/05/08 07:50:04 +0000 -------

The ID of the error report is r8nfqkc

Comment 4 stefan.baltzer 2009-06-09 13:47:30 UTC
SBA->redflagzhulihua: Any hints if this ever worked different?
Reassigned to me.
Comment 5 stefan.baltzer 2009-06-09 17:48:32 UTC
Thanks to Rene for mentioning this debian issue:
Comment 6 redflagzhulihua 2009-06-10 03:36:35 UTC
Hi Stefan,
As far as I can dig out, this never worked correctly since OOo2.3. I havn't
earlier version by hand.
In OOo2.3, OOo2.4, OOo3.0: the Heading font is MS Mincho, others are Arial
Unicode MS
In OOo3.1, all the fonts are set to Andale Sans UI
Comment 7 redflagzhulihua 2009-06-10 03:41:53 UTC
The font settings I mentioned above are lies in:
Writer-Basic Fonts(Asia)
Comment 8 2009-06-10 06:36:43 UTC
I just confirmed the same thing happens in the latest Korean version(3.1.0). The
new document created from Windows Explorer has 'Andale Sans UI' instead of user
defined Asian font.
Comment 9 2009-06-10 09:02:42 UTC
This issue seems to be a duplication of issue 40223 (at least for Windows). Once
issue 40223 is solved then Windows shell will use the same template as and it will solve the font problem described here.

@redflagzhulihua: Take a look at my comment and mark this issue as duplication,
if you agree on that.
Comment 10 redflagzhulihua 2009-06-10 09:32:11 UTC
@jeongkyu: Thank you, I agree with you.

@sba: What's your opinion?
Comment 11 maho.nakata 2009-06-14 20:37:28 UTC
Hi zhulihua, 
matayoshi-san reported as follows [1]:

* he reproduced this problem on 3.1.0(OOO310m11)
for Writer,Calc,Impress,Draw.
* when he tries to create a new files by right click, the default font for Japanese
was "Andale sans UI"
* similar problem has been discussed in ja community forum:

Comment 12 michael.ruess 2009-07-29 16:29:35 UTC
Root cause is issue 58014.

*** This issue has been marked as a duplicate of 58014 ***
Comment 13 michael.ruess 2009-07-29 16:35:42 UTC
Closing duplicate.