Issue 101558 - Confirm Password for a Protected Document unintuitive
Summary: Confirm Password for a Protected Document unintuitive
Status: CLOSED DUPLICATE of issue 99885
Alias: None
Product: ui
Classification: Code
Component: ui (show other issues)
Version: OOO310m11
Hardware: All Windows, all
: P4 Trivial (vote)
Target Milestone: ---
Assignee: spreadsheet
QA Contact: issues@ui
URL:
Keywords: oooqa
Depends on:
Blocks:
 
Reported: 2009-05-05 09:48 UTC by ishaq_azad
Modified: 2009-05-05 10:28 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments

Note You need to log in before you can comment on or make changes to this issue.
Description ishaq_azad 2009-05-05 09:48:05 UTC
After Entering the password for password protected ODF SpreadSheet, one has to 
click on the OK button to validate the password. In earlier versions of 
OpenOffice such as 2.4.2 when you press 'Enter' the password validation process 
starts. In recent versions of OpenOffice (3.0 upwards) this defect could be 
found. Basically after entering the password the OK button has to be clicked, 
And the 'Enter' does NOT start the password validation process.
Comment 1 Rainer Bielefeld 2009-05-05 10:18:29 UTC
Not a special CALC problem
You can reproduce the problem easily:

0. Create new sample document "sample.odt" (I do from OOo File menu, 
   OOo dialogue) and save it with PW protection, PW "abcdefg". Close document!
1. Menu "File -> Recent Documents -> "sample.odt"
   Password dialogue appears
2. Insert password "abcdefg"
3. Press <Enter>
   expected: PW should be checked, document should be opened
   actual: nothing, caret remains flickering behind password.

Known problem! DUP of Issue 100962, which itself is a DUP of Issue 99885
Fixed for 3.2!

*** This issue has been marked as a duplicate of 100962 ***
Comment 2 Rainer Bielefeld 2009-05-05 10:26:02 UTC
Wrong issue
Comment 3 Rainer Bielefeld 2009-05-05 10:26:58 UTC
DUP of Issue 99885

*** This issue has been marked as a duplicate of 99885 ***
Comment 4 Rainer Bielefeld 2009-05-05 10:28:37 UTC
.