Issue 101563 - OOo crashes when opening .pptx presentation
Summary: OOo crashes when opening .pptx presentation
Status: CLOSED FIXED
Alias: None
Product: Impress
Classification: Application
Component: open-import (show other issues)
Version: OOo 3.0.1
Hardware: Unknown Linux, all
: P2 Trivial (vote)
Target Milestone: OOo 3.2
Assignee: wolframgarten
QA Contact: issues@graphics
URL:
Keywords:
: 101074 114154 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-05-05 12:03 UTC by mnasato
Modified: 2017-05-20 10:22 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
PowerPoint 2007 presentation (409.47 KB, application/vnd.openxmlformats-officedocument.presentationml.presentation)
2009-05-05 12:05 UTC, mnasato
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description mnasato 2009-05-05 12:03:45 UTC
OOo 3.0.1 (and 3.1rc2 too) on Linux crashes when opening the attached .pptx
presentation.

(OOo 3.0.1 on Windows doesn't seem to crash, although the presentation is
missing various pieces shown in PowerPoint 2007.)
Comment 1 mnasato 2009-05-05 12:05:56 UTC
Created attachment 61996 [details]
PowerPoint 2007 presentation
Comment 2 wolframgarten 2009-05-05 12:13:23 UTC
Reproducible. Reassigned.
Comment 3 sven.jacobi 2009-05-11 11:18:21 UTC
Accepted, loading this document on linux leads to a crash, on windows everything
is fine.
Comment 4 sven.jacobi 2009-05-13 14:06:02 UTC
This issue has been fixed now in cws[impress171] in
sd/source/ui/unoidl/unopback.cxx -rev 271862
Comment 5 mnasato 2009-05-13 14:18:38 UTC
Thanks for the quick fix!
Comment 6 sven.jacobi 2009-05-18 15:23:59 UTC
*** Issue 101074 has been marked as a duplicate of this issue. ***
Comment 7 sven.jacobi 2009-06-04 10:08:28 UTC
sj->wg: now Nelson can be loaded without problems.
Comment 8 wolframgarten 2009-06-05 12:08:37 UTC
Verified in CWS.
Comment 9 caolanm 2009-06-30 08:56:40 UTC
seen m51, closing
Comment 10 Joe Smith 2009-07-16 18:27:37 UTC
Testing: DEV300_m52 on Fedora Linux 11

Opening the .pptx file leads to hang at 100% cpu for at least several minutes
until I manually kill soffice.bin.

I see a plain crash on opening the file in OOo 3.1.
Comment 11 wolframgarten 2009-07-17 08:25:04 UTC
Reopened.
Comment 12 wolframgarten 2009-07-17 08:25:58 UTC
@sj: could you please have a look if the fix arrived in the master?
Comment 13 wolframgarten 2009-07-21 08:56:27 UTC
Reassigned.
Comment 14 sven.jacobi 2009-07-21 11:18:30 UTC
Indeed, there was a merge problem in sd/source/ui/unoidl/unopback.cxx which I
now have been fixed in cws[impress174].
Comment 15 sven.jacobi 2009-08-21 11:48:07 UTC
this issue is ready to be verified
Comment 16 wolframgarten 2009-08-26 14:22:43 UTC
Verified in CWS.
Comment 17 sven.jacobi 2010-08-31 13:54:25 UTC
*** Issue 114154 has been marked as a duplicate of this issue. ***