Issue 101593 - WW8: tables structure from 2.x OOo versions wrecked at export
Summary: WW8: tables structure from 2.x OOo versions wrecked at export
Status: CLOSED FIXED
Alias: None
Product: Writer
Classification: Application
Component: save-export (show other issues)
Version: OOo 3.1 RC2
Hardware: All All
: P2 Trivial with 2 votes (vote)
Target Milestone: ---
Assignee: michael.ruess
QA Contact: issues@sw
URL: http://user.services.openoffice.org/e...
Keywords: regression
: 101689 103524 (view as issue list)
Depends on:
Blocks:
 
Reported: 2009-05-06 10:04 UTC by hagar_de_lest
Modified: 2013-08-07 14:43 UTC (History)
4 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
Original file (9.26 KB, application/vnd.oasis.opendocument.text)
2009-05-06 10:05 UTC, hagar_de_lest
no flags Details
Exported file to .doc (12.50 KB, application/msword)
2009-05-06 10:05 UTC, hagar_de_lest
no flags Details
Exported doc saved back to ODF (8.88 KB, application/vnd.oasis.opendocument.text)
2009-05-06 10:06 UTC, hagar_de_lest
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description hagar_de_lest 2009-05-06 10:04:39 UTC
With 3.1 (final release) on W2k.

If I create a table with an AutoText made with 2.x OOo version, when exported to
.doc, the table loses some formatting but is visible with MS Word 2003.
- If I open it with OOo 2.4.1, the table layout is changed
- If I open it with OOo 3.1, the table is partly invisible. In the Navigator, I
can see that additional tables have been created. If I delete a table and undo
that action, I can see the table fine!

If I create the same table layout in 3.1, no problem. If I copy an 'old' table
in the document, same problem as the original AutoText table.

Here are 3 attachments:
- Tables.odt is the original document with a table inserted by AutoText, another
copied and pasted from that one and a 3rd made in 3.1
- Tables.doc is the exported version
- Tables doc saved in ODF.odt is the .doc version above opened with OOo 3.1 and
saved back to .odt

Note that there is no dataloss because the content.xml file from the Tables doc
saved in ODF.odt version still has the data but it's very difficult to retrieve
them from OOo.
Comment 1 hagar_de_lest 2009-05-06 10:05:09 UTC
Created attachment 62048 [details]
Original file
Comment 2 hagar_de_lest 2009-05-06 10:05:42 UTC
Created attachment 62049 [details]
Exported file to .doc
Comment 3 hagar_de_lest 2009-05-06 10:06:17 UTC
Created attachment 62050 [details]
Exported doc saved back to ODF
Comment 4 hagar_de_lest 2009-05-06 17:10:00 UTC
Added a link to a thread in Community forum (URL field).

The MS Word version seem to have an influence. No such issue if edited by MS
Word 2000.
Comment 5 michael.ruess 2009-05-06 19:09:08 UTC
MRU->HBRINKM: as described, export attached document to WW8 format, reopen ->
now 5 instead of 3 tables are available and the structure is messed up.
Comment 6 openoffice 2009-06-18 15:35:54 UTC
Analysis: 
- The new table export supports nested tables.
- The first two tables use the old table model in ODT and are hence exported as nested tables by the new export.
- This results in the intendedly increased number of tables.
- The structure of the nodes array is correct after import.
- The layout frames for the nested tables seem to be missing.
- The third table uses the new table model in ODT and is hence exported as non-nested table.
Comment 7 openoffice 2009-06-29 12:48:33 UTC
Sending        source/core/layout/tabfrm.cxx
Committed revision 273471.
Comment 8 openoffice 2009-07-01 10:18:08 UTC
Ready for QA (CWS mav53)
Comment 9 thorsten.martens 2009-07-07 12:50:22 UTC
reassigned to appropiate QA-member
Comment 10 michael.ruess 2009-07-07 14:47:37 UTC
Verified in CWS mav53.
Comment 11 openoffice 2009-07-16 16:41:54 UTC
*** Issue 101689 has been marked as a duplicate of this issue. ***
Comment 12 majukr05 2009-07-21 22:47:22 UTC
Tested with OOo-dev 3.1.1 [OOO310_m16 – Build:9413] / WinXP
[CWS mav53 integrated]

... works fine ...
Comment 13 michael.ruess 2009-07-22 07:13:35 UTC
Closin issue, works in 300m53 and 310m16.
Comment 14 openoffice 2009-07-23 10:20:49 UTC
*** Issue 103524 has been marked as a duplicate of this issue. ***
Comment 15 helgekraak 2009-07-23 10:23:05 UTC
Just in case this is related to: http://qa.openoffice.org/issues/show_bug.cgi?
id=54832

Maybe you can fix this issue as well. Thanks!