Issue 101725 - Drag&Drop takes 45 seconds and GUI does not redraw. It finally causes OOo to crash.
Summary: Drag&Drop takes 45 seconds and GUI does not redraw. It finally causes OOo to ...
Status: CLOSED FIXED
Alias: None
Product: Calc
Classification: Application
Component: editing (show other issues)
Version: OOO310m11
Hardware: PC All
: P2 Trivial (vote)
Target Milestone: ---
Assignee: oc
QA Contact: issues@sc
URL:
Keywords: regression
: 101802 103326 (view as issue list)
Depends on:
Blocks: 101565
  Show dependency tree
 
Reported: 2009-05-10 13:32 UTC by Stefan Weigel
Modified: 2013-08-07 15:15 UTC (History)
3 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---


Attachments
bugdoc mentioned in bug description (32.32 KB, application/vnd.oasis.opendocument.spreadsheet)
2009-05-10 13:34 UTC, Stefan Weigel
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description Stefan Weigel 2009-05-10 13:32:21 UTC
When your document contains a Datapilot, Drag&Drop gets unusable. It finally
causes OOo to crash. This is a very strange behaviour. Please follow these steps
in order to reproduce the bug:

I´ll attach a bugdoc for easy reproduction of the bug. However, the bug is *not*
related to this special document. It seems the bug occurs with any document,
that contains a Datapilot based on a certain minimum amount of data.

First with Windows 2000:

(1) Open the bugdoc.
(2) Select some cell range inside the Datapilot.
(3) Use Drag&Drop and the CTRL-Key in order to copy and paste the selected cells
to somewhere else.

Up to now, everything is fine.

(4) Select some other cell range. This time your selection does not need to be
inside the Datapilot but can be any cell range within your document.
(5) Again, use Drag&Drop and the CTRL-Key in order to copy and paste the
selected cells to somewhere else.

Now, after performing Drag&Drop for a second time, the application freezes for
30 to 60 seconds. After that, Drag%Drop has been executed, but the GUI does not
redraw. You will have to scroll the sheet forward and back in order to force
redrawing, so that you can see the result.

(6) Close the document.
(7) OOo freezes and/or crashes.

It is slightly different with Ubuntu Linux 8.10:

(1) Open the bugdoc.
(2) Select some cell range inside the Datapilot.
(3) Use Drag&Drop and the CTRL-Key in order to copy and paste the selected cells
to somewhere else.

Up to now, everything is fine.

(4) Select some other cell range. This time your selection does not need to be
inside the Datapilot but can be any cell range within your document.
(5) Again, use Drag&Drop and the CTRL-Key in order to copy and paste the
selected cells to somewhere else.

(6) OOo freezes and/or crashes.
Comment 1 Stefan Weigel 2009-05-10 13:34:10 UTC
Created attachment 62140 [details]
bugdoc mentioned in bug description
Comment 2 Stefan Weigel 2009-05-10 13:36:42 UTC
This bug is new in OOo 3.1  --> regression
Comment 3 oc 2009-05-11 12:22:56 UTC
Hi Niklas, please have a look
Comment 4 niklas.nebel 2009-05-11 17:51:35 UTC
Fixed in CWS "calc311fixes" (for 3.1.1) and "calc50" (for 3.2).
Comment 5 niklas.nebel 2009-05-12 09:49:49 UTC
*** Issue 101802 has been marked as a duplicate of this issue. ***
Comment 6 niklas.nebel 2009-05-12 11:21:46 UTC
*** Issue 101802 has been marked as a duplicate of this issue. ***
Comment 7 niklas.nebel 2009-05-26 18:56:14 UTC
reassigning to QA for verification
Comment 8 oc 2009-06-02 14:31:02 UTC
verified in internal build cws_calc311fixes (OOo311) and
verified in internal build cws_calc50 (OOo32)
Comment 9 niklas.nebel 2009-07-07 09:36:40 UTC
*** Issue 103326 has been marked as a duplicate of this issue. ***
Comment 10 Stefan Weigel 2009-08-23 20:04:37 UTC
Ok in OOo 3.1.1 rc2 OOO310m19
closing.