Issue 101742 - Mouse wheel doesn't work when set to "One screen at a time"
Summary: Mouse wheel doesn't work when set to "One screen at a time"
Alias: None
Product: General
Classification: Code
Component: ui (show other issues)
Version: OOo 3.3
Hardware: PC Windows Vista
: P3 Trivial with 3 votes (vote)
Target Milestone: ---
Assignee: AOO issues mailing list
QA Contact:
Keywords: needmoreinfo, oooqa
Depends on:
Reported: 2009-05-11 08:31 UTC by fudus
Modified: 2013-01-29 21:52 UTC (History)
2 users (show)

See Also:
Issue Type: DEFECT
Latest Confirmation in: ---
Developer Difficulty: ---

Mouse wheel settings (28.74 KB, image/png)
2010-02-13 13:47 UTC, fudus
no flags Details

Note You need to log in before you can comment on or make changes to this issue.
Description fudus 2009-05-11 08:31:14 UTC
Using OO 3.1. Go to mouse properties then the wheel tab. Select "One Screen at 
a time" radio button then click OK.

Open a new document in Writer. Try to scroll down using the mouse wheel. 
Nothing happens.

Go back to Mouse properties. Select "The following number of lines a time". Hit 
OK. Try to scroll again in blank document in writer.  Works as expected.

Desired result is that when "One screen at a time" is selected, it scrolls down 
one whole page, like hitting page down/up. Worked fine in 3.0x previous version.

Previous version (3.0.2 i think) worked fine. Only began when I upgraded to 3.1.
Comment 1 eric.savary 2009-05-11 09:14:01 UTC
Does this happen in other appa (Calc, Draw) then Writer?
Comment 2 fudus 2009-05-11 09:26:48 UTC
Calc scrolls one line a time.

Impress scrolls, but not a whole page at a time.

Draw scrolls one a time only too.

Works properly in Math.
Comment 3 kpalagin 2009-05-12 19:34:57 UTC
Confirming - before 3.1 blank text doc was scrollable if "one scren at a time" 
was selected. With 3.1 it would not scroll.
Comment 4 michael.ruess 2009-05-19 09:15:06 UTC
I can confirm that in a one page document the "One Screen at a time" does not
have any effect when trying to scroll. When having more pages, it scrolls to the
beginning of every page as expected.
But did it really scroll to the page end (in a single-page-doc) in older
versions? I will try out later.
Comment 5 fudus 2009-05-19 09:22:08 UTC
It scrolled at least in the proper direction. Last version I used was 3.0.x.
Comment 6 eric.savary 2009-06-18 02:25:48 UTC
It works fine *in Writer* after restarting OOo.
Found out that it doesn't seem to work even after restert in Calc and Draw...
Comment 7 eric.savary 2009-06-18 02:26:49 UTC
*** Issue 90907 has been marked as a duplicate of this issue. ***
Comment 8 fudus 2010-02-13 13:43:24 UTC
Just downloaded 3.2 final. Same error as before.

When there are multipage pages in writer, the scroll bar goes down to the next 
page of document, not the next screen as it should.
Comment 9 fudus 2010-02-13 13:47:46 UTC
Created attachment 67804 [details]
Mouse wheel settings
Comment 10 fudus 2010-03-17 10:19:01 UTC
For clarification, with the mouse settings as

With one page only in writer, scrolling with the wheel does nothing.

With more than one page, it goes to the next page of the document, not the next 
view, like what happens when you use page up/down keys.

Expected results: with these settings, the mouse wheel scrolling should behave 
the same way as using page up/down keys.
Comment 11 fudus 2010-06-08 03:07:13 UTC
Still there in 3.2.1 build 9502
Comment 12 fudus 2010-11-03 12:44:35 UTC
Exact same problem in 3.3 RC3. It has been a year, will this ever be fixed?
Comment 13 fudus 2011-01-05 18:53:39 UTC
Still the same with RC8
Comment 14 fudus 2011-02-28 11:36:58 UTC
Still in the final version of 3.3.